System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Remoting CDE to Linux HPUX-11.0

bill-clayton
Advisor

Remoting CDE to Linux HPUX-11.0

I have a bare bones (almost) HPUX 11.0 -9000 system. I have successfully remoted X applications and all "dt..." x-like applications to a Linux computer on the same LAN. Am not concerned with security now as it is isolated LAN for development. I have not been able to remote CDE login, or the CDE desktop to Linux. I have searched via Google and the knowledge base but no help so far.

Herev are some things I have done:
/usr/dt/config/Xaccess
Made sure one line said "*"
Entered a line under %hostline with an IP of 10.51.201.157 on it. That is my Linux IP addr.

/usr/dt/config/Xconfig -- used all defaults here

Made several changes to xfs stuff I found on a previous ITRC forum discussion. Most of mine were ther. Perhaps the most important is that /usr/dt/config/xfonts/C is in the 'catalog line'.

If i try to start/stop xfs I get a usage error as follows:
xfs [-config config_file] [-port tcp_port] [-daemon]
What is all of this for??

By the way I can run and am using the following remoted to my Linux box:
xterm
hpterm
xclock
dtcalc
and they all work fine. I've had as many as five xterm's opened at once. So the remote X thing works, but not CDE remote login.

Also I tried to run /usr/dt/bin/dthello and received three errors concerning fonts, one of which said the DISPLAY 10.51.201.157:0.0 did not have access to the font "fixed". Huh??

So in summary remoting most X apps seems to work -- I even have been using SAM, but not CDE login screen and CDE desktop.

Please DO NOT say to use Putty or SSH. I have neither on the HPUX computer and will not be able to put them there for other reasons. I know that SSH should clear this up easily, but I cannot use it -- at least right now.
Thanks for any help you may provide.
bc
3 REPLIES
Matti_Kurkela
Honored Contributor

Re: Remoting CDE to Linux HPUX-11.0

The problem with the font "fixed" might be because 11.00-era CDE probably wants to use fonts with HP Roman-8 character set by default. Your Linux will most likely have the font "fixed" only with Unicode or ISO-8859-* character sets, depending on the age of the distribution (modern ones tend to favor Unicode, which I think is not understood by 11.00 CDE at all).

In other words, the basic font "fixed" your system needs to display the CDE on Linux would be identified with X font specification like:
-*-fixed-*-*-*-*-*-*-*-*-*-*-hp-roman8

...while your Linux system most likely has fonts like:
-*-fixed-*-*-*-*-*-*-*-*-*-*-iso8859-*
or
-*-fixed-*-*-*-*-*-*-*-*-*-*-iso10646-1
(the latter is used with UTF-8 Unicode)

You can use the old utility "xfontsel" to see which fonts your Linux system has available. It is typically in a package named "x11-utils" or something similar.

HP-UX CDE also requires some other fonts to look correct: if some critical fonts are missing, CDE won't start at all. With other fonts missing, it will just look bad.

Your xfs troubles might be because something is mistyped in /etc/rc.config.d/xfs on HP-UX, or you're not using the right command to start it ("sh /sbin/init.d/xfs start" should do it if /etc/rc.config.d/xfs is correct).

If possible, make sure the X font server (xfs) is running on HP-UX, then use the "xset +fp=tcp/:7100" command on the Linux system to make it use the fonts from HP-UX's font server in preference to anything else (this may be somewhat disruptive to your Linux apps; you can tweak this later, once you get CDE working).

To get a real remote CDE login on Linux, you have to either drop your Linux to text-based console mode and re-start the X server using "X -query " so the remote CDE will be the only GUI on your Linux virtual console, or use a nested X server (Xnest/Xephyr) and specify a non-default DISPLAY value, e.g.

Xephyr :1.0 -query

The latter approach should get you the HP-UX CDE desktop in a window within your Linux desktop.

MK
MK
bill-clayton
Advisor

Re: Remoting CDE to Linux HPUX-11.0

Matti, thanks for the advice. I think one thing might be wrong. Instead of xset +fp, I used fp+ which makes the fonts from my HPUX box show up last in the list on my Linux box when I do xset -q. It shows as tcp/HPUX_IP addr.

I tried what you said for starting CDE from a console shell with no luck. However if I execute something like /usr/dt/bin/dthello even from X on Linux via an Xterm back to HPUX, I get the full transition screen for what would be a normal dtlogin I think. I then use another Xterm and kill it. So this tells me my X-display is remoted OK and now all fonts from /usr/bin/X11/xfs are remoted.

If I reboot Linux to a text only console and try dtlogin from HPUX, I see what I know is a true hourglass displayed and I hear my HP box trying and trying to no avail. I have to kill the attempt at dtlogin from another text login I have set up just for access in cases like this.

Do you know exactly what is supposed to be executed when one does dtlogin, or runs /usr/dt/bin/dtrc (which should call the correct config file in /etc/dt/config?

It seems really close, but nothing but hanging right now. By the way, if I didn't say it before, I DO NOT have a graphics card in my HPUX box. I really cannot understand how I can run all types of X apps (e.g.SAM) on my Linux box, but not the full CDE and its login. This is getting frustrating!!
bc
bill-clayton
Advisor

Re: Remoting CDE to Linux HPUX-11.0

Most of the problems I had seem to be related to getting a good font server from the HPUX computer back to Linux. Once that was fixed, I was able to login via CDE.
bc