System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Revert from NIS to local user setup.

John R. Ulmer
Occasional Advisor

Revert from NIS to local user setup.

'Back into some sys admin work after having been out of it for years. Please pardon extreme rustiness.

I have inherited two hp ux 11 boxes. I'm trying to get remsh to work between them and think that the user management is the problem. It appears that NIS+ was partially setup on one of the boxes. We have a very small number of users and don't need NIS.

So, is there a way to do this via SAM. That'd be easy. I don't see an obvious way to do it.

Or, sans SAM, what files are involved, how do I modify them to go back to local user management (undo the NIS setup), and what processes need to be stopped and prevented from restarting?

Thanks
8 REPLIES
Pete Randall
Outstanding Contributor

Re: Revert from NIS to local user setup.

Having never really played with NIS, I can only offer a guess that you would need to modify /etc/nsswitch.conf, particularly for hosts, password and group. Sort of like this:

hosts: files[NOTFOUND=continue UNAVAIL=continue] dns [NOTFOUND=continue UNAVAIL=
continue TRYAGAIN=return] nis

You should be able to do this through SAM > Networking and Communications > Name Service Switch.


Pete

Pete
Steven Schweda
Honored Contributor

Re: Revert from NIS to local user setup.

> [...] I'm trying to get remsh to work
> between them and think that the user
> management is the problem. [...]

Evidence? It might be interesting to see
exactly what you tried, and exactly what
failed when you tried it.

> It appears that [...]

Again, I can't see what you see.

> So, is there a way to do this via SAM.

Do what, exactly? Turn off NIS or NIS+? I
haven't looked, but I'd assume that that's
pretty easy. Add a few local users manually?
How hard can that be?
Steven Schweda
Honored Contributor

Re: Revert from NIS to local user setup.

And, of course, actual output from "uname -a"
would be more informative than "hp ux 11",
which is pretty non-specific.
melvyn burnard
Honored Contributor

Re: Revert from NIS to local user setup.

If I recall correctly, I believe that you tell the system to llok at NIS by adding a + entry into the passwd file, but I may be wrong.
You should also check your /etc/nsswitch.conf and see if that refers you to NIS rather than files
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Steven Schweda
Honored Contributor

Re: Revert from NIS to local user setup.

> I haven't looked, [...]

Ok. Now I've looked. At NIS, at least. On
my 11.11 system, SAM offers:

Networking and Communications
NIS
Actions
Disable Server
Disable Client

Name Service Switch
Actions
Configure Name Service Switch...

I've never used NIS+, so I know nothing on
that front, other than to tell Name Service
Switch not to use it, but there is an icon
for it, too.

There's also:

Accounts for Users and Groups
Local Users
Actions
Add...

SAM may lack the visual charm of the SMIT
Dude on AIX, but it can be pretty helpful.
(As you mentioned SAM, I'll assume that
you're not running 11.31, where it's (mostly)
replaced by SMH.)
John R. Ulmer
Occasional Advisor

Re: Revert from NIS to local user setup.

Sorry to treat you that way. It makes me crazy for people to ask Perl questions without any code or details.... exactly what I just did.

# uname -a
HP-UX boxName B.11.23 U ia64 other stuff

When I 'ssh boxName1 ls', I get a directory listing of the home dir on the boxName1.

When I 'remsh boxName1 ls', I get,
rcmd_af: primary connection shut down.

I've been reading HP-UX manuals and papers and googling that error and I find some references to that error being a security problem involving inetd.

I've created a new user identically on both boxes, same uid. On the box to which I want to remsh, I have created an /etc/hosts.equiv file listing the client box and the new user.

The box to which I want to remsh does not mention NIS anywhere in its /etc/nsswitch.conf file. It should be looking at its local passwd file.

I'm stumped..... but, am still digging.

Thanks

Steven Schweda
Honored Contributor

Re: Revert from NIS to local user setup.

> When I 'remsh boxName1 ls', I get,
> rcmd_af: primary connection shut down.

Unfamiliar to me. Anything in the system log
file(s) on the server?

Lacking any actual insight, I'd also try
remsh from a system to itself, which would
tend to filter out any external network
quirks.
Dennis Handly
Acclaimed Contributor

Re: Revert from NIS to local user setup.

>I have created an /etc/hosts.equiv file listing the client box and the new user.

Rather than use /etc/hosts.equiv, you may want each user to just create his own ~/.rhosts file.