System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Routing Problem - no route to host

amreek bansal
Frequent Advisor

Routing Problem - no route to host


Hi, Can someone help please, I have 2 servers which are trying to set up connectivity between. The servers are on 2 different networks, the firewalls have been opened to allow access. Its now the routing on the 2 servers which need to be set up and i'm not totally sure on what routes to add.

As when i try to ssh or ftp from server 1 to server2 i get no route to host message.

Details of the servers are the following:

I'm trying to connect from server1 to server2 (i.e ssh and ftp).

server1 :

IP add: 10.93.58.135
Gateway: 10.93.58.129

netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
10.93.58.128 0.0.0.0 255.255.255.192 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 10.93.58.129 0.0.0.0 UG 0 0 0 eth1

[root@LFHG-M-TRANS01 root]# ifconfig -a

eth1 Link encap:Ethernet HWaddr 00:50:56:8F:50:72
inet addr:10.93.58.135 Bcast:10.93.58.191 Mask:255.255.255.192
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21926421 errors:1194 dropped:7352 overruns:0 frame:0
TX packets:10571981 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1024700470 (977.2 Mb) TX bytes:697895955 (665.5 Mb)
Interrupt:19 Base address:0x1480


server2 :

IP add: 10.254.5.70
Gateway: 148.253.97.33

Routing tables
Destination Gateway Flags Refs Interface Pmtu
127.0.0.1 127.0.0.1 UH 0 lo0 4136
10.254.5.70 10.254.5.70 UH 0 lan5 4136
148.253.97.34 148.253.97.34 UH 0 lan900 4136
10.254.3.39 10.254.3.39 UH 0 lan3 4136
156.150.219.128 10.254.5.65 UGH 0 lan5 0
148.253.97.32 148.253.97.34 U 2 lan900 1500
10.254.3.32 10.254.3.39 U 2 lan3 1500
10.254.5.64 10.254.5.70 U 2 lan5 1500
156.150.0.0 10.254.5.65 UG 0 lan5 0
127.0.0.0 127.0.0.1 U 0 lo0 0
default 148.253.97.33 UG 0 lan900 0

Please help to resolve this. Thanks
7 REPLIES
johnsonpk
Honored Contributor

Re: Routing Problem - no route to host

Hi Amreek,

lets make it simple

server 1

I/P :10.93.58.135
netmask :255.255.255.192
default gateway:10.93.58.129

Server 2

I/P :10.254.5.70
netmask :?????
default gateway:148.253.97.33

we need more info

does the default gw 10.93.58.129 of server1 has routing entries to 10.254.5 network?If not what is the router ip which has that routing table?


please paste netstat -in of second server (it seems there is more that one interface configured with ip)

Johnson

V. Nyga
Honored Contributor

Re: Routing Problem - no route to host

Hi,

you already got an answer how to add a route:
http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=1341468

so what's the problem?

See 'man route' about the route-command.

You have to tell the server1 over which gateway he reaches server2 and vice versa.

Else some more hints would be nice.

Volkmar
*** Say 'Thanks' with Kudos ***
amreek bansal
Frequent Advisor

Re: Routing Problem - no route to host


Hi Johnson,

Thanks for your reply, the output of netstat -in is shown below

netstat -in

Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll
lan3 1500 10.254.3.32 10.254.3.39 16027972 0 46245723 0 0
lo0 4136 127.0.0.0 127.0.0.1 4606183 0 4606183 0 0
lan5 1500 10.254.5.64 10.254.5.70 17543651 0 16726929 0 0
lan900 1500 148.253.97.32 148.253.97.34 1683718340 0 1861802118 0 0


netstat -rn
Routing tables
Destination Gateway Flags Refs Interface Pmtu
127.0.0.1 127.0.0.1 UH 0 lo0 4136
10.254.5.70 10.254.5.70 UH 0 lan5 4136
148.253.97.34 148.253.97.34 UH 0 lan900 4136
10.254.3.39 10.254.3.39 UH 0 lan3 4136
156.150.219.128 10.254.5.65 UGH 0 lan5 0
148.253.97.32 148.253.97.34 U 2 lan900 1500
10.254.3.32 10.254.3.39 U 2 lan3 1500
10.254.5.64 10.254.5.70 U 2 lan5 1500
156.150.0.0 10.254.5.65 UG 0 lan5 0
127.0.0.0 127.0.0.1 U 0 lo0 0
default 148.253.97.33 UG 0 lan900 0
johnsonpk
Honored Contributor

Re: Routing Problem - no route to host

Hi,

Need answer for this

does the default gw 10.93.58.129 of server1 has routing entries to 10.254.5 network?If not what is the router ip which has that routing table?

thanks!
Johnson
amreek bansal
Frequent Advisor

Re: Routing Problem - no route to host


Hi Johnson,

To answer your question

"does the default gw 10.93.58.129 of server1 has routing entries to 10.254.5 network?If not what is the router ip which has that routing table? "

Is this checked from netstat -rn ?

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
10.93.58.128 0.0.0.0 255.255.255.192 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 10.93.58.129 0.0.0.0 UG 0 0 0 eth1

If not, then can you advise on how to check this please ?

johnsonpk
Honored Contributor

Re: Routing Problem - no route to host

Hi,
since the ip 10.93.58.129(router) is out side of your server ,u wont be able to fetch the info,better contact the Network admin and ask him to have a look.

if he can set that routes on the router(10.93.58.129), you need not to do anything on server side

Thanks!!
Johnson
Laurent Menase
Honored Contributor

Re: Routing Problem - no route to host

from hpux:
traceroute -i lan900 -s 148.253.97.34 10.93.58.135

because since your default address in on 148.* network, the default ip used will be the 148.* one when connection from hpux to the linx

If you really want to be able to use 10.254.5.70 then try a
traceroute -i lan900 -s 10.254.5.70 10.93.58.135

be sure also that your routers knows that 10.254.5.70 is your hpux system.

You also could network traces to see where the messages are sent to. - nettl or tcpdump)