cancel
Showing results for 
Search instead for 
Did you mean: 

SAMBA 11iv1 and AD 2008

Mduffy_1
Advisor

SAMBA 11iv1 and AD 2008

I have a few systems that are running HP UX 11iv1 and they need to connect to AD 2008 for SAMBA. After I created the smb.conf, joined the domain and started smb, I still get the following error when I try to open a share....
[2011/03/08 09:41:48, 0] auth/auth_domain.c:domain_client_validate(256)
domain_client_validate: unable to validate password for user userid in domain
USVCI001 to Domain controller CONTNAME. Error was NT_STATUS_INVALID_PARAMETER

I have found when I updated 11iv3, and 11iv2 systems to CIFS 3 I dont have this issue, but I dont see a way to upgrade 11iv1 to CIFS 3, highest CIFS i see is 2.04.02, and SAMBA 3.0.30. Any ideas, or work arounds?

Output is as follows..
swlist -l product|grep -i cifs
CIFS-Client A.01.06 HP CIFS/9000 Client
CIFS-Development A.02.04.02 HP CIFS Server Source Code Files
CIFS-Server A.02.04.02 HP CIFS Server (Samba) File and Print Ser

Also
smbd -V
Version 3.0.30 based HP CIFS Server A.02.04.02

To communicate with AD 2008 you need to have Samba version 3.0.37 or newer, but I dont see a CIFS to get me there for 11iv1.

When I upgraded to CIFS A.03.01 and Samba 3.4.3 for my 11iv3 and 11iv2 systems I had no issues with Samba and AD 2008.

3 REPLIES
Steven E. Protter
Exalted Contributor

Re: SAMBA 11iv1 and AD 2008

Shalom,

CIFS-Client A.01.06 HP CIFS/9000 Client

That needs to be updated.

Download and install a current version from http://software.hp.com

This will require a system reboot.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
grahamswilson
Trusted Contributor

Re: SAMBA 11iv1 and AD 2008

If you search for SAMBA at software.hp.com, there is the HP version A.02.04.02 available for HP-UX11iv1.

From the notes, it says "Starting with the HP CIFS Server A.02.04 release, HP CIFS Server supports Windows Server 2008 and Windows Vista operating systems."

(This is based on SAMBA version 3.0.37.)
Mduffy_1
Advisor

Re: SAMBA 11iv1 and AD 2008

Steven, I have downloaded the newest CIFS-Client, but I have to wait for a downtime to try that out. If there are other work arounds until I can get one scheduled, let me know.

Grahamswilson, I have downloaded and installed 2.04.02 but that only updates you to 3.0.30 for 11iv1. And as you posted its based on Samba 3.0.37, so that doesnt fix it.

Thanks