System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

SFTP to non-Tru64 (with no password)

SOLVED
Go to solution
Mike Ingram_1
Frequent Advisor

SFTP to non-Tru64 (with no password)

Hi All,

I am trying to set up sftp so that the Tru64 client can connect to a Windows sftp host.
I have managed to get this working from other Unix clients, but not from a Tru64 client.
On the other systems, I copied the client public key file to the host's authorized_keys file, and this allowed me to sftp and not be prompted for the password.
I tried this for the Tru64 setup, but it still prompts me for the password.
The format of the public key file is very different on Tru64, so I guess I need to change it somehow?
Can anyone advise me what needs to be done?
Many thanks.
3 REPLIES
Victor Semaska_3
Esteemed Contributor
Solution

Re: SFTP to non-Tru64 (with no password)

Mike,

It sounds like you have a version of Tru64 that comes with the SSH.COM version of SecureShell which uses the SSH2 format.

What you have to do is convert the key to OpenSSH format after you copy it to the Windows system. On UNIX systems you would use the ssh-keygen utility with the '-i' option. I assume this utility is available on Windows.

Vic
There are 10 kinds of people, one that understands binary and one that doesn't.
Steven Schweda
Honored Contributor

Re: SFTP to non-Tru64 (with no password)

"ssh-keygen -i" should work, but on a bad
day, it is possible to do the conversion
manually. The significant data are the same
in both formats, so remove the newline
characters (and all the stuff you can read)
from a Tru64 key file, and the result should
work in your OpenSSH authorized_keys file.

Also "ssh -v" may provide a little more info
on where things go wrong, but you seem to
know that already.
Mike Ingram_1
Frequent Advisor

Re: SFTP to non-Tru64 (with no password)

Hi Gents,

Many thanks to you both - I now have it working.
One area I was messing up on, was that the public key from other systems ends with username@host, and I was manually adding this to the Tru64 key, which is not needed.

All working now - many thanks.