HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

SG package does not start automatically.

 
SOLVED
Go to solution
Vishu
Trusted Contributor

SG package does not start automatically.

Hi masters,

I have two node clusters(obd1 and obd2) running Serviceguard having two packages running on the primary node. When i boot my server, the packages do not start up automatically. infact, the same scene is with when i run command :
'cmruncl -v'

But, when i run the follwing commands, the packages come up beautifully and working fine.
cmrunpkg -v pdobdpkg
cmrunpkg -v sdobdpkg

I have checked that AUTO_RUN feature is enabled in the cmviewcl output. I want to run the packages automatically. please help me in this.

Regards
Vishu
11 REPLIES
Emil Velez
Honored Contributor

Re: SG package does not start automatically.

Is the cluster configured to run at boot time ?

Re: SG package does not start automatically.

post the output of the following:

grep -i autostart /etc/rc.config.d/cmcluster

cmgetconf -p pdobdpkg | sed -e 's/#.*//g' -e '/^$/d'

cmgetconf -p sdobdpkg | sed -e 's/#.*//g' -e '/^$/d'

HTH

Duncan

HTH

Duncan
Vishu
Trusted Contributor

Re: SG package does not start automatically.

yes, the cluster is configured to start automatically.
AUTO_START_CMCLD=1 in /etc/rc.config.d/cmcluster. Also, when i executes cmruncl command, even then the packages did not came up automatically, instead need to bring them up manually using cmrunpkg.
Patrick Wallek
Honored Contributor

Re: SG package does not start automatically.

Are the packages themselves set to start automatically?

If you do a 'cmviewcl' do you see "ENABLED" in the "AUTO_RUN" column for the packages?
Vishu
Trusted Contributor

Re: SG package does not start automatically.

Hi,
Below is the output of cmviewcl.

obd1 root # cmviewcl

CLUSTER STATUS
obdb_atl up

NODE STATUS STATE
obd1 up running

PACKAGE STATUS STATE PKG_SWITCH NODE
pdobdpkg up running enabled obd1
sdobdpkg up running enabled obd1

NODE STATUS STATE
obd2 up running

obd1 root #

Re: SG package does not start automatically.

just cos pkg switching is now enabled, doesn't mean it was at cluster staret time... as previously requested we need some info on the cfg of your pakcages - can you post:

cmgetconf -p pdobdpkg | sed -e 's/#.*//g' -e '/^$/d'

cmgetconf -p sdobdpkg | sed -e 's/#.*//g' -e '/^$/d

HTH

Duncan

HTH

Duncan
Vishu
Trusted Contributor

Re: SG package does not start automatically.

Hi,
Below are the parameters in the package configuration file.



PACKAGE_NAME pdobdpkg

FAILOVER_POLICY CONFIGURED_NODE

FAILBACK_POLICY MANUAL

NODE_NAME obd1
NODE_NAME obd2

RUN_SCRIPT /etc/cmcluster/pdobdpkg/pdobdpkg_control.sh
RUN_SCRIPT_TIMEOUT NO_TIMEOUT
HALT_SCRIPT /etc/cmcluster/pdobdpkg/pdobdpkg_control.sh
HALT_SCRIPT_TIMEOUT NO_TIMEOUT

SERVICE_NAME pdobdpkg_monitor.sh
SERVICE_FAIL_FAST_ENABLED NO
SERVICE_HALT_TIMEOUT 300

SUBNET 135.58.64.0

PKG_SWITCHING_ENABLED NO

NET_SWITCHING_ENABLED YES

NODE_FAIL_FAST_ENABLED NO
Solution

Re: SG package does not start automatically.

So this must be a pretty old cluster, as PKG_SWITCHING_ENABLED was deprecated in v11.12 and replaced with AUTO_RUN - what version of SG are you running now?

Anyway, to have packages start when the cluster starts, you'll need to chnage PKG_SWITCHING_ENABLED to yes and reapply the package configurations with cmapplyconf.

HTH

Duncan

HTH

Duncan
Vishu
Trusted Contributor

Re: SG package does not start automatically.

Thanks Duncan,

Reapply package configuration by changing the PKG_SWITCHING_ENABLED to yes resolved my problem.....

thanks very much for the solution.

Vishu
Trusted Contributor

Re: SG package does not start automatically.

Also Duncan,

One more thing to ask. I changed my cluster lock disk at the same hardware address and i did not have the vgcfgbackup of it on one another server in a 2 node cluster. Now, i am going to reapply the cluster configuration.

But my question is do i need to run the cmapplyconf with package's conf file also or only cluster ascii files will do the needful and package will start and work automatically.

thanks
Vishu
Trusted Contributor

Re: SG package does not start automatically.

Guys,

Plz help me in this also. or Should i start a new thread for it.

thanks