cancel
Showing results for 
Search instead for 
Did you mean: 

SSH and TTY

 

SSH and TTY

I have a HP 11.11 server running T1471AA A.05.50.013 HP-UX Secure Shell. When I attempt a SSH login the session hangs and I get message: stty: : Not a typewriter.
ps -ef | grep ssh
root 25364 1 0 Oct 10 ? 18:28 /opt/ssh/sbin/sshd
grecnis 16994 16912 0 13:00:02 ? 0:00 sshd: grecnis@notty
root 16912 25364 0 12:59:50 ? 0:01 sshd: grecnis [priv]

When I look at a system with a sucessfull login I see:
ohio612% nexec -e ps -ef | grep ssh
root 551 1 0 Oct 10 ? 11:02 /opt/ssh/sbin/sshd
root 9714 551 0 11:27:50 ? 0:00 sshd: mhs [priv]
mhs 9727 9714 0 11:27:56 ? 0:00 sshd: mhs@pts/1

I'm not sure why thr TTY session will not allocate, Any suggestions ?

Thanks
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: SSH and TTY

Shalom,

This is usually an environment problem.

Please post:

stty -a

env

You need a TERM variable at the very least.

Take a look at the user .profile configuration as well.

The typewriter message happens a lot when Oracle shells out to the OS because it does this without an environment.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: SSH and TTY

stty -a
stty: : Not a typewriter

env
_=bin/rscd
SENDMAIL_SERVER=1
RBOOTD_DEVICES=
DDFA=0
SNMP_MASTER_START=1
MROUTED_ARGS=
PATH=/usr/sbin:/usr/bin:/usr/ccs/bin:/usr/contrib/bin:/opt/nettladm/bin:/opt/pd/bin:/usr/bin/X11:/usr/contrib/bin/X11:/opt/upgrade/bin:/sbin:/usr/nsh/bin:/usr/nsh/sbin
XNTPD_ARGS=
XNTPD=1
SNMP_TRAPDEST_START=1
INETD_ARGS=
MROUTED=0
SNMP_MIB2_START=1
ERASE=^H
INIT_STATE=3
RWHOD=0
SNMP_HPUNIX_START=1
PRE_U95=true
HOME=/
START_RSCD=1
LD_LIBRARY_PATH=/usr/nsh/lib
PWD=/usr/nsh
TZ=UTC0
SENDMAIL_SERVER_NAME=
NTPDATE_SERVER=198.151.186.175 198.151.186.176 192.231.184.7 192.231.184.11 192.231.184.1
TERM=xterm
DISPLAY=127.0.0.1:10.0
RSCD_CLIENT_USER=grecnis
ohio611%
eric lipede_1
Regular Advisor

Re: SSH and TTY

Hi

Have you looked at the
ssh -t
ssh -f
and
ssh -n options ?

try these (see man pages)