cancel
Showing results for 
Search instead for 
Did you mean: 

SSH and symlinks

SOLVED
Go to solution
Bouda16
Occasional Advisor

SSH and symlinks

Hello,
I have problem with public key authentication. when .ssh directory with authorized_keys file is standard directory it is working correctly, but when it is symbolic link to some other directory outside home directory it doesn't work.
I have to use the symbolic link, is there some way to avoid symbolic link checking by sshd or other way to make it working?

Thanks in advance for any ideas...
3 REPLIES
Ivan Ferreira
Honored Contributor
Solution

Re: SSH and symlinks

Try setting StrictModes to No in the sshd_config file.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Bouda16
Occasional Advisor

Re: SSH and symlinks

THANKS GOD...
Bouda16
Occasional Advisor

Re: SSH and symlinks

One answer = good answer