cancel
Showing results for 
Search instead for 
Did you mean: 

Samba access prblem

Iyyappan
Occasional Visitor

Samba access prblem

I have given samba access to user with wire permission.

But user could not create or modify the files
Please find the smb.conf file below:


comment = Download Reports
path = /reports
read only = Yes
write list = trakesh
guest ok = no


Directory Permission:

drwxrwxr-x 5 trakesh info 13312 Feb 25 15:06 reports

Please help me out


6 REPLIES
Steven E. Protter
Exalted Contributor

Re: Samba access prblem

Shalom,

read only = Yes

People can't write there with the share marked like that.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Iyyappan
Occasional Visitor

Re: Samba access prblem

I have tried but problem remains same

comment = Download Reports
path = /reports
read only = no
write list = trakesh
guest ok = yes


Re: Samba access prblem

try this one


comment = Download Reports
path = /reports
writeable = yes
admin users = trakesh
guest ok = no



Iyyappan
Occasional Visitor

Re: Samba access prblem

Tried but problem remains same
Matti_Kurkela
Honored Contributor

Re: Samba access prblem

Does the "workgroup = " setting in the smb.conf file match the workgroup/domain used by the client?

If you haven't specified the workgroup setting, default value is "workgroup = WORKGROUP". So your write-listed (or admin-listed) user "trakesh" is actually "WORKGROUP\trakesh" in Windows style.

If your client connects as COMPANYDOMAIN\trakesh, samba naturally thinks it isn't the same user as WORKGROUP\trakesh and treats you as a nobody.

MK
MK
Iyyappan
Occasional Visitor

Re: Samba access prblem

we have more than 50 systems with same kind of configurations(samba).

Users are belogs to windows domain, i have maped them in the username.map files(samba)
for all the servers.

Only one server getting access denied problem when try to copy/write the files.