HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Samba issue (Not able to access by domain users)

 
SOLVED
Go to solution
senthil_kumar_1
Super Advisor

Samba issue (Not able to access by domain users)

Hi All,

I am using samba 2.21 in HPUX 11.00.

The samba is running as domain member (security=domain), so all the users availabe in Domain (win2003 server) can access the samba shares.

today we wanted to stop the samba service for some reasons.

I have stopped the samba (smb and nmb) using SWAT (http://serverip:901).

Then after some time we started the samba thru SWAT.

After that it is asking for username and password whenever we are accessing the samba shares from Client (windows xp / 2003), then we entered the domain username and password but even after also not able to open the share.

Then i checked from console.

Then i stopped the service:
/sbin/init.t/samba stop

I am getting the error "Not able to stop gracefully.

it is not stopped.

Then i tried to start samba:
/sbin/init.d/samba start

I am getting the message "Samba service already up, and started".


But i am able to start and stop the samba completely from SWAT.

But what is the problem is after doing thru SWAT, it is asking for username and password to open the shares when trying to open from windows client.

Then i checked for log file (/var/opt/samba/)

Where i got the message:

[2009/08/06 11:52:32, 0] smbd/password.c:(1574)
domain_client_validate: could not fetch trust account password for domain XYZ

So i issued following command.

> smbpasswd -j XYZ -r pridc67 -U Administrator
Password:
Joined domain XYZ.


Even after also i am getting the same error when opening the shares from windows client.

Actually the samba was configured by prvious UNIX admin.

My DC name - pridc67.abc.domain.com

Some important setting in smb.conf

workgroup = XYZ
security = domain
password server = pridc67.abc.domain.com
encrypt passwords = yes


Please give me the answers for following questions:

1)Why it is showing error message when starting and stopping from console.

2)why it is asking for username and password even after integrated with domain once again?

3)is workgroup name of smb.conf file must be same as domain name?
here our domain name is "abc.domain.com"
but in smb.conf domain name is "xyz"



5 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: Samba issue (Not able to access by domain users)

Shalom,

Few things.

HP provided a Samba Version 2 based Samba on HP-UX 11.00. They never provided any software based on Samba 3.

There is nothing in the post about the domain controller, but if its Windows Server 2003, that is based on Samba 3 and integration issues are likely.

The specific error seems to indicate the Samba daemon was not stopped. This indicates a possible problem with the samba installation.

Stop swat service and try again.

If the problem persists, back up the smb.conf file, swremove Samba and swinstall the latest depot you can get your hands on.

Or better yet, pull Samba 3 code from the Samba website and compile it. It will go a long way to dealing with integration issues.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
senthil_kumar_1
Super Advisor

Re: Samba issue (Not able to access by domain users)

How to stop the SWAT?
senthil_kumar_1
Super Advisor

Re: Samba issue (Not able to access by domain users)

Hi Steven E. Protter and All,

How to stop SWAT. it is very urgent.


Please help me.
Stephan.
Honored Contributor

Re: Samba issue (Not able to access by domain users)

Swat is running as part of inetd, so restarting inetd should do the trick: 'inetd -c'.

You can also try 'man swat', 'man inetd'.

hth
Steven E. Protter
Exalted Contributor

Re: Samba issue (Not able to access by domain users)

Sorry I missed the first response.

Quick way:

ps -ef | grep swat

as root

issue a kill command on the daemon.

I never bothered to turn swat on ever. I always manipulated smb.conf.

There is probably a startup script in /sbin/init.d for swat

There is also probably a start/stop configuration script for the service in /etc/rc.config.d

Here are a few links to help out for permanent changes to swat.

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1249907391949+28353475&threadId=33499


http://forums11.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1249907571751+28353475&threadId=994935

I just read that swat might be run by the inetd daemon in which case you modify /etc/inetd.conf comment out swat and:

inetd -c


SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com