System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Scalar 2000 tape library disappeared. Driver issue?

KiddA
Advisor

Scalar 2000 tape library disappeared. Driver issue?

Hi people, hope you're doing fine ...

We came across an issue with this tape library ... for some reason server stopped seeing it.

Server details: Integrity rx7640, running three vpars.

vparstatus -v -p vp1_vparname
[Virtual Partition Details]
Name: vp1_vparname
State: Up
Attributes: Dynamic,Autoboot,Nosearch
Kernel Path: /stand/vmunix
Boot Opts: -lq

[CPU Details]
Min/Max: 1/8
User assigned [Path]:
Boot processor [Path]: 0.120
Monitor assigned [Path]: 0.121

Non-cell-specific:
User assigned [Count]: 0
Monitor assigned [Count]: 2
Cell-specific [Count]: Cell ID/Count


[IO Details]
0.0.0
0.0.1
0.0.12
0.0.14
0.0.0.3.0.6.0
0.0.1.1.0.4.1.5.0
0.0.0.3.0.6.0.0.0.0.0 BOOT
0.0.1.1.0.4.1.5.0.0.0.0.0,ALTBOOT

[Memory Details]
ILM, user-assigned [Base /Range]:
(bytes) (MB)
ILM, monitor-assigned [Base /Range]: 0x100000000/10240
(bytes) (MB)
ILM Total (MB): 10240

ILM Granularity (MB): 1024

CLM, user-assigned [CellID Base /Range]:
(bytes) (MB)
CLM, monitor-assigned [CellID Base /Range]:
(bytes) (MB)
CLM (CellID MB):

CLM Granularity (MB): 1024



First thing we did is to reboot the vpar (without luck).
It was configured on hardware path 0/0/12/1/0/4/0 (please refer to old_ioscan.txt)
But checking ioscan after the reboot ... we found that it disappeared.
I found some errors on syslog file regarding sctl driver:

Nov 17 12:22:44 vparname avrd[19836]: sctl driver not installed or not configured, using normal open() for scanning
Nov 17 12:22:49 vparname above message repeats 159 times
Nov 17 12:22:59 vparname avrd[19836]: sctl driver not installed or not configured, using normal open() for scanning
Nov 17 12:42:45 vparname avrd[19836]: sctl driver not installed or not configured, using normal open() for scanning
Nov 17 12:42:50 vparname above message repeats 159 times
Nov 17 12:43:00 vparname avrd[19836]: sctl driver not installed or not configured, using normal open() for scanning

I then went to SAM to rescan for tape drives. then I went to "diagnose missing tape drive" and here's what I got:

DeviceFileSystem, KeyboardMUX, LegacyDeviceDriver, MouseMUX, OOCdio, ¦ ¦
¦+-¦ UsbBootKeyboard, UsbBootMouse, UsbBulkOnlyMS, UsbEhci, UsbHid, ¦-+ ¦
¦¦ ¦ UsbMiniBus, UsbOhci, UsbScsiAdaptor, audio, beep, ccio, consp1, ¦ ^ ¦
¦¦ ¦ dm_sample_fsid, dmapi, dmsample, ehci, framebuf, graph3, hcd, hid, ¦ ¦
¦¦ ¦ hub, idds, iomap, iomem, krio, ktest, ktestio, mass_storage, nfs, pa, ¦ ¦
¦¦ ¦ pid, plat_intr, pppoe, pxb_wxb, rmp3f01, root, schgr, sflop, sim, ¦ ¦
¦¦ ¦ sim_psm, simcons, simdisk, ssrfc, stape, ted, tgt, usbcomposite, ¦ ¦
¦¦ ¦ usbd, vmm_cdio, vxfs, vxportal ¦ ¦
¦¦ ¦ ¦ ¦
¦¦ ¦ The absence of one or more of these drivers may be the reason that ¦ ¦
¦¦ ¦ SAM is unable to find the device. You can install these drivers from ¦ ¦
¦¦ ¦ SAM Kernel Config (kcweb) subarea.

After that I checked the kernel modules and sctl driver:

SAM -> Kernel Configuration -> Module -> Modify -> sctl
---------------------------------------------------------------------
Module sctl [4C376E63]
Description SCSI Controller Driver
State static (best state)
State at Next Boot static (best state)
Capable static unused
Depends On module c8xx:0.0.0
module qlisp:0.0.0
interface HPUX_11_23:1.0


Enter new state ( s-static u-unused ) OR q(Quit) =

===

And I also enabled stape driver.

SAM -> Kernel Configuration -> Module -> Modify -> stape
---------------------------------------------------------------------
Module stape [4C376E63]
Description SCSI Tape Driver
State unused
State at Next Boot unused
Capable static unused
Depends On module sctl:0.0.0
interface HPUX_11_23:1.0


Enter new state ( s-static u-unused ) OR q(Quit) = s

Do you want to save the current kernel configuration ? (y/n/q)[y] = y

Enter comments =

Command Preview: /usr/sbin/kcmodule -h -B stape=static

Do you want to proceed ? (y/n) [n] = y

* The automatic 'backup' configuration has been updated.
* Building a new kernel for configuration 'nextboot'...
* Adding version information to new kernel...
* The requested changes have been saved, and will take effect at
next boot.

press enter to continue...

I would like to know if someone already experienced this and would share some light on this issue.

Thanks everyone for the time&help.
Fernan.
1 REPLY
KiddA
Advisor

Re: Scalar 2000 tape library disappeared. Driver issue?

attached ioscan after reboot.