cancel
Showing results for 
Search instead for 
Did you mean: 

Secure Ftp

SOLVED
Go to solution
Roro_2
Regular Advisor

Secure Ftp


Hello,

Our customer could not find sftp on ES40 server running Tru64 Unix 5.1
Where can i find it ?

Thanks and Regards

Roger
6 REPLIES
Steven Schweda
Honored Contributor

Re: Secure Ftp

> Our customer could not find sftp on ES40
> server running Tru64 Unix 5.1

Where did he look? Which "Tru64 Unix 5.1"?

sizer -v

Around here:

urtx# sizer -v
HP Tru64 UNIX V5.1B (Rev. 2650); Fri Mar 20 20:19:48 CDT 2009

urtx# /usr/sbin/dupatch -track -type patch_level | \
grep -i 'patch kit'
Gathering details of relevant patch kits...
Patch Kit 5: T64V51BB26AS0005-20050502 OSF540
Patch Kit 6: T64V51BB27AS0006-20061208 OSF540
Patch Kit 7: T64V51BB28AS0007-20090312 OSF540

urtx# type sftp
sftp is /usr/bin/sftp

urtx# /usr/bin/sftp -V
/usr/bin/sftp: SSH Secure Shell Tru64 UNIX 3.2.0


http://h30097.www3.hp.com/unix/security-download.html

Note: SSH is included in Tru64 UNIX V5.1B
and is no longer available for download
from this site.
If you are using an earlier version of
Tru64 UNIX and require SSH, there are
other SSH implementations available, such
as OpenSSH.
Roro_2
Regular Advisor

Re: Secure Ftp


Hi Steven,

1- The output of "sizer - v" is :

Compaq Tru64 UNIX V5.1 (Rev. 732); Thu Jun 11 14:45:50 EDT 2009

2- The output of "dupatch ..." is :

Patches installed on the system came from following patch kits:

- T64V51AS0002-20001204 OSF510


Please advise.

Thanks and Regards

Roger


Steven Schweda
Honored Contributor
Solution

Re: Secure Ftp

> Compaq Tru64 UNIX V5.1 (Rev. 732); Thu Jun 11 14:45:50 EDT 2009

That looks like a plain V5.1, which is about
ten years old, and may be out of support.
If you have a support contract, then you
should probably contact HP. If not, then I'd
probably start looking for an OpenSSH kit, as
suggested.

If you don't have a support contract, then
you probably can't even look at the old Tru64
patch kits, and even if there were some SSH
kit available for V5.1, then it'd probably be
about ten years old, too, and then you'd
probably do better with a more modern version
of OpenSSH.
John Manger
Valued Contributor

Re: Secure Ftp

Tru64 V5.1 (732), pre-dates the delivery of SSH (which includes sftp). You'll need to d'load one of the open/free ssh variants from the 'net, and build it yourself. There probably several notes on how to do that here on ITRC.

John M
Nobody can serve both God and Money
Roro_2
Regular Advisor

Re: Secure Ftp

Hello,

We don't have support with HP.
So could you tell me how can i get "sftp" .

Thanks and Regards

Roger
Steven Schweda
Honored Contributor

Re: Secure Ftp

> So could you tell me how can i get "sftp" .

Is Google broken?

I'd start here:

http://www.openssh.com/