cancel
Showing results for 
Search instead for 
Did you mean: 

Secure Shell Error

SOLVED
Go to solution
Vincent_5
Super Advisor

Secure Shell Error

Hi Guys,

Can anyone advice, I tried to install secure shell 7.3 into a rx2800 server running on hp ux 11iv3 , below is the error , kindly help ?

 * Summary of Analysis Phase:
ERROR:       Exclude       Secure_Shell.SECURE_SHELL,r=A.07.30.003
ERROR:   1 of 2 filesets had Errors.
       * 1 of 2 filesets had no Errors or Warnings.
ERROR:   The Analysis Phase had errors.  See the above output for
         details.


       * Beginning the Install Execution Phase.
       * Filesets:         1
       * Files:            491
       * Kbytes:           6040
       * Installing bundle "SecureShell,r=A.07.30.003" .
       * Installing fileset "Secure_Shell.SECSH-CMN,r=A.07.30.003" (1
         of 1).
NOTE:    A new version of "/opt/ssh/etc/ssh_config" has been installed
         on the system.
NOTE:    A new version of "/opt/ssh/etc/sshd_config" has been installed
         on the system.
NOTE:    A new version of "/opt/ssh/etc/moduli" has been installed on
         the system.

       * Beginning the Configure Execution Phase.
unknown key type ed25519
ERROR:   could not generate ED25519 host key
ERROR:   The "configure" script for "Secure_Shell.SECSH-CMN" failed
         (exit code "1"). The script location was
         "/var/tmp/BAA008052/catalog/Secure_Shell/SECSH-CMN/configure".
       * This script had errors and the execution of this fileset
         cannot proceed until the problem is fixed.  Check the above
         output from the script for further details.

       * Summary of Execution Phase:
ERROR:       Installed     Secure_Shell.SECSH-CMN,r=A.07.30.003
ERROR:       Skipped (in analysis) Secure_Shell.SECURE_SHELL,r=A.07.30.003
ERROR:   2 of 2 filesets had Errors.
ERROR:   The Execution Phase had errors.  See the above output for
         details.


=======  12/11/17 13:26:14 SST  END install AGENT SESSION (pid=8052)
         (jobid=vsoe13-0007)


=======  12/11/17 13:26:15 SST  BEGIN install AGENT SESSION (pid=8136)
         (jobid=vsoe13-0007)

       * Agent session started for user "root@vsoe13". (pid=8136)

=======  12/11/17 13:26:33 SST  END install AGENT SESSION (Cancelled)
         (pid=8136) (jobid=vsoe13-0007)


=======  12/11/17 13:30:44 SST  BEGIN remove AGENT SESSION (pid=8151)

       * Agent session started for user "root@vsoe13". (pid=8151)

       * Beginning Analysis Phase.
       * Target:           vsoe13:/
       * Target logfile:   vsoe13:/var/adm/sw/swagent.log
       * Reading source for file information.
       * The fileset "SecurityTools.TOOLSFILESET,l=/,r=B.01.04.10"
         requires the selected fileset
         "Secure_Shell.SECURE_SHELL,l=/opt/ssh,r=A.06.20.030" as a
         corequisite.
ERROR:   The dependencies for fileset
         "Secure_Shell.SECURE_SHELL,l=/opt/ssh,r=A.06.20.030" cannot be
         resolved (see previous lines).
         You must resolve the above dependencies before operating on
         this fileset or change the "enforce_dependencies" option to
         "false".

       * Summary of Analysis Phase:
ERROR:       Exclude       Secure_Shell.SECURE_SHELL,l=/opt/ssh,r=A.06.20.030
ERROR:   1 of 1 filesets had Errors.
ERROR:   The Analysis Phase had errors.  See the above output for
         details.


       * Beginning Analysis Phase.
       * Target:           vsoe13:/
       * Target logfile:   vsoe13:/var/adm/sw/swagent.log
       * Reading source for file information.
       * The fileset "SecurityTools.TOOLSFILESET,l=/,r=B.01.04.10"
         requires the selected fileset
         "Secure_Shell.SECSH-CMN,l=/opt/ssh,r=A.07.30.003" as a
         corequisite.
ERROR:   The dependencies for fileset
         "Secure_Shell.SECSH-CMN,l=/opt/ssh,r=A.07.30.003" cannot be
         resolved (see previous lines).
         You must resolve the above dependencies before operating on
         this fileset or change the "enforce_dependencies" option to
         "false".
       * The fileset "SecurityTools.TOOLSFILESET,l=/,r=B.01.04.10"
         requires the selected fileset
         "Secure_Shell.SECURE_SHELL,l=/opt/ssh,r=A.06.20.030" as a
         corequisite.
ERROR:   The dependencies for fileset
         "Secure_Shell.SECURE_SHELL,l=/opt/ssh,r=A.06.20.030" cannot be
         resolved (see previous lines).
         You must resolve the above dependencies before operating on
         this fileset or change the "enforce_dependencies" option to
         "false".
NOTE:    Could not remove the bundle "SecureShell,l=/,r=A.07.30.003"
         because not all of its filesets could be removed.

       * Summary of Analysis Phase:
ERROR:       Exclude       Secure_Shell.SECSH-CMN,l=/opt/ssh,r=A.07.30.003
ERROR:       Exclude       Secure_Shell.SECURE_SHELL,l=/opt/ssh,r=A.06.20.030
ERROR:   2 of 2 filesets had Errors.
ERROR:   The Analysis Phase had errors.  See the above output for
         details.


=======  12/11/17 13:34:13 SST  END remove AGENT SESSION (Canceled)
         (pid=8151)

Regards

Vincent

 

nothing is better than to know more
1 REPLY
Bhagw_p
Occasional Advisor
Solution

Re: Secure Shell Error

Hello Vincent,

 

This error could be because if the previous ssh ver is not installed properly.

1) Run check_patches to check if all the patches are in configured state. The report will be generated at /tmp/check_report*

2) Ensure all the patches / softwares are in configured state.

3) If there are any patches are in installed state, run # swconfig -x reconfigure=true <patchname>

4) try ssh update and check if the issue persists.

Hope this helps!!!