System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Secure Shell and OpenSSL (user sftp only)

 
SOLVED
Go to solution
Carme Torca
Super Advisor

Secure Shell and OpenSSL (user sftp only)

Hi,
I have one server 11.23 with
openssl A.00.09.07l.005
Secure_Shell A.05.00.025

but it doesn't works ok. I have create one user with sftp only, but it cans go to all the directorys in the server, and I want that the user only stay in its home.

I have download the versions (to prove if these versions solved the problem):

HP-UX Secure Shell - HP-UX 11i v2 - A.05.50.014 (T1471AA_A.05.50.014_HP-UX_B.11.23_IA_PA.depot)

OpenSSL - HP-UX 11i v2 -penSSL_A.00.09.08n.011
(OpenSSL_A.00.09.08n.011_HP-B.11.23_IA_PA.depot)

but when I install them, I have problems like this:

ERROR: Could not open remote depot/root
"/tmp/depots/OpenSSL_A.00.09.08n.011_HP-UX_B.11.23_IA_PA-v2.depot"
due to an RPC or network I/O error.
* Retry number 1 of 1 for product information.
ERROR: Could not open remote depot/root
"/tmp/depots/OpenSSL_A.00.09.08n.011_HP-UX_B.11.23_IA_PA-v2.depot"
due to an RPC or network I/O error.
ERROR: Cannot open source. Check above for errors, as well as the
daemon logfile on the source host (default location:
/var/adm/sw/swagentd.log

I have download the files twice and the errors are the same...
And now I don't know what to do.
Could anyone help me?

Thanks a lot of,
Carmen.

Users are not too bad ;-)
3 REPLIES 3
Jeeshan
Honored Contributor
Solution

Re: Secure Shell and OpenSSL (user sftp only)

run "swagentd -r" and try to install again
a warrior never quits
Highlighted
Jeeshan
Honored Contributor

Re: Secure Shell and OpenSSL (user sftp only)

or you may check the /etc/hosts file. May be there exist an incorrect IP or hostname.
a warrior never quits
Rita C Workman
Honored Contributor

Re: Secure Shell and OpenSSL (user sftp only)

I'm going to ignore your second section of issues (trying to install from a depot) because your issue first is - why isn't sftp working right.

You don't tell us what you did, just that you have SSH & SSL loaded. You mention you used sftp (i.e. OpenSSH), but that the user didn't stay in it's own directory. My guess is you may not have set up the account as chroot?

Attached is a script that may help you. When you run it, it will help guide you setting up a user as chroot-ed.
Just go back when it's done and make sure that your /etc/passwd puts a (./) after the users home directory path. That's /home/user/./:/bin/

Sometimes it will put extra path info you shouldn't have so you need to vipw and fix it.

Hope it helps,
Rita