Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
System Administration
Showing results for 
Search instead for 
Did you mean: 

Segmentation Fault w/ X11 apps on Red Hat 5.3

Go to solution
Victor Semaska_3
Esteemed Contributor

Segmentation Fault w/ X11 apps on Red Hat 5.3


I just started to install and use Red Hat 5.3 and I'm running into a problem. Whenever I run a X11 app that's piped to my Windows XP PC via X11 tunneling it aborts with Segmentation Fault. When I run the same app on a RHEL4 it runs fine.

I suspect the problem lies with the Xwindows emulator that I'm using. It's very old software called eXcursion. What I want to do is try a different emulator. Can anyone recommend one to try?

There are 10 kinds of people, one that understands binary and one that doesn't.
Honored Contributor

Re: Segmentation Fault w/ X11 apps on Red Hat 5.3

If your old Xwindows emulator sends bad data to your application, the X11 libraries should reject the data with a meaningful error message, *not* cause the application to crash with a generic Segmentation Fault. If your old Xwindows emulator truly causes this behaviour, it means either the application or the X11 library has a *very* basic programming error.

The X11 libraries required for X11 connection at the application end are pretty mature by now. I would expect that any bugs of this magnitude would have been found and fixed long ago. But everything is possible, I guess.

If you wish to try a newer Xwindows emulator, I've been successfully using Xming:


If your application (the exact same binary) runs fine unmodified on RHEL4, it is possible that the newer libraries on RHEL 5.3 are causing it some trouble. Recompiling the application on RHEL 5.3 might help, if you have the source code.

If that is not possible, you might use "ldd " to identify the libraries your application uses, copy the RHEL4 versions of those libraries to some directory (e.g. /usr/local/oldlibs) and then run your application with a custom LD_LIBRARY_PATH variable (e.g. start the application with "LD_LIBRARY_PATH=/usr/local/oldlibs application").

Because the old libraries have known bugs, you might wish to try and minimize the amount of old libraries used by your application. If the program runs successfully with the full set of old libraries, start removing the old libs one by one and see when the problem reappears.
When you have found the minimal set of old libraries that allows the program to run, you have a good workaround, and you can make a very informative bug report to the application developers.

Victor Semaska_3
Esteemed Contributor

Re: Segmentation Fault w/ X11 apps on Red Hat 5.3


Thanks for the information. What I did was download and install Xming. The app.s work with that fine although a little sluggish. It does seem that eXcursion was just too old.
There are 10 kinds of people, one that understands binary and one that doesn't.