System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Server not comming after reboot :(

SOLVED
Go to solution
bullz
Super Advisor

Server not comming after reboot :(

Hello Guruz,

I have just changed the hostname using set_parms hostname command... After the reboot, server seems to be not booting after changing hostname.

While booting from Alom, i have got the below error as shown below.

/sbin/auto_parms: DHCP access is disabled (see /etc/auto_parms.log)

I guess its something to do with auto_boot?
Please advice
17 REPLIES
SoorajCleris
Honored Contributor
Solution

Re: Server not comming after reboot :(

Hi,

What is the configuration in /etc/netconf ?

Is the DHCP enables? if no then do you have a valid IP address configured in /etc/netconf?

try to boot it in single user mod if it is not booting in any other mod.

Regards,
Sooraj
"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity" - Dennis Ritchie
Lijeesh N G_1
Respected Contributor

Re: Server not comming after reboot :(

Hi,

I think DHCP is enabled, ensure DHCP server is up.

If server is up, try to follow Sooraj's step,note that the file is /etc/rc.config.d/netconf

Regards,
LIJEESH N G
OldSchool
Honored Contributor

Re: Server not comming after reboot :(

"/sbin/auto_parms: DHCP access is disabled (see /etc/auto_parms.log)

I guess its something to do with auto_boot?"

actually, it isn't. DHCP is a method to dynamically assign ip address at boot time. You may not ever have had it configured or used it. If you didn't then that message is normal.

What makes you think that the server didn't come back after reboot? if you're testing by trying to ping (or otherwise connect) via the newly-assigned hostname (and you use DNS) did you update the DNS entries? Can you access it via the ip address? Can you access it via the OLD name?

Again, what do you see that makes you think it didn't come up? And what commands have you tried? What errors (if any) did they generate?
Raj D.
Honored Contributor

Re: Server not comming after reboot :(

Bultz,
Try booting off single user mode, and revert back the changes , and see what happens.

- what is the version of os. & hw model.
- Did you modified netconf.
- check files under /etc/rc.config.d/

Also pls provide more data to troubleshoot.


Cheers,
Raj.
" If u think u can , If u think u cannot , - You are always Right . "
bullz
Super Advisor

Re: Server not comming after reboot :(

Hello All,

Here is the content of file /etc/rc.config.d/netconf

INTERFACE_NAME[0]="lan1"
IP_ADDRESS[0]="10.188.36.14"
SUBNET_MASK[0]="255.255.255.0"
BROADCAST_ADDRESS[0]=""
INTERFACE_STATE[0]=""
DHCP_ENABLE[0]=0
INTERFACE_MODULES[0]=""

whenever i reboot server is not comming up until i boot via, alom...

But who -b o/p shows last reboot is happend 10 days back..

i doubt whether the connectivity fails :(

bash-4.0# who -b
. system boot Aug 10 07:46
bullz
Super Advisor

Re: Server not comming after reboot :(

Hoo i am sorry.. My system date is wrong :(
Its rebooting properly....

Server is not coming back after reboot :(
OldSchool
Honored Contributor

Re: Server not comming after reboot :(

"whenever i reboot server is not comming up until i boot via, alom...

But who -b o/p shows last reboot is happend 10 days back..

i doubt whether the connectivity fails :("

========================================================

"Hoo i am sorry.. My system date is wrong :(
Its rebooting properly...."

Server is not coming back after reboot :("
========================================================


What, EXACTLY, does the first sentece mean? The server doesn't autoboot?

What command(s) are you issuing to reboot and what action(s) do you take to correct the issue?



unix adm
Regular Advisor

Re: Server not comming after reboot :(

Try to boot the server once again monitor the boot logs carefully via GSP or MP , give last 10 lines of message where it gets stuck during boot.


Whats the hardware model & OS of the server?



Thanks - Rajeev
Mel Burslan
Honored Contributor

Re: Server not comming after reboot :(

As old school also indicated, your messages are quite contradictory. If it is rebooting properly, what do you mean by "not coming up after reboot" ? It is up but not accessible over the network ? If you are on the console, could you please elaborate the error messages you see ?
________________________________
UNIX because I majored in cryptology...
bullz
Super Advisor

Re: Server not comming after reboot :(

Hello Experts,

I am sorry for all confusion which I made earlier,
Let me describe what is the problem here exactly.

1) Yesterday I changed the hostname with the command of set_parms hostname
2) After changing the hostname I tried rebooting the server, looks server is not booting, I mean sever is not accessible other than alom.
3) In console I am getting into main menu (Main Menu: Enter command or menu >) after rebooting it :(
4) When I try to boot from console, I am getting the below message in console.


/sbin/auto_parms: DHCP access is disabled (see /etc/auto_parms.log)


HP-UX Start-up in progress
__________________________

Configure system crash dumps ........................................ OK
VxVM INFO V-5-2-3360 VxVM device node check ......................... OK
VxVM INFO V-5-2-3362 VxVM general startup ........................... OK
VxVM INFO V-5-2-3366 VxVM reconfiguration recovery .................. OK
Mount file systems .................................................. OK
Setting hostname .................................................... OK
Start Kernel Logging facility ....................................... OK
Set privilege group ................................................. N/A
Display date ........................................................ N/A
Copy processor logs to /var/tombstones .............................. OK
Save system crash dump if needed .................................... N/A
Start evp ........................................................... OK
Enable auxiliary swap space ......................................... OK
Start syncer daemon ................................................. OK
Start Utmp Daemon : manages User Accounting Database ................ OK
Configure Loopback interfaces (lo0) ................................. OK
VxVM INFO V-5-2-3370 VxVM volume recovery start ..................... OK
Configuring all unconfigured software filesets ...................... OK
Configuring PFIL .................................................... OK
Starting IPFilter ................................................... OK
Configuring Install Time Security ................................... N/A
Recover editor crash files .......................................... OK
Clean UUCP .......................................................... OK
List and/or clear temporary files ................................... OK
Clean up old log files .............................................. OK
Start system message logging daemon ................................. OK
Start pty allocator daemon .......................................... OK
Configuring OLA/R interface ......................................... N/A
Start network tracing and logging daemon ............................ OK
Configure HP igelan Gigabit Ethernet interfaces ..................... OK
Configure HP iether 100BT/Gigabit Ethernet interfaces ............... OK
Configure HP gelan Gigabit Ethernet interfaces ...................... OK
Create PCI FDDI device files. ....................................... OK
Configure HP 100BASE-T interfaces ................................... N/A
Configure VLAN interfaces ........................................... OK
Configure LAN interfaces ............................................ OK
Configure LAN interfaces for IPv6 ................................... OK
Starting DHCPv6 Server daemon ....................................... N/A
Configuring DHCPv6 Interfaces ....................................... OK
Start name server daemon ............................................ N/A
Starting HP-UX Secure Shell ......................................... OK
Start NFS core subsystem ............................................ OK
Start NIS+ server subsystem ......................................... OK
Start NIS+ client subsystem ......................................... OK
Start NIS server subsystem .......................................... OK
Start ldap client daemon ............................................ N/A
Start NIS/LDAP server subsystem ..................................... N/A
Start NIS client subsystem .......................................... OK
Start NFS client subsystem .......................................... OK
Start the Trusted Mode with NIS+ subsystem .......................... N/A
Start multicast routing daemon ...................................... N/A
Start Internet services daemon ...................................... OK
Start dynamic routing daemon ........................................ N/A
Start router discover protocol daemon ............................... N/A
Configuring PPP Interface ........................................... OK
Configuring PPPoE ................................................... N/A
Start RARP protocol daemon .......................................... N/A
Start remote system status daemon ................................... N/A
Start IPv6 router advertisement daemon .............................. N/A
Starting mail daemon ................................................ OK
Starting cfengine's cfservd daemon .................................. N/A
Starting syslog-ng daemons .......................................... N/A
Starting outbound connection daemons for DDFA software .............. N/A
Starting sfmdb PostgreSQL daemons ................................... OK
Start SNMP Master Network Management daemon ......................... OK
Start OSPF MIB Network Management subAgent .......................... N/A
Start SNMP HP-UNIX Network Management subAgent ...................... OK
Start SNMP IPv6 Network Management subAgent ......................... OK
Start SNMP MIB-2 Network Management subAgent ........................ OK
Start Native Adapter Agent .......................................... OK
Start SNMP Trap Dest Network Management subAgent .................... OK
Start DCE daemons ................................................... N/A
Start SNMP PCI FDDI Network Management subAgent ..................... OK
Start RPC daemon if needed .......................................... OK
Start CIM cimserver subsystem ....................................... OK
Initialize Instant Capacity ......................................... N/A
Starting ISEE hpservices mad daemon. ................................ N/A
Start Runner ........................................................ N/A
Starting X Font Server at TCP port 7000 ............................. N/A
Start vt daemon ..................................................... N/A
Start time synchronization .......................................... N/A
Start accounting .................................................... N/A
Install/Load XF86 DLKM Helper Modules ............................... N/A
Starting the password/group assist subsystem ........................ OK
Starting HP Disk Array Manager daemons. ............................. OK
Start print spooler ................................................. N/A
Start clock daemon .................................................. OK
Run Security Patch Check Utility .................................... N/A
Start diagnostic subsystem .......................................... OK
Start environment monitoring daemon ................................. OK
Start auditing subsystem ............................................ N/A
Start audio server daemon ........................................... N/A
Start Distributed Single Logical Screen daemon ...................... N/A
Start USB hub daemon ................................................ OK
SAM System administration configuration ............................. OK
Initialize Software Distributor agent daemon ........................ OK
Starting the System Management HomePage server ...................... OK
Starting the gWLM Agent ............................................. N/A
Starting CIFS Client ................................................ N/A
Configure HP RAID SA interfaces ..................................... N/A
Copy processor logs to /var/tombstones .............................. OK
Starting Event Monitoring Service ................................... OK
Start EMS SNMP subagent ............................................. OK
Configure HP Fibre Channel Mass Storage interfaces .................. OK
Configuring Ultra320 SCSI Mass Storage interfaces ................... N/A
Starting the Winbind Daemon ......................................... N/A
Starting the RST EMS listener ....................................... N/A
Configure HP Fibre Channel Tachyon TL/TS Mass Storage interfaces .... OK
Configuring HP Fibre Channel FCD Mass Storage interfaces ............ OK
VxVM VVR INFO V-5-2-3502 Starting Communication Daemon .............. N/A
VxVM VVR INFO V-5-4-2409 Starting VRAS daemon ....................... N/A
VxVM VVR INFO V-5-4-2409 Starting VxRSync daemon .................... N/A
Starting VERITAS Enterprise Administrator Service (vxsvc) ........... OK
Start NFS server subsystem .......................................... OK
Start X print server(s) ............................................. N/A
Starting HP-UX Apache-based Web Server .............................. N/A
Starting HP-UX Tomcat-based Servlet Engine .......................... N/A
Starting HP-UX Webmin-based Admin ................................... N/A
Starting the HPUX Webproxy subsystem ................................ N/A
Starting HP-UX XML Web Server Tools ................................. OK
Start kwdbd ......................................................... N/A
Start NDDB Comm Server .............................................. N/A
Start CDE login server .............................................. OK
Starting PRNGD (Pseudo Random Number Generator Daemon) .............. N/A
Mel Burslan
Honored Contributor

Re: Server not comming after reboot :(

and does it stop at this last line :

Starting PRNGD (Pseudo Random Number Generator Daemon) .............. N/A

or will it continue to give you a login prompt ?
________________________________
UNIX because I majored in cryptology...
Lijeesh N G_1
Respected Contributor

Re: Server not comming after reboot :(

Hi,

Now what is the present status, Is it hanging here or are you getting login prompt??

Regards,
LIJEESH N G
bullz
Super Advisor

Re: Server not comming after reboot :(

I am geting the login prompt as normal after this.

But don't know y it's not coming up after the reboot automaticaly untill i boot it from console :(

V. Nyga
Honored Contributor

Re: Server not comming after reboot :(

Hi,

maybe you should enlighten us what 'alom' is?

Also which messages do you see when connecting to console?
Can you watch the boot process when rebooting?
Can you post your /etc/hosts?

There are still some open questions, if I haven't overread something - so what os do you have? What hardware is the server?

V.
*** Say 'Thanks' with Kudos ***
Torsten.
Acclaimed Contributor

Re: Server not comming after reboot :(

3) In console I am getting into main menu

(Main Menu: Enter command or menu >)


Well, autoboot is not set.

Boot it up and do

# setboot -b on

# setboot -s on

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Mel Burslan
Honored Contributor

Re: Server not comming after reboot :(

>> But don't know y it's not coming up after the reboot automaticaly untill i boot it from console :(

because your autoboot setting somehow got obliterated by something you did or your terminal emulator caused at the console. Right now, I do not have the luxury of crashing one server to check what exactly you need to do to restore this but when you stop at the menu where you have type boot hit enter to let it go boot, instead of typing boot, you need to select the settings or configuration or something similar, to go in and change the autoboot setting. Right now it is set not to autoboot. when you change it, it will wait 10 seconds and will go and boot from the primary boot device. As I said,I do not remember the menu prompts so well anymore.
________________________________
UNIX because I majored in cryptology...
bullz
Super Advisor

Re: Server not comming after reboot :(

Thanx all who all replied.