cancel
Showing results for 
Search instead for 
Did you mean: 

Slowness of system

SOLVED
Go to solution
Danesh Qureshi
Regular Advisor

Slowness of system

I have HP DL380 G4 server running RedHat AS 3 taroon update 4.

The server is running an application called WebCT Vista 4 which generates several java processes.

I started to notice the server was running very slow and affecting performance.

The top command displayed CPUs were idle around 75% to 100% idle. However. memory utilization was hitting 52%.

I wanted to investigate further so I used the ps command to check the process id of the java application displayed by top but ps would not display those java process ids?

Does anyone know why top displays process ids which ps cannot detect?

Also ideas why the server running slow?

I have attached which displays output of top command.


7 REPLIES
Ivan Ferreira
Honored Contributor
Solution

Re: Slowness of system

You miss the attachment. If you see in top, then exit, and run ps, maybe the process are respawning too fast. Are you running ps auxw?

Also, you should investigate I/O activity. It's not common to have 52% of memory used, Linux normally tries to use 99% of memory.

Please post the output of:

vmstat 5 10
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Danesh Qureshi
Regular Advisor

Re: Slowness of system

The slowness occurred yesterday on the server and I captured the output of top from yesterday.

The server has since been rebooted.

The first output of top is from yesterday before the reboot.

The second output of vmstat is from today since yesterdays's reboot.

Danesh Qureshi
Regular Advisor

Re: Slowness of system

Output of top from yesterday before reboot.
Ivan Ferreira
Honored Contributor

Re: Slowness of system

>>> I started to notice the server was running very slow and affecting performance.

Are you sure that the server was slow? Or the application was slow?

This is because, according to the output of top, your server wans't doing anything.

Java process do not uses CPU, and most CPU was idle. Memory utilization could be normal, your load average was very slow. There was no IO WAIT, swap was not in use, so that makes me assume that the system wasn't paging.

So, was the server really slow or just the application unresponsive? If you login to the system, and run some commands, you notice is slow also?

Have you verified if you have some network related problems? Check the output of netstat -ni if you see errors/collisions.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Danesh Qureshi
Regular Advisor

Re: Slowness of system

The server was not slow it was the application that was very slow.

I was able to type any unix command e.g. ps,vmstat,ls,watch and it responded back immediately. However, the WebCT application was very slow on the server.

There were no network related issues.We also checked the F5 load balancer and there was not much traffic going through it.

I have attached the output netstat -ni.

So if the server response was not the problem and the application was runnin very slow then what does this mean and I do find a solution for it?
Ivan Ferreira
Honored Contributor

Re: Slowness of system

The applications developers must debug the application. This problem is application related, not server related.

Also, please keep asigning points.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Danesh Qureshi
Regular Advisor

Re: Slowness of system

I have assigned points to you accordingly.

I will get back to the DBA who look after the WebCT application and run debug on the application.

Thank you for your advice.