System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Storageworks Ultrium 232 and proliant DL380 G4

 
DanielATU
Advisor

Storageworks Ultrium 232 and proliant DL380 G4

Hi all,
I have Storageworks Ultrium 232 and proliant DL380 G4(with linux instaled on it)

Ultrium connected to SCSI on back side of DL380.

Problem is system doesnt see Ultrium (from linux I mean) -

The first think I donn't know how to check is Ultrium connected to raid controler or to external SCSI controloer? When pressing f8 after rebooting there is only disks attached all 6 slots bay used if it helps.

The second think dmesg showed only one message regarding SCSI

SCSI subsystem initialized

but cat /proc/scsi/scsi
sowed nothing attached

lsmod showed no st loaded
I load it manualy now st loaded.

On external SCSI LUN is 0.


So can any body help me making them both work?????

Thanks for all...
10 REPLIES
Steven E. Protter
Exalted Contributor

Re: Storageworks Ultrium 232 and proliant DL380 G4

Shalom,

Suggest you fire up hwbrowser application and see what details you find on the hardware.

Set the scsi id on the drive to a number other than zero.

This drive needs its own scsi card and should not be daisy chained.

Check cable and power and such.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
skt_skt
Honored Contributor

Re: Storageworks Ultrium 232 and proliant DL380 G4

Please post "lspci" and "cat /proc/scsi/scsi" and lsmod

Also there might be some jumper settings . Check with the vendor if any change required from the default factory shipping.

For IBM drives there is a tool itdt(refer the readme.txt comes along with ) to scan and test the tape drives.
DanielATU
Advisor

Re: Storageworks Ultrium 232 and proliant DL380 G4

thank you all from assistance :)

requested info in attachment.

I changed lun on Ultrium SCSI to 6, made it restart - nothing changed. Do I need to restart server(I need to wait after 6 pm- production server :( )?

a llitle about ls mod

I added module st , but now I found next

scsi_mod 116557 5 st,sg,aic7xxx,cciss,sd_mod

the scsi mod is used by st and others is it means that problem is not in software and everuthing set upu properly?

Module Size Used by
st 40029 0
sg 38113 0
autofs4 22085 0
i2c_dev 14273 0
i2c_core 25921 1 i2c_dev
ipt_REJECT 10561 1
ipt_state 5825 11
ip_conntrack 45957 1 ipt_state
iptable_filter 6721 1
ip_tables 21441 3 ipt_REJECT,ipt_state,iptable_filter
md5 8001 1
ipv6 238817 26
dm_mod 57157 0
button 10449 0
battery 12869 0
ac 8773 0
uhci_hcd 32729 0
ehci_hcd 31813 0
tg3 79173 0
floppy 58065 0
aic7xxx 146552 0
ext3 118473 8
jbd 59481 1 ext3
cciss 45221 11
sd_mod 20545 0
scsi_mod 116557 5 st,sg,aic7xxx,cciss,sd_mod


Additional questions

I ran command MAKEDEV st
it created huge number of files in /dev

I just removed this newly created files by rm command. Is I will receive some errors after rebooting :). I didnt found how can I remove devices created by MAKEDEV :(
DanielATU
Advisor

Re: Storageworks Ultrium 232 and proliant DL380 G4

missed attachment
DanielATU
Advisor

Re: Storageworks Ultrium 232 and proliant DL380 G4

Ok while booting process

SLOT 0 HP Smart Array 6i Controller (64,v.36)
1775 - SLOT 0 DRIVE ARRAY - PROLIANT STORAGE enclosere not responding
SCSI PORT 1: check storage encloser power switch and cables
and bla bla bla.

I switched cale on ULTRIUM rack from one port to another then rebooted both and while booting i received.

SLOT 0 HP Smart Array 6i Controller
TYPE or CD-ROM DRIVE(S) DETECTED:
SCSI PORT 1 : SCSI ID 3

Then ultrium apeared in OBDR MENU - That is RESULT! :)

BUT

in linux again same problems nothing seems that ultrium attached.

and

I discovered that my SCSI in SIMPLEX MODE...


If I change it to emmbeded duplex mode will i receive any result(searching for terminator right now cant check yet)?

Plus

SCSI ID 3 (as i know it by default)

how can I changed it to for example 6?

Can there be any conflicts whith this ID 3..

I am using DL380 embede port on backpanel to connet Ultrium

Thank you All in advance



Joshua Small_2
Valued Contributor

Re: Storageworks Ultrium 232 and proliant DL380 G4

Hi,

You can see from the output, you have the drive connected to the smart array controller.

I would suggest if you do not have a SCSI card in a PCI slot, that you should get one.
DanielATU
Advisor

Re: Storageworks Ultrium 232 and proliant DL380 G4

Dear Joshua, I am newbie to proliant I only work with it for 2 days long.

Can you explaint why I can't use SCSI port on Motherboard?

I made fantastic thing I was able to write small file to type :)))). But then Error apears and everything is gone....

I ran this commands in this order (took from history, and I deleted not important commands betwhin these)

insmod st
cat /proc/scsi/scsi
cd /dev/
modprobe st
vi /etc/scsi_id.config
scsi_id -v
scsi_id -s
ls /sys/block
ls /sys/block/cciss
ls /proc/driver/cciss/cciss
vi /proc/driver/cciss/cciss0
echo "engage scsi" > /proc/driver/cciss/cciss0
echo "engage scsi" > /proc/driver/cciss/cciss0
echo "rescan" > /proc/scsi/cciss/0
mknod /dev/st0 c 9 0
# mt -f /dev/st0 rewind
mt -f /dev/st0 status
tar tvf /dev/st0
vi /proc/driver/cciss/cciss0
echo "engage scsi" > /proc/driver/cciss/cciss0
cat /proc/scsi/scsi


I don't know how but in /dev I saw next files - st0 st0l st0m tape1 type2 type3 type4 nst0 and so on.


I ran dmesg and what i saw there

st: Version 20040403, fixed bufsize 32768, s/g segs 256
ERROR: SCSI host `cciss' has no error handling
ERROR: This is not a safe way to run your SCSI host
ERROR: The error handling must be added to this driver
[] scsi_host_alloc+0x8d/0x325 [scsi_mod]
[] cciss_scsi_detect+0x13/0x8b [cciss]
[] cciss_engage_scsi+0x221/0x226 [cciss]
[] cciss_proc_write+0xc1/0xd4 [cciss]
[] open_namei+0x229/0x57e
[] dentry_open+0xe0/0x180
[] filp_open+0x36/0x3c
[] proc_file_write+0x23/0x27
[] vfs_write+0xb6/0xe2
[] sys_write+0x3c/0x62
[] syscall_call+0x7/0xb
scsi0 : cciss
Vendor: HP Model: Ultrium 1-SCSI Rev: P23D
Type: Sequential-Access ANSI SCSI revision: 03
Attached scsi tape st0 at scsi0, channel 0, id 0, lun 0
st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA 4294967295
cciss0: SCSI subsystem already engaged.
cciss0: No device changes detected.
cciss0: SCSI subsystem already engaged.
st0: Block limits 1 - 16777215 bytes.
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 1

I want your attention on error what it means?


then iplayed with type
tar cvf /dev/st0 text

tar xvf /dev/st0 text

after a wile i ran hp_ltt and start automatic device discover after this my device is gone dmesg showed me

cciss: cp c2285280 timedout
scsi: Device offlined - not ready after error recovery: host 0 channel 0 id 0 lun 0

and

cat /proc/scsi/scsi again showed nothing attached

lsmodo showed some additional module pop up - sg

when I remove it modprobe -r sg

my Sequential access device is gone to

cat /proc/driver/cciss/cciss0
showed Sequential access devices: 0
but before it was one

cciss0: HP Smart Array 6i Controller
Board ID: 0x40910e11
Firmware Version: 2.36
IRQ: 5
Logical drives: 2
Current Q depth: 0
Current # commands on controller: 0
Max Q depth since init: 4
Max # commands on controller since init: 384
Max SG entries since init: 31
Sequential access devices: 0

cciss/c0d0: 145.65GB RAID 5
cciss/c0d1: 146.80GB RAID 0


can anybody explain me what i did to add Sequential access devices and able to work with type? what the errors means? and only the way to atache TYPE is buy SCSI PCI card?
and why my Ultrium was attached to
host 0 channel 0 id 0 lun 0 (i saw wile boot that id was 3 and here it is 0)?

Thank you

P.S.

Dear People you are writing verry un informative, by default for you as a person who ask already GOD of proliant and unix. I searched whole forum and didnt see any nice solution with command that user must run, with brief that explaining. For example this post "fire up hwbrowser" why do i need it? am i need it at all? no body answered even how I can change SCSI ID?

and Joshua wrote just change card withou explaining details :(


Allot of people are newbies in diff levels.

and I am a lammer in this and I need yours help and detailed help :) .

Thgank you verry much
Joshua Small_2
Valued Contributor

Re: Storageworks Ultrium 232 and proliant DL380 G4

Hi,

The SCSI port you are using is not a SCSI port - it is a RAID port. It is connected to the Smart Array RAID card, and not suited for connecting to a tape drive.
skt_skt
Honored Contributor

Re: Storageworks Ultrium 232 and proliant DL380 G4


here is what my systems i have.. a separate card for scsi tape device as below

04:04.0 SCSI storage controller: Adaptec ASC-29320ALP U320 (rev 10)

and this is the raid card for the disks used in the system.

08:0e.0 RAID bus controller: Adaptec ServeRAID Controller (rev 07)
DanielATU
Advisor

Re: Storageworks Ultrium 232 and proliant DL380 G4

I played with type and it seems to work even on RID inerface. As nobody showed any type of errors that can be ocured I am going to the next step installing backup software. Thank you for all for trying to help.