System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Strange behavior on resolv.conf file !!

SOLVED
Go to solution
Ivan Azuara
Regular Advisor

Strange behavior on resolv.conf file !!

Hi

I have an strange behavior on my hpux servers. We have 2 dns servers defined into the resolv.conf file, but today one of them fails, and my users start to call me with problems about ftp hangs, problems with the resolution names, etc,etc.

This is the content of my resolv.conf file:

search banco.gfi.mx seguros.gfi.mx gfi.mx portalgfi.mx
nameserver 146.219.220.196 # DNS1
nameserver 146.219.244.102 # DNS2 ---> FAILS

my quick solution now, was to comment the second dns entry and all the problems disapear.

search banco.gfi.mx seguros.gfi.mx gfi.mx portalgfi.mx
nameserver 146.219.220.196 # DNS1
#nameserver 146.219.244.102 # DNS2

Some idea about this strange behavior ??

Regards.


"Enjoy the life .."
6 REPLIES
Denver Osborn
Honored Contributor

Re: Strange behavior on resolv.conf file !!

Review the "hosts:" entry in your /etc/nsswitch.conf file.

Also read up on the resolv.conf man page... see the retry and retrans options.


-denver
Steven E. Protter
Exalted Contributor

Re: Strange behavior on resolv.conf file !!

Shalom,

/etc/nsswitch.conf controls how DNS goes to secondary DNS entries.

It needs to be looked at.

More basically, make sure you can pint all the name servers.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ivan Azuara
Regular Advisor

Re: Strange behavior on resolv.conf file !!

What about my nsswitch.conf file ??

#
# /etc/nsswitch.files:
#
# @(#)B.11.11_LR
#
# An example file that could be copied over to /etc/nsswitch.conf; it
# does not use any name services.
#
passwd: files
group: files
hosts: dns [NOTFOUND=continue UNAVAIL=continue TRYAGAIN=continue] files [NOTFOUND=return UNAVAIL=continue TRYAGAIN=return] dns [NOTFOUND=return UNAVAIL=continue TRYAGAIN=return]

Do you have some recomendation or maybe has a lot of unnecessary options for the hosts entry ??

Regards !!
"Enjoy the life .."
Shibin_2
Honored Contributor

Re: Strange behavior on resolv.conf file !!

>> hosts: dns [NOTFOUND=continue UNAVAIL=continue TRYAGAIN=continue] files [NOTFOUND=return UNAVAIL=continue TRYAGAIN=return] dns [NOTFOUND=return UNAVAIL=continue TRYAGAIN=return]

You don't need to specify these default policies there. Just mentions as

hosts: dns files

or simply

hosts: dns
Regards
Shibin
Ivan Azuara
Regular Advisor

Re: Strange behavior on resolv.conf file !!

In fact these policies are defined automatically when i use the sam utility.

Regards ...
"Enjoy the life .."
Shibin_2
Honored Contributor
Solution

Re: Strange behavior on resolv.conf file !!

Take a backup and edit it as

hosts: files [NOTFOUND=continue] dns

Try this option.
Regards
Shibin