cancel
Showing results for 
Search instead for 
Did you mean: 

Swapinfo High (100%)

Akif_1
Super Advisor

Swapinfo High (100%)

Hi All,
On my production server rp7410 with OS 11i last week i upgraded memory from 5G to 8G x4, But my problem is that on one of the node(DB1) out of four, shows me swapinfo percentage were 100. where as other 3 where normal,
What i noticed is that i usuallay use DB1 for export a file of 5GB. After completion of this job the swapinfo were not reducing.
What were the solution for this


Thanks in Advance
T(ogether) E(very one) A(chive) M(ore)
14 REPLIES
sajeer_2
Regular Advisor

Re: Swapinfo High (100%)

What is your swap size?Did you increase swap space after memory upgrade?.
Add a secondery swap and see the performance.
Michael Steele_2
Honored Contributor

Re: Swapinfo High (100%)

You have 8GB of RAM in DB1. So for DB1 attach:

swapinfo -tam

vmstat 4 4

And check for memory leaks:

# UNIX95= ps -ef -o pid,ppid,vsz,sz,cpu,args|sort -k3nr|more



Support Fatherhood - Stop Family Law
Akif_1
Super Advisor

Re: Swapinfo High (100%)

Dear Michel n Sajeer,
The output of above were as follows and bcz of small space in our drives we are unable to create new swap, as we have old swap which works before on 5GB..... Please follow attach file for more details.....



Cheez:)


T(ogether) E(very one) A(chive) M(ore)
Steven E. Protter
Exalted Contributor

Re: Swapinfo High (100%)

Shalom,

Due to the format of the attachment it is hard to read it and interpret the results, at least for me.

swapinfo -tam would be helpful.

It would appear however that your system is under memory stress from Oracle and java.

The real solution to this problem is to lower memory use, perhaps by adjusting the buffer or the oracle SGA or add memory to the system.

Too much swap will not make the system faster.

http://www.hpux.ws/system.perf.sh

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Michael Steele_2
Honored Contributor

Re: Swapinfo High (100%)

Steve, save it to disk and open it with word.

This all looks normal to me. Is DB1 at the same patch level as the other four nodes? Same with glance if that's what you're using.

Can you paste in:

ipcs -moba
Support Fatherhood - Stop Family Law
Akif_1
Super Advisor

Re: Swapinfo High (100%)

Hi Steel,


Please follow an attach file of ipcs -moba, and dbc_max_pct 50 and dbc_max_pct 5, as on upgraded 8GM of RAM,,,,


Thanks in Advance
T(ogether) E(very one) A(chive) M(ore)
Steven E. Protter
Exalted Contributor

Re: Swapinfo High (100%)

Shalom,

Oracle is better at buferring its own data than the OS.

You can significantly decrease your memory use by changing dbc_max_pct to a lower number like 5 6 or 7.

This will reduce memory pressure by hunreds of megabytes.

You should also check with the DBA's and see if they can make memory consumption reduction in the oracle SGA's.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Akif_1
Super Advisor

Re: Swapinfo High (100%)

Hi Stee,
Sorry for mistake my dbc_max_pct 50 and dbc_min_pct 5, So is this improve my server performance, eventhough SGA max size is 2432M , with 4.5(Approx) of export data. and EVA has its own cache batteries on the controller.


Help me to release this 100% high memory in one of the 4 servers ... i.e:DB1.


Cheez:)
T(ogether) E(very one) A(chive) M(ore)
Bill Hassell
Honored Contributor

Re: Swapinfo High (100%)

Well, the first change is to reduce dbc_max_pct from 50 to 3. That will return almost half of your memory. The default setting (50) is just plain bad for any sized system.

Also, in your previous attachment with a ps listing, the command was:

ps -ef pid,ppid,vsz,sz,cpu,args|sort -k3nr|more

which does not show memory usage and should have been:

UNIX95=1 ps -ef -o pid,ppid,vsz,sz,cpu,args|sort -k3nr|more

If you used the -o option without UNIX95=1 then ps will give you an error. To make memory usage easier to read:

UNIX95=1 ps -ef -o vsz,pid,ppid,sz,cpu,args|sort -k3nr|more

which put VSZ first and the largest processes will sort to the top. Just a note that glance (an priced product from HP) is invaluable in understanding and managing system resources in HP-UX.


Bill Hassell, sysadmin
Akif_1
Super Advisor

Re: Swapinfo High (100%)

Hi Bill,
I go through with hp.docs ...... http://docs.hp.com/en/B2355-60105/dbc_min_pct.5.html?btnNext=next%A0%BB which shows me different picture of dbc_max_pct not to disturb or do calculation before making mind to change dbc_max_pct or dbc_min_pct
and other result of UNIX95 enclosed ......
I appreciate ur help and need more to close this thread...


Thanks,
T(ogether) E(very one) A(chive) M(ore)
Michael Steele_2
Honored Contributor

Re: Swapinfo High (100%)

From your vmstat report which indicated zero idle time and your unix95 report, ora_d000 and ora_s000 are you're two biggest cpu consumers.

UNIX95=1 ps -ef -o pid,ppid,vsz,sz,cpu,args|sort -k3nr|more

6124 1 102464 25616 193 ora_d000_NPRD1
10770 1 102976 25440 72 ora_s000_NPRD1

However you've also got 14 NFS daemons up and running and that's a lot of NFS activity. Have you investigated NFS reports?

As I understand it DB1 is the only node out of four that are reacting poorly in this serviceguard environment. How is your serviceguard cluster mapped into these nodes? Do you have 14 NFS daemons up on these other nodes? Is the speed and duplex correctly set for DB1 and different for the other nodes?

Is oracle relying on nfs mounted filesystems?

These are the only configuration issues I can see in the O/S. Everything else points to the Oracle side of the server. But in reviewing the UNIX95 report I don't see a lot of memory problems. So I'd concentrate on what's different with DB1 and the other nodes and start comparing configurations.

What's your lan speed and duplexs on every node?
Support Fatherhood - Stop Family Law
Akif_1
Super Advisor

Re: Swapinfo High (100%)

Dear Michel,

How to check this duplex speed of nic as i go through with my cfg2html file displays me this output in all the four servers. (Technology Specific:
Speed/Duplex = NO LINK AUTONEG )

Cheez:)
T(ogether) E(very one) A(chive) M(ore)
nanan
Trusted Contributor

Re: Swapinfo High (100%)

Hi Akif

Use lanadmin
lanadmin -x

You can get the PPA NO you concerned with lanscan

Regards
nanan
Akif_1
Super Advisor

Re: Swapinfo High (100%)

Thanks for your valuable support
T(ogether) E(very one) A(chive) M(ore)