cancel
Showing results for 
Search instead for 
Did you mean: 

Swlist error

Jayan Nair
Frequent Advisor

Swlist error

Hello,

I am getting error while executing swlist.
# swlist
# Initializing...
# Contacting target "HBPTCI02"...
WARNING: Incomplete definition for the root (installation) "/",
beginning at line 0. The following attributes are not
defined:
products the products contained in the root
ERROR: The depot "ptc1250:/" exists but is currently empty.

Kindly advice me on this issue.

Thanks in advance

Jay
6 REPLIES
Dennis Handly
Acclaimed Contributor

Re: Swlist error

Have you fiddled with the IPD?
/var/adm/sw/products/

You are probably going to have to get it back from your ignite backup.
Ganesan R
Honored Contributor

Re: Swlist error

Hi Jayan,

It could be due to INDEX file corruption. Backup your existing configuration, then execute these steps to regenerate the INDEX file:

# cd /var/adm/sw/products
# mv INDEX INDEX.orig
# cd /tmp
# vi void.psf
product
tag void
fileset
tag void
:wq!
# swpackage -s /tmp/void.psf
# swinstall void
# swremove void
# rm void.psf
# swremove -d void
Best wishes,

Ganesh.
Jayan Nair
Frequent Advisor

Re: Swlist error

Hello,
I have done all the above steps now getting
# swlist
# Initializing...
# Contacting target "HBPTCI02"...
ERROR: The expected depot or root does not exist at "/".
ERROR: There is currently no installed software on host "ptc1250" at
location "/".
Robert-Jan Goossens_1
Honored Contributor

Re: Swlist error

Hi Jay,

Did someone remove the installed products from the /var/adm/sw/products/ directory?

Regards,
Robert-Jan
Ganesan R
Honored Contributor

Re: Swlist error

Hi Jayan,

All the product directory exists under /var/adm/sw/products ?

If not you need to restore it from your recent backup.
Best wishes,

Ganesh.
Jayan Nair
Frequent Advisor

Re: Swlist error

thanks all