System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

System ask for runlevel at boot

Pietro84
Advisor

System ask for runlevel at boot

I dont know why my system ask for runlevel everytime I reboot it.

 

This is the log from console MP:

 

Checking root file system.
file system is clean - log replay is not required
Root check done.
Create STCP device files
$Revision: vmunix: B11.23_LR FLAVOR=perf Fri Aug 29 22:35:38 PDT 2003 $
Memory Information:
physical page size = 4096 bytes, logical page size = 4096 bytes
Physical: 12555920 Kbytes, lockable: 9767760 Kbytes, available: 11276828 Kbytes

/sbin/ioinitrc:
/dev/vg00/lvol1:file system is clean - log replay is not required
/sbin/krs_sysinit:
* The module 'j3526' has been loaded.
* The module 'sxb' has been loaded.
* The module 'synchal' has been loaded.
TSCTTL: init called
TSCTTL: initiated successfully
tracing & logging driver installed succesfully with major number
<<< Ok
* The module 'mmm' has been loaded.
* The module 'mbm' has been loaded.
* The module 'tscttl' has been loaded.
* The module 'octtldrv' has been loaded.
* The module 'dmpaa' has been loaded.
* The module 'dmpaaa' has been loaded.
* The module 'dmpap' has been loaded.
* The module 'dmpapg' has been loaded.
* The module 'dmpapf' has been loaded.
* The module 'dmpjbod' has been loaded.
* The module 'dmphpalua' has been loaded.
* The module 'dmphdsalua' has been loaded.
* The module 'ipf' has been loaded.
* The module 'rng' has been loaded.
* The module 'gvid_info' has been loaded.
* The module 's_sctp' has been loaded.
* The module 'xid' has been loaded.

insf: Installing special files for ipmi instance 0 address 250/0


ENTER RUN LEVEL (0-6, s, or S):

 

 

How can I disable this? and start with default runlevel everytime?

 

Thanks

3 REPLIES
Matti_Kurkela
Honored Contributor

Re: System ask for runlevel at boot

The /etc/inittab file on your system might be damaged somehow.

 

Normally the default runlevel is specified on the first line of /etc/inittab, which should look like this:

init:3:initdefault:

 A "factory default" inittab file can be found at /usr/newconfig/etc/inittab: you should check your current /etc/inittab should contain at least all the lines of the factory default inittab, unless you have an extremely good reason to remove something.

 

Certain HP-UX components (e.g. OnlineJFS, CIM/WBEM, EMS resource monitoring) and other software may add extra lines to /etc/inittab when installed.

MK
rariasn
Honored Contributor

Re: System ask for runlevel at boot

Hi:

 

if boot init does not find an initdefault  entry in inittab, it requests an   initial run level from the user at                       boot time.

 

man 4 inittab

 

rgs,

Pietro84
Advisor

Re: System ask for runlevel at boot

Hello,

thaks for replies.

 

I have seen that inside /etc/inittab it miss this entry:

 

init:3:initdefault

 

Now is ok.

 

Thanks