cancel
Showing results for 
Search instead for 
Did you mean: 

System log error

System log error
Occasional Advisor

System log error

Hi,

Im got this system logs in our HP-UX 11i,

Feb 10 16:32:43 MIH-PROD inetd[927]: discard/tcp: accept: Bad file number
Feb 10 16:32:43 MIH-PROD ftpd[2361]: getpeername (ftpd): Invalid argument
Feb 10 16:32:43 MIH-PROD sshd[2360]: error: setsockopt SO_KEEPALIVE: Invalid a
Feb 10 16:32:51 MIH-PROD remshd[2369]: read: Connection reset by peer

how critical is this and how to reslove? Thanks

PAUL
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: System log error

Shalom Paul,

You are having DNS name resolution problems.

Check the servers defined in /etc/resolv.conf provide proper answers and can be reached.

IF not change them.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
System log error
Occasional Advisor

Re: System log error

Hi Steven,

No such file as resolv.conf in /etc directory. how this error occured? is there somebody trying to access the server thats why these logs are generated?

PAUL
Laurent Menase
Honored Contributor

Re: System log error

What is your os version & ARPA patch?

is it permanent or just sometimes?

Are you using 3rd party application like centrify one?
what do you have in nsswitch.conf

usually it means that a socket have been closed in inetd unexpectedly.

The only know case is with third party nss services installed. - they close a socket they don't own-

System log error
Occasional Advisor

Re: System log error

Hi Steven,

That day ive disabled the SNMP port, do u thuink this is the cause?

Paul
Laurent Menase
Honored Contributor

Re: System log error

Hi Paul,

No
clearly your inetd had closed some of its sockets unexpectedly.
what do you have in your /etc/nsswitch.conf?

is it something which happens often or just once?
System log error
Occasional Advisor

Re: System log error

Hi,

What i did is i stopped snmp using the command "/sbin/init.d/snmpdm stop".
I found no nsswitch.conf in /etc but:
nsswitch.compat
nsswitch.files
nsswitch.hp_defaults
nsswitch.nis
nsswitch.nisplus

regards,
PAUL