System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

TMP Directory become full when install Oracle Application

 
mohssinm
Occasional Advisor

TMP Directory become full when install Oracle Application

I have EM grid agent on HP-UX 11.11 and I try to install patch on on but every time I try to install this patch give me error
and TMP dir becomes full

output bdf

/dev/vg00/lvol4 2048000 1380392 662656 68% /tmp



and alos I have big size under TMP
wd_action.dbg owned by root ??

I am not sure deletting dome files will work or not


any Ideas ? like changin TMP for current user...etc
3 REPLIES
yulianto piyut
Valued Contributor

Re: TMP Directory become full when install Oracle Application

mohssinm
Occasional Advisor

Re: TMP Directory become full when install Oracle Application

Hi

it seem I cannot remove this file .Can I put another TMP directory for current user
VK2COT
Honored Contributor

Re: TMP Directory become full when install Oracle Application

Hello,

a) Set TMPDIR variable to point to some
other non-boot-volume.

I always encourage application admins to use
their own areas for temporary files.

Some applications look at TMPDIR
environment variable.

Others look at two other variables:

Try setting TEMP and TMP as well as TMPDIR
for a user.

c) Is the /tmp file system mounted with
"tmplog" option in /etc/fstab?

That is what you should use on any HP-UX server.

I dislike and discourage use of
/tmp for permanent depository of files
and any HP-UX server that I architect and build, I enforce /tmp cleanup at boot time
(see /etc/rc.config.d/clean_tmps.

d) Finally, let's talk about your
wd_action.dbg file.

I think this file is created by
EMS. JAGag45975 talks about it (ia64_corehw
monitor creates /tmp/wd_action.dbg debugging file).

Firstly, check if anything worthy is in this file (if it is readable).

You hopefully have lsof or fuser installed
on your server. Use these utilities to see
which process is writing to this file.
Most probably, stop EMS, remove the file and restart it.

Instead of removing it (possibly still
open by some process), do this:

# cp /dev/null /tmp/wd_action.log

or

# > /tmp/wd_action.log

Cheers,

VK2COT
VK2COT - Dusan Baljevic