System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

SOLVED
Go to solution
Johnson Punniyalingam
Honored Contributor

TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi All,

Can any one advice me "which kernal parameter" needs to be changed.? bit confused becoz some forum says you can increase "nfile" some says "too many open files you should only increase "maxfile" & maxfile_lim" which should i increase..?

nfile ?
maxfile?
maxfile_lim?

Current Kernal values:-
=====================

/ > kmtune |grep nfile
nfile 3329 - (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))


/ > kmtune |grep maxfile
maxfiles 60 - 60
maxfiles_lim 1024 Y 1024


model:- N4000 , OS HPUX 11.11

Thanks,
Johnson
Problems are common to all, but attitude makes the difference
20 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Shalom,

Yes to all the above.

I believe in taking the forumulas out of a lot of these parametrs.

Also, take a look at maxuprc, the maximum number of files for one user. I'd bump that up to 200 at least. The default is 75.

You should increase these parameters and monitor use to preemptively increase them before they run low.

Oracle does have a guide for minimum kernel parameters for HP-UX on the metalink website.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Shalom,

so can you advice me what can be new kernal values for ?

nfile ?
maxfile?
maxfile_lim?

or you want me to bump "maxurpc" to 200
my current valuve for "maxurpc" is 150



Thanks,
Johnson
Problems are common to all, but attitude makes the difference
Ganesan R
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Johnson,

Ok. It depends whice user or process produce the error. First brief about these kernel parameters.

nfile=> maximum number of open files (system-wide)
Note: It is a system wide parameters.

maxfiles=>initial (soft) maximum number of file descriptors per process
Note:It is a initial limit. means still process can extend. upto what limit can extend? it is controlled by maxfiles_lim

maxfiles_lim=>hard maximum number of file descriptors per process

Now you can come to a conclusion which parameter you can increase.

If you are getting the error when you start a particular process, you should increase maxfiles or even maxfiles_lim if necessary.

If the system gives the error, frequently irrespective of process, means system is reaching the system wide hard limit, then you should consider to increase nfiles.
Best wishes,

Ganesh.
Ganesan R
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Again,

Forgot to add one more thing. You should consider to set the file descriptors value to unlimited for specific users through ulimit command if only particular user is receiving the error.
Best wishes,

Ganesh.
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Ganesan,

Many thanks for your explanation.


>>If the system gives the error, frequently irrespective of process, means system is reaching the system wide hard limit, then you should consider to increase nfiles.<<

Consideration of the above comment , can you recommend how can increase nfile.?


Thanks,
Johnson
Problems are common to all, but attitude makes the difference
Dennis Handly
Acclaimed Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

>maxfiles 60 - 60
>maxfiles_lim 1024 Y 1024

These are too small. Try 1024 and 2048.
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Dennis,

how about nfile? value, can also advice for me ..:)

Thanks,
Johnson
Problems are common to all, but attitude makes the difference
Dennis Handly
Acclaimed Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

>how about nfile value?

What is your current value?
What is: (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))

As SEP said, just put a number there. Try 16000.

Note: Typically you get "table is full" logged in syslog.log if your nfile is too small.
Ganesan R
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Johnson,

>>>
can you recommend how can increase nfile.?
<<<

Since nfile depends on other parameters, you are getting that formula in kmtune output. Means changing the other dependency parameter will also change the nfile value.

If you need to increase nfile value straight away, goto SAM->Kernel Configuration -> Configurable Parameters->select nfile->Actions->Modify Configurable Parameter->here you will have this field

Formula/Value:

You can specify the new value in the above field. Note that nfile is static and needs kernel rebuilt.
Best wishes,

Ganesh.
likid0
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

With sar -v the third column is your nfile use:

#sar -v

00:00:01 text-sz ov proc-sz ov inod-sz ov file-sz ov
00:15:00 N/A N/A 246/4200 0 1899/162600 0 3490/65536 0
00:30:01 N/A N/A 262/4200 0 1911/162600 0 3525/65536 0
00:45:00 N/A N/A 248/4200 0 1899/162600 0 3493/65536 0
01:00:00 N/A N/A 259/4200 0 1912/162600 0 3522/65536 0
01:15:01 N/A N/A 249/4200 0 1902/162600 0 3500/65536 0
Windows?, no thanks
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi All,

As discussed earlier have increased "nfile" from "3000" to "60000" but still have below problem,

so can any one advice no i should also tune

"maxfile" & "maxfiles_lim"

Oracle listener fail again at 17:40 pm.
Below our listener log.

27-MAY-2009 17:41:16 * 1159
TNS-01159: Internal connection limit has been reached; listener has shut down
TNS-12540: TNS:internal limit restriction exceeded
TNS-12560: TNS:protocol adapter error
TNS-00510: Internal limit restriction exceeded
HPUX Error: 24: Too many open files
No longer listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EIFSDW)))
No longer listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=dwhsvr01)(PORT=1521)))


Just for your info, I noticed that the ulimit in dwhsvr01 and dwhsvr02 a bit different.


/home/oracle > ulimit -a
time(seconds) unlimited
file(blocks) unlimited
data(kbytes) 262144
stack(kbytes) 8192
memory(kbytes) unlimited
coredump(blocks) 4194303
nofiles(descriptors) 60
Problems are common to all, but attitude makes the difference
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

sorry... "typ0 error" we changed it " 6000 " for nfile . still the problem comes again listerner down.

Thx,
Johnson
Problems are common to all, but attitude makes the difference
Rita C Workman
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Would you do me a favor, cause I tend to shy away from recommending parm changes without knowing what the box has to offer in resources....so please give me some info:

O/S version?
Oracle version?
Any other appl software running on it?
# of CPU's?
Amt of RAM?
Is this in a clustered environment?
Can other apps/pkgs fail to this box?

You gave us the nfile setting

dbc_max_% ? or higher os filecache_max
dbc_min_% ? or higher OS filecache_min
nproc
ninode
maxdsiz (32 & 64 bit)
maxssiz "
maxtsiz "
vx_ninode
..and all your semaphore parm settings..

Thanks,
Rita
James R. Ferguson
Acclaimed Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Johnson:

While I realize that your release is 11.11, the manpages beginning at 11.23 include excellent documentation on many, many kernel tunables. I suggest that this may be very useful to you.

http://docs.hp.com/en/B3921-60631/index.html

Regards!

...JRF...
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Hi Rita,

Bunch of thanks for you concern. please see below information as requested.

Parameter Current Dyn Planned Module Version
===============================================================================

dbc_max_pct 50 - 50
dbc_min_pct 5 - 5

nproc 1620 - (20+8*MAXUSERS)
ninode 1988 - ((NPROC+16+MAXUSERS)+32+(2*NPTY))
maxdsiz 0x10000000 - 0x10000000
maxdsiz_64bit 0x40000000 - 0X40000000
vx_ninode 0 - 0
sema 1 - 1
semaem 16384 - 16384
semmap 202 - (SEMMNI+2)
semmni 200 - 200
semmns 400 - 400
semmnu 30 - 30
semmsl 2048 Y 2048
semume 10 - 10
semvmx 32767 - 32767

O/S version?
OS: B.11.11,

Oracle version?
Oracle 8

Any other appl software running on it?

NO

# of CPU's?

CPU: 4 x 550 MHz, PA-RISC2.0, v.


Amt of RAM?

RAM: 12288 MB

Is this in a clustered environment?

NO

Can other apps/pkgs fail to this box?

NO cluster ENV.
Problems are common to all, but attitude makes the difference
Rita C Workman
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

OK...4 CPU, 12Gb RAM, Oracle 8..and not knowing your shop - here's a few suggestions:

dbc_max_% - chg to 10 to 13
dbc_min_% - chg to 5 to 8
I tend to go to the higher number, but you pick. YOur settings are defaults-BAD defaults!!

nproc 1620 - maybe higher say 2000 or even 4000 if you run big batch jobs

ninode 1988 - I'd up to 2048 - 4096. This parm creates a recycle table for inodes. The kernel calc creates way way to big a table that the sar command shows you don't need.

vx_ninode 0 - I'd hard set this to 20m to 40m. Leaving it at zero the system then creates a huge table of wasted resources on memory.You can increase if you need to, but 40m is plenty.

...on your semaphores...probably too small, can use sar -mS 1 10 (or other intervals/counts) to monitor...
sema 1 - 1
semaem 16384 - 16384
semmap 202 - try 2002 or 4002
semmni 200 - try 2000 or 4000
semmns 400 - try 2000 or 4000
semmnu 30 - try 1000 or 1500
semmsl 2048 Y 2048 - ok
semume 10 - 10 - try 1000
semvmx 32767 - 32767 - ok

I didn't address the maxd parm, cause I'd like to know what you have your shmmax set at first. So let us know.
A hint - just because Oracle says you need to set a parm to a certain value, doesn't mean you have to or even that you should.

Hope this helps. Remember, kernel tuning is not a science it's more an art. And each shop needs to tune for it's needs, so everyone tunes to their own music.

Rita
Rita C Workman
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Johnson,

I apologize for not reading more closely on one posting above - I thought the sar output above was from your system, but it appears it was Daniels.
So run your own sar -v command.

The three columns give you great info for procs/inodes/files as Daniel mentions. Each column breakdown include 'current usage'/'parm setting'.

/rcw
Rita C Workman
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

Gotta head to a 'seminar' or something shortly, so here goes:

shmmax - I tend to go with something Stephen Ciullo said - give it to them. So for your 12Gb RAM, I'd leave around 2Gb for that system reserve and I'd give them the 10Gb left.
shmmax - 0x280000000 (hope I converted that right - you might want to double check it)

Now the maxdsiz value. If I counted the zeros right yours comes out to (dec)268435456. Looks ok to me.

For your nfile....I agree with what has been said, and tune as needed.

Rgrds,
Rita
Dennis Handly
Acclaimed Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

>so can anyone advice no I should also tune maxfile & maxfiles_lim
nofiles(descriptors) 60

I mentioned how to increase them and why your problem wasn't nfile, yet. Why is this still 60?
Johnson Punniyalingam
Honored Contributor

Re: TNS-00510: Internal limit restriction exceeded HPUX Error: 24: Too many open files

I would like to thank every one .. :) for their valuable comments.

Especially > Dennis < Thanks a lot.

increasing the value of maxfile& maxfile_lim kernel parameter has per "Oracle recommendation resolved the problem.


Thanks,
Johnson
Problems are common to all, but attitude makes the difference