System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Tape drive showing no hardware

mrmo07
Regular Advisor

Tape drive showing no hardware

Hi boss !
i have new tape drive with hpux 11.11. showing NO_HW. this problem solved by reboot on test environment. but in production i cant reboot.
any way to solve this issue without reboot.

please help. this is very urgent for me.


Regards,
Morshed.


tape 0 0/2/1/0.1.12.255.0.0.0 stape NO_HW DEVICE HP Ultrium 4-SCSI
/dev/rmt/0m /dev/rmt/0mn /dev/rmt/c8t0d0BEST /dev/rmt/c8t0d0BESTn
/dev/rmt/0mb /dev/rmt/0mnb /dev/rmt/c8t0d0BESTb /dev/rmt/c8t0d0BESTnb
10 REPLIES
Manix
Honored Contributor

Re: Tape drive showing no hardware

Do have the drivers for this tape ,it shows the device files but not the hardware.

does insf -e helps

whats the make of the server , you may check the model no of the tape to search for the drivers & since it worked on the other HW I guess it`s compatible ,are both the models same.

Thanks
Manix

HP-UX been always lovable - Mani Kalra
mrmo07
Regular Advisor

Re: Tape drive showing no hardware

i have another query:

drives are connected into SAN.

when different server detects the drive with different device file. how can i link both device file for backup purpose. as i configure one device file on data protector.

please advice.
vishnu.khandare
Respected Contributor

Re: Tape drive showing no hardware

Hi,

first U check is that Tape Drive power ON or not.
If no, ON it, run ioscan -fnC tape.
Have U replaced this tape drive with previous one?
even then its showing NO_HW?
In this case scsi id need to replace u need to run one command with the scsi id u will get in
/var/adm/syslog/syslog.log form recent logs.
Run this command
#scsimgr -v -f replace_wwid -C lunpath -I XX
please give scsi id in place of XX

Hope this solves ur issue, by doing this no need to take reboot.

Regards
Vishnu Khandare
You should deserve before U desire!!!!
mrmo07
Regular Advisor

Re: Tape drive showing no hardware

Hi,
power on. actually i am getting like below:

please suggest.
bscstest:/root#date
Sat Jan 29 13:52:55 BST 2011
bscstest:/root#ioscan -fn
tape 0 0/2/1/0.1.12.255.0.0.0 stape NO_HW DEVICE HP Ultrium 4-SCSI
/dev/rmt/0m /dev/rmt/0mn /dev/rmt/c8t0d0BEST /dev/rmt/c8t0d0BESTn
/dev/rmt/0mb /dev/rmt/0mnb /dev/rmt/c8t0d0BESTb /dev/rmt/c8t0d0BESTnb
autoch 0 0/2/1/0.1.12.255.0.0.1 schgr NO_HW DEVICE HP MSL G3 Series
/dev/rac/c8t0d1
vishnu.khandare
Respected Contributor

Re: Tape drive showing no hardware

Hi,

Please check the /var/adm/syslog/syslog.log
for recent changes regarding this tape drive,
and run ioscan -fnC tape


Regards
Vishnu Khandare
You should deserve before U desire!!!!
Norm Diederich
Honored Contributor

Re: Tape drive showing no hardware

Mohammad,

Once you recognize the drive.

When you configure the drive in Data Protector, use the same lock for each logical drive that is assigned to the same physical drive.

Regards,
Norm
Kranti Mahmud
Honored Contributor

Re: Tape drive showing no hardware

Dear Morshed Bhai,

Check below thread:

http://h30499.www3.hp.com/t5/System-Administration/LTO4-drive-changed-now-NO-HW-listed-in-ioscan/m-p/4629496#M378284

Rgds-Kranti

Dont look BACK as U will miss something INFRONT!
Kranti Mahmud
Honored Contributor

Re: Tape drive showing no hardware

Hi Again...!!!

Check below issue too:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=3936307&prodTypeId=12169&objectID=c01708465


Rgds-Kranti
Dont look BACK as U will miss something INFRONT!
Taifur
Respected Contributor

Re: Tape drive showing no hardware

Dear Morshed,

tape 0 0/2/1/0.1.12.255.0.0.0 stape NO_HW DEVICE HP Ultrium 4-SCSI
/dev/rmt/0m /dev/rmt/0mn /dev/rmt/c8t0d0BEST /dev/rmt/c8t0d0BESTn
/dev/rmt/0mb /dev/rmt/0mnb /dev/rmt/c8t0d0BESTb /dev/rmt/c8t0d0BESTnb

From above message , drive has found but might be robotics has not found. 1st check schgr has found or not from ioscan,. If found then hardware has found then u have to install or enable driver for schgr.

Cheers//
Taifur
mrmo07
Regular Advisor

Re: Tape drive showing no hardware

thanks all.