System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

The enclosure services controller cards have different versions

SOLVED
Go to solution
HP UNIX Professionals
Frequent Advisor

The enclosure services controller cards have different versions

Hi Experts,
We are getting following root mail alert daily in /usr/mail/root for the HP-UNIX box (HP-UX B.11.00 U 9000/800 )
For this we updated patch” PHSS_34686” and “PHKL_31018”

But still getting this alert, anybody know
1. why this alert comming
2. What is the solution for this issue


Root Mail Alert
===============

Message 2:
From root Fri Dec 17 03:36:58 GMT 2010
Received: (from root@localhost)
by server123.3663.co.uk (8.9.3 (PHNE_29773)/8.8.6) id DAA15049;
Fri, 17 Dec 2010 03:36:58 GMT
Date: Fri, 17 Dec 2010 03:36:58 GMT
Message-Id: <201012170336.DAA15049@server123.3663.co.uk>
To: root
From: root@server123.3663.co.uk
Subject: server123: Event Monitor Notification
Status: R

>------------ Event Monitoring Service Event Notification ------------<

Notification Time: Fri Dec 17 03:36:58 2010

server123 sent Event Monitor notification information:

/storage/events/enclosures/ses_enclosure/0_4_0_0.8.0.255.0.15.0
is >= 3.
Its current value is MAJORWARNING(3).



Event data from monitor:

Event Time..........: Fri Dec 17 03:36:57 2010
Severity............: MAJORWARNING
Monitor.............: dm_ses_enclosure
Event #.............: 402
System..............: server123

Summary:
Enclosure at hardware path 0/4/0/0.8.0.255.0.15.0 : Hardware failure


Description of Error:

The enclosure services controllers have different versions of firmware.

Probable Cause / Recommended Action:

The enclosure services controller cards have different versions of
firmware. Update the controllers to the same version of firmware.

User Defined Annotation: .

Additional Event Data:
System IP Address...: 194.33.136.100
Event Id............: 0x4d0adad900000000
Monitor Version.....: B.01.00
Event Class.........: I/O
Client Configuration File...........:
/var/stm/config/tools/monitor/default_dm_ses_enclosure.clcfg
Client Configuration File Version...: A.01.00
Qualification criteria met.
Number of events..: 1
Associated OS error log entry id(s):
None
Additional System Data:
System Model Number.............: 9000/800/N4000-55
OS Version......................: B.11.00
System Serial Number............: USM392406X
System Software ID..............: 628309303
EMS Version.....................: A.03.20
STM Version.....................: A.44.00
Latest information on this event:
http://docs.hp.com/hpux/content/hardware/ems/dm_ses_enclosure.htm#402
8 REPLIES
pradeep m
Respected Contributor

Re: The enclosure services controller cards have different versions

Hi,
Please post the output of below commands
# swlist -l product
# swverify PHSS_34686
# swverify PHKL_31018

Where there any recent firmware update or any other changes done on the server?

Regards,
Pradeep

I am an HP Employee
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details


Torsten.
Acclaimed Contributor

Re: The enclosure services controller cards have different versions

What versions are installed?

In MST, select the enclosure device and run the info tool - post results.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: The enclosure services controller cards have different versions

Example output:

...
Hardware path: 0/10/0/0.15.0


Product ID: A6491A

Controller A
------------
Hardware Path: 0/10/0/0.15.0
Serial No: S44JL1712345
Firmware Rev.: HP16

...
Controller B
------------
Hardware Path: 0/12/0/0.15.0
Serial No: S44NL1712345
Firmware Rev.: HP16

...

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
HP UNIX Professionals
Frequent Advisor

Re: The enclosure services controller cards have different versions

Hi Pradeep,

I am attached the output of the follwoing commands

swlist
swverfy
=======



root@server123:/# swverify PHSS_34686

======= 12/31/10 10:36:10 GMT BEGIN swverify SESSION
(non-interactive)

* Session started for user "root@server123".

* Beginning Selection
* Target connection succeeded for "server123:/".
* Software selections:
PHSS_34686.FC-TL-KRN,l=/,r=1.0,a=HP-UX_B.11.00_32/64,v=HP,fr=1.0,fa=HP-UX_B.11.00_64
PHSS_34686.FC-TL-RUN,l=/,r=1.0,a=HP-UX_B.11.00_32/64,v=HP,fr=1.0,fa=HP-UX_B.11.00_32/64
* Selection succeeded.


* Beginning Analysis
* Session selections have been saved in the file
"/.sw/sessions/swverify.last".
* The analysis phase succeeded for "server123:/".
* Verification succeeded.


NOTE: More information may be found in the agent logfile (location
is server123:/var/adm/sw/swagent.log).

======= 12/31/10 10:36:21 GMT END swverify SESSION (non-interactive)

root@server123:/#
root@server123:/# swverify PHKL_31018

======= 12/31/10 10:37:05 GMT BEGIN swverify SESSION
(non-interactive)

* Session started for user "root@server123".

* Beginning Selection
* Target connection succeeded for "server123:/".
* Software selections:
PHKL_31018.CORE2-KRN,l=/,r=1.0,a=HP-UX_B.11.00_32/64,v=HP,fr=1.0,fa=HP-UX_B.11.00_64
PHKL_31018.FCMS-ENG-A-MAN,l=/,r=1.0,a=HP-UX_B.11.00_32/64,v=HP,fr=1.0,fa=HP-UX_B.11.00_32/64
PHKL_31018.FCMS-KRN,l=/,r=1.0,a=HP-UX_B.11.00_32/64,v=HP,fr=1.0,fa=HP-UX_B.11.00_64
PHKL_31018.FCMS-RUN,l=/,r=1.0,a=HP-UX_B.11.00_32/64,v=HP,fr=1.0,fa=HP-UX_B.11.00_32/64
* Selection succeeded.


* Beginning Analysis
* Session selections have been saved in the file
"/.sw/sessions/swverify.last".
* The analysis phase succeeded for "server123:/".
* Verification succeeded.


NOTE: More information may be found in the agent logfile (location
is server123:/var/adm/sw/swagent.log).

======= 12/31/10 10:37:14 GMT END swverify SESSION (non-interactive)

Thanks

vinay
Dennis Handly
Acclaimed Contributor

Re: The enclosure services controller cards have different versions

>I am attached the output of the following commands

swlist It seems like this was missing a tab between the first and second columns?

swverify doesn't show any errors.
HP UNIX Professionals
Frequent Advisor

Re: The enclosure services controller cards have different versions

Hi Experts,

I checked the Both Patch installed in the HPUX for fiber channel Firmware version error. Both are installed ok ,

But sill we are getting the mail alert, Anybody know what is the problem tell me the advice and suggestion



PHSS_346861.0 Tachyon TL Fibre Channel Driver Patch
PHKL_310181.0 Fibre Channel Mass Storage Driver Patch



root@XXXXXX:/# swverify PHSS_346861.0

======= 01/13/11 12:12:21 GMT BEGIN swverify SESSION
(non-interactive)

* Session started for user "root@XXXXXX".

* Beginning Selection
* Target connection succeeded for "XXXXXX:/".
ERROR: Could not apply the software selection "PHSS_346861.0"; it is
not available from depot or root "XXXXXX:/".
* Software selection failed for "XXXXXX:/".
ERROR: Cannot continue the "swverify" task.
* Selection had errors.



======= 01/13/11 12:12:26 GMT END swverify SESSION (non-interactive)

root@XXXXXX:/#
root@XXXXXX:/#
root@XXXXXX:/# swverify PHKL_310181.0

======= 01/13/11 12:12:57 GMT BEGIN swverify SESSION
(non-interactive)

* Session started for user "root@XXXXXX".

* Beginning Selection
* Target connection succeeded for "XXXXXX:/".
ERROR: Could not apply the software selection "PHKL_310181.0"; it is
not available from depot or root "XXXXXX:/".
* Software selection failed for "XXXXXX:/".
ERROR: Cannot continue the "swverify" task.
* Selection had errors.



======= 01/13/11 12:13:02 GMT END swverify SESSION (non-interactive)
Torsten.
Acclaimed Contributor

Re: The enclosure services controller cards have different versions

Are you sure this is a patch problem?

Did you compare the installed versions?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Patrick Wallek
Honored Contributor
Solution

Re: The enclosure services controller cards have different versions

>>I checked the Both Patch installed in the
>>HPUX for fiber channel Firmware version
>>error. Both are installed ok ,

>>But sill we are getting the mail alert,
>>Anybody know what is the problem tell me the
>>advice and suggestion

This isn't a patch problem.

You are being told exactly what the problem is. The problem is that the controllers IN THE FC10 itself have different versions of firmware installed on them.

This can be due to one of them going bad and getting replaced.

The solution is the upgrade the firmware in the controller with the lower version so it matches the one with the newer version.

I have always HP do this for me, so I am not sure of the exact procedure.

You were given advice on how to check the controller firmware versions by Torsten above.