System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to get Veritas Netbackup 5.1 work with OEL5 update 3

SOLVED
Go to solution
Daniel Simard
Frequent Advisor

Trying to get Veritas Netbackup 5.1 work with OEL5 update 3

Good afternoon All,

We are trying to get veritas netbackup working with Oracle Enterprise Linux 5, update 3.

Veritas halts it's backup job (doesn't start properly), with error code 49.

It says to load a library which is currently has a newer version installed on the system. Therefore i cannot install the same version of library because it conflicts.

anyone reading this have Veritas Netbackup working with Linux.

This is the post i'm referring to:
http://seer.entsupport.symantec.com/docs/273690.htm

STATUS CODE 49: A Telnet to the bpcd port on a Linux client results in the error "bpcd: relocation error: bpcd: undefined symbol: __vt_9exception". Bpcd is not starting.
--------------------------------------------------------------------------------
Exact Error Message
bpcd: relocation error: bpcd: undefined symbol: __vt_9exception

Details:
Overview:
If a Linux client is missing the Red hat 7.3 compat-libstdc++ compatibility libraries, then bpcd may fail to start. This is listed as a required operating system patch in the NetBackup 5.1 Release notes. If the libstdc++ RedHat Package Manager (RPM) package is installed, the library files needed for bpcd to start will be available, but they will be missing the needed symbol "__vt_9exception". Without compat-libstdc++, a backup may fail with a Status Code 49.

Troubleshooting:
To duplicate the problem, telnet to the bpcd port on the client. The telnet should fail immediately with the following error:
# telnet client 13782
Trying x.x.x.x...
Connected to .
Escape character is '^]'
bpcd: relocation error: bpcd: undefined symbol: __vt_9exception

Log Files: n/a

Resolution:
To correct this problem, install the following (or newer) RPM:
compat-libstdc++-7.3-2.96.122 "Standard C++ libraries for Red Hat 7.3 backwards compatibility compiler"

This RPM contains the libraries with the required symbols needed for bpcd to run. The TechNote referenced below lists the required RPM's needed for the different versions of Linux.
Si tu n'as pas ce que tu aimes, aimes ce que tu as.
2 REPLIES
Sherbert Punt
Occasional Advisor
Solution

Re: Trying to get Veritas Netbackup 5.1 work with OEL5 update 3

Hi Daniel,

Have you installed the compat-libstdc++ library yet ?

using yum

# yum install compat-libstdc++ or

or up2date

# up2date compat-libstdc++

--Sherbert
dirk dierickx
Honored Contributor

Re: Trying to get Veritas Netbackup 5.1 work with OEL5 update 3

you have the solution in you post, install the compat packages and the problem should go away.

"To correct this problem, install the following (or newer) RPM:
compat-libstdc++-7.3-2.96.122 "Standard C++ libraries for Red Hat 7.3 backwards compatibility compiler" "