Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Two Apache web servers

Clay_Chappell
Occasional Advisor

Two Apache web servers

All of my servers (HP-UX 11.23, IA64) have two different Apache web server products installed: hpuxwsApache and hpuxws22Apache. There is very little information out there about hpuxws22Apache.
What is the difference between these two products and are both really necessary?
3 REPLIES
pradeep m
HPE Pro

Re: Two Apache web servers

The major difference between the hpuxwsApache and hpuxws22Apache is the version of Apache.
hpuxwsApache has Apache version 2.0
hpuxws22Apache has Apache Version 2.2

hpuxwsapache has been replaced by hpuxws22apache (Apache 2.2.8.08),which combines Apache with numerous popular modules from other Open Source projects and provides HP value-added features for HP-UX.

Refer "HP-UX Apache-based Web Server" release notes for details:
https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW222

Regards,
Pradeep
Regards,
Pradeep

I am an HP Employee
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details


Clay_Chappell
Occasional Advisor

Re: Two Apache web servers

hpuxwsApache is part of a webserver suite that contains: Webserver, Tomcat, and Web Admin. If I remove hpuxwsApache, will hpuxws22Apache work properly with the remaining software products in the suite or must I remove the entire suite and upgrade with the latest HP-UX Apache-based Web Server v.3.x bundle?
Highlighted
Clay_Chappell
Occasional Advisor

Re: Two Apache web servers

Per HP
SMH has a dependency with wsApache.
Until this dependency is resolved and SMH is ported to ws22Apache, it will be necessary to run both versions of Apache.
Since there are security vulnerabilities with both versions, it will be necessary to upgrade wsApache to v2.0.63.01 and ws22Apache to v2.2.15.03