HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

Ulimiit

 
Musa123
Advisor

Ulimiit

Hi,
HP-UX acn120 B.11.11 U 9000/800 2067689352 unlimited-user license

ulimit -a
time(seconds) unlimited
file(blocks) unlimited
data(kbytes) 4294705152
stack(kbytes) 131072
memory(kbytes) unlimited
coredump(blocks) 4194303
nofiles(descriptors) 2048

HP-UX acn123 B.11.31 U 9000/800 185074309 unlimited-user license

ulimit -a
time(seconds) unlimited
file(blocks) unlimited
data(kbytes) 4194300
stack(kbytes) 8192
memory(kbytes) unlimited
coredump(blocks) 4194303
nofiles(descriptors) 2048

I want to change the data & stack values in acn123 server .what same mention in acn120 server.

1)please provide the steps

Thanks in advance!!!!

9 REPLIES
Steven E. Protter
Exalted Contributor

Re: Ulimiit

Shalom,

This thread provides the guide you seek.

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1283896784820+28353475&threadId=1290110

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Musa123
Advisor

Re: Ulimiit

Thanks ,

ulimit -d 4294705152
sh: ulimit: The specified number is not valid for this command.

Am getting above mentioned error.
kindly advice how to set..

Dont mistaken me am learner in HP_UX.

Re: Ulimiit

>I want to change the data & stack values in acn123 server, to the same as acn120.

(You should be looking directly at the kernel parms, not ulimit.)

Your value of maxdsiz is at its max on acn123, so you only need to change maxssiz:
kctune maxssiz=$(( 131072 * 1024 ))

If you want to make sure the 64 bit values are the same you need to use:
kmtune | grep -e maxssiz -e maxdsiz

Then use kctune(1m) to set them on acn123.
Musa123
Advisor

Re: Ulimiit

Hi Team,

Thanks for Your valuable reply..

ulimit -s 131072
sh: ulimit: The specified value exceeds the user's allowable limit.

Am get above error ..pls advice !!!
Horia Chirculescu
Honored Contributor

Re: Ulimiit

>sh: ulimit: The specified value exceeds the user's allowable limit.

You should check the relevant kernel parameters. User parameters can not exceed the limits imposed by kernel.

Best regards,
Horia.

Best regards from Romania,
Horia.
DeafFrog
Valued Contributor

Re: Ulimiit

Hi ftp ,

you should first extend the value of both maxssiz and maxssiz_64bit , then you will be able to increase the stack limit , also there are many post on this topic if you try Mr. Google witha " + itrc" flag.

Regards,
FrogIsDeaf

Re: Ulimiit

>ulimit -s 131072
sh: ulimit: The specified value exceeds the user's allowable limit.

I suggested you NOT use ulimit but only use kctune(1m). And I provided the command.
Musa123
Advisor

Re: Ulimiit

Hi,

Am edit the profile and added the below entry but not updated.

uname -a
HP-UX acnux06 B.11.31 U 9000/800 185074309 unlimited-user license

ulimit -d 4294705152

>ulimit -d 4294705152
sh: ulimit: The specified number is not valid for this command.

echo $SHELL
/sbin/sh

so I need to increase the data to 4294705152 and stack to 131072?

Thanks in Advance !!!

Re: Ulimiit

>Am edit the profile and added the below entry but not updated.

You don't edit any profile. As root you must execute kctune(1m).

>so I need to increase the data to 4294705152 and stack to 131072?

No (for data)!
Please read what I said. You can't use ulimit to increase the value. Only kctune(1m).

Note: ulimit is broken on 11.11 and returns a bogus value of 4294705152.
On your 11.31 system you have 4194300, the maximum value for ulimit and 32 bit.