cancel
Showing results for 
Search instead for 
Did you mean: 

Umount: Device Busy

SOLVED
Go to solution
Jayraj
Frequent Advisor

Umount: Device Busy

hi all,

I have tried to unmount filesystem,
umount /dev/vg01/lvol11
but it is giving device busy
I have killed all the processes using
fuser -ku /dev/vg01/lvol11
However it is still giving the same error..
how to unmout this file system
9 REPLIES
Ivan Krastev
Honored Contributor
Solution

Re: Umount: Device Busy

Try with lsof to see more details:

lsof | grep mountpoint

regards,
ivan
Steven E. Protter
Exalted Contributor

Re: Umount: Device Busy

Shalom,

Try fuser -cuk /filesystem_name

As a matter of fact try umount /filesystem_name

If that does not work, shut down daemons like oracle and whatnot that might have open file handles on the file system.

There is always single use mode.

People normally don't name their file systems the same name as the logical volume name.

SEP

Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Fredrik.eriksson
Valued Contributor

Re: Umount: Device Busy

If you're trying to umount something like your /home and you're in your /home/user/ directory, this will return a device busy error.

If any user is currently cd'd into a directory on that particular filesystem this happens.

Best regards
Fredrik Eriksson
Robert-Jan Goossens
Honored Contributor

Re: Umount: Device Busy

Hi,

Download and install lsof from;

http://hpux.connect.org.uk/hppd/hpux/Sysadmin/lsof-4.81/

use lsof to list the current processes running on the device.
# lsof /dev/vg01/lvol11

Regards,
Robert-Jan
Robert-Jan Goossens
Honored Contributor

Re: Umount: Device Busy

bye the way, which HPUX level are you running?

I believe HPUX 11iv2 and 11iv3 have a forced umount option.

Regards,
Robert-Jan
Md. Farhan A Azam
Trusted Contributor

Re: Umount: Device Busy

Hi,

In HP-UX 11.11,

#fuser -cu [mountpoint)

it will show you , which user is loggedin in the mount point.

#fusert -ck [mountpoint]

To kill all the process, which is running in the mount point....

then try for unmount
Mahesh Mongare
Occasional Visitor

Re: Umount: Device Busy

1. check how many users working on this mount point. beacuse some process is running on this mount point so u r not able to umount it fuser -cu

2. Kill these all process and ask to user dont fire any new query on it or shutdown the application.
asfter that just use fuser -ku and try to umount.

Suraj K Sankari
Honored Contributor

Re: Umount: Device Busy

Hi,

What is the out put of #fuser -cu /mountpoint

Suraj
MarotiG
Occasional Visitor

Re: Umount: Device Busy

Could be the reason where in mount point is shared as nfs on other nodes.

If yes, unshare the filesystem and check fuser -cu <mount point>

kill if any session running on it then try unmount

umount <mount point>