Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to change root passwd using set_parms

SOLVED
Go to solution
Yaroki
Super Advisor

Unable to change root passwd using set_parms

Hi,

 

On HP-UX, b.11.11

 

# set_parms root_passwd gives the following message:

 

"set_parms: Cannot find dialog for en_US.iso88591 -- using English" and the process is terminated.

 

Other option (such as ip_addr, timezone) of set_parms gives the same message but proceed and open the dialog box to fill in.

 

I can allwas use the passwd command but I would like to know the reason for the problem above.

 

BR,

Yali

4 REPLIES
Dennis Handly
Acclaimed Contributor

Re: Unable to change root passwd using set_parms

>set_parms: Cannot find dialog for en_US.iso88591

 

Try using the American Nerd locale instead?:

export LANG=C

Yaroki
Super Advisor

Re: Unable to change root passwd using set_parms

export LANG=C

as a command line or on .profile?

Dennis Handly
Acclaimed Contributor
Solution

Re: Unable to change root passwd using set_parms

>as a command line or on .profile?

 

Only just where you need it:

# LANG=C set_parms root_passwd

 

(Me, I always set American Nerd because I know how locales make libc sweat.  :-)

Highlighted
Yaroki
Super Advisor

Re: Unable to change root passwd using set_parms

:)