System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to configure Ultrium 1760 SAS Tape on Linux

 
habib_lalji
Visitor

Unable to configure Ultrium 1760 SAS Tape on Linux

I have need to configure the above storageworks 1760 SAS tape on a Redhat Enterprise 5 Linux box...I dont have a clue. I have insured all the physicall cable connections are correct...someone please kindly help as i am the only person who can do this job at this time.
6 REPLIES
Matti_Kurkela
Honored Contributor

Re: Unable to configure Ultrium 1760 SAS Tape on Linux

First, run "lsscsi". Does it see the tape drive?

(If the command is not recognized, install the lsscsi RPM from the RedHat Enterprise Linux installation media.)

If the tape drive is visible to "lsscsi", then the udev subsystem should automatically create device nodes for it, like /dev/st0 and /dev/nst0. If this does not happen, then the SCSI tape driver might not be loaded: run "modprobe st" to load it manually.

If the device nodes exist, you can try querying the status of the tape drive with the "mt" command:

mt -f /dev/nst0 status

If that works, the hardware installation is complete; the rest will depend on what you want to do with your tape drive. If you want to use the "tar" command to backup files and directories to tapes, you can do that. If you want to use a more advanced tape backup program, read the documentation of that program to find out how to tell the program what device to use.

MK
MK
S.N.S
Valued Contributor

Re: Unable to configure Ultrium 1760 SAS Tape on Linux

And Habib,

You should be able to get it right from Matti's post...
Refer the doc that came with the drive if something else comes up - it may have certain other basic details that you would overlooked

HTH
SNS
"Genius is 1% inspiration, 99% Perspiration" - Edison
habib_lalji
Visitor

Re: Unable to configure Ultrium 1760 SAS Tape on Linux

Guys Thanks...i will try it and come back to you to tell of success!
habib_lalji
Visitor

Re: Unable to configure Ultrium 1760 SAS Tape on Linux

i have never installed anything on linux unlike windows...would you have any intrcution set on how i can install lsscsi RPM incase the command fails or is not recognised.
Matti_Kurkela
Honored Contributor

Re: Unable to configure Ultrium 1760 SAS Tape on Linux

If your system is registered to RedHat Network (RedHat's update distribution service), then you can install lsscsi with this command:

yum install lsscsi

If your system is not connected to the Internet or not registered to the RedHat Network, you can install it from the RHEL 5 installation DVD too: mount the DVD, go to the Server subdirectory and find the lsscsi-.rpm. To install it, you can use this command:

rpm -Uvh lsscsi-*.rpm

Or if you prefer to use the GUI, just double-click the lsscsi RPM package icon: the package installation tool should start automatically.

MK
MK
habib_lalji
Visitor

Re: Unable to configure Ultrium 1760 SAS Tape on Linux

Guys thanks for the above information; seems like lsscsi was installed. I got the below results:

[root@pwreveradb ~]# lsscsi
[0:0:0:0] cd/dvd hp DVD RW AD-7586H KP03 /dev/scd0
[root@pwreveradb ~]#

[root@pwreveradb ~]# modprobe st
[root@pwreveradb ~]#

[root@pwreveradb ~]# mt -f /dev/nst0 status
/dev/nst0: No such file or directory
[root@pwreveradb ~]#

it seems that the tape is note installed...unless i am gong wrong.

Please help