System Administration
Showing results for 
Search instead for 
Did you mean: 

Unable to enable printer queues

Sok Yee
Occasional Contributor

Unable to enable printer queues

I'm currently facing a printing problem:
Whenever we send a print job to print to unix print queue, the printer queue will go down (disabled status).
The print job will get stuck in the print queue and we are unable to re-enable to printer queue unless we cancel the print job.
This is the 1st time I'm facing this problem. Typically we should be able to re-enable a print queue without the need to cancel away all the existing stuck print jobs in the print queue.

We do not wish to delete the stuck print jobs before we can enable the printer for printing.

Attached are some print screens for your references. Appreciate your inputs.
Michael Sillers
Trusted Contributor

Re: Unable to enable printer queues

Have you ever been able to print to this printer? I've discovered that a printer will enable until you try to print to it if it is not available. Only when you try to print to it will it disable. It disables immediately when you enable it with a print job there because it will try to print then disable as soon as it is enabled. If this is the case, the problem is likely with the printer setup or outside of UNIX.

I've also experienced problems with a corrupt print job. To test this, send a simple text job to the printer i.e: lp -d printer /etc/profile after moving the existing print jobs to a temporary location from which you can print them later.
Rita C Workman
Honored Contributor

Re: Unable to enable printer queues

Can you print from jetadmin?

Run hpppi and see if you can print a testjob.

Another thing to check is permissions, cause it's amazing the funny things wrong permissions can do..

chown -R bin:bin /opt/hpnpl

Then go back and change:
chown lp:bin for /opt/hpnpl/tmp ONLY

Just a couple things to try.
Sok Yee
Occasional Contributor

Re: Unable to enable printer queues

I managed to resolve the problem.
It's due to owner permission for rlp in /usr/sbin. Initially it was set to bin ownership but once we changed it to root, everything is working fine now.

-r-sr-xr-- 1 root lp 84780 Feb 15 2007 rlp