System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to tune the kernel parameter value in B11.11

P Arumugavel
Respected Contributor

Unable to tune the kernel parameter value in B11.11

Hi All,

Please help me on below issue.
I am unbale to change the value of parameter below
#kmtune -s msgtql=4096

This value is not getting changed even after reboot.

OS version is B11.11

Thanks in advance.

Rgds...
3 REPLIES
Kenan Erdey
Honored Contributor

Re: Unable to tune the kernel parameter value in B11.11

Hi,

msgtql is a static kernel parameter. so after changing it's value you must recompile kernel and start the system with this kernel. best and easy way is changing msgtql from sam. it'll all do what is needed.

if you want this from cli, you can search the forum.
Computers have lots of memory but no imagination
Stephan.
Honored Contributor

Re: Unable to tune the kernel parameter value in B11.11

Did you try changing it using SAM?

4096 seems pretty high compared to the default of 40 but according to http://hpux.de/KCParms/KCparam.MsgTql.html there is only a memory limit.

After using kmtune, if you check it with

kmtune -l -q msgtql

does it show the new value?

hth
Stephan
Ismail Azad
Esteemed Contributor

Re: Unable to tune the kernel parameter value in B11.11

Hi,

The param seems to have a dependency on msgseg. You cannot configure msgtql over msgseg... However, the value suggests, that might not be the issue.. Anyways, have a look.

Regards
Ismail azad
Read, read and read... Then read again until you read "between the lines".....