System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Unbale to configure the printer on HPUX due to long remote port name

 
Vijeesh CTK
Trusted Contributor

Unbale to configure the printer on HPUX due to long remote port name

Hello
I have a windows print server with multiple printers configured on it.I am trying to configure one of the printer as a remote printer on my HPUX server with OS version 11.11.
The issue I am facing is the remote port name for the printer on windows server is too long IP_206.44.21.237.
The maximum I can specify while configuring the printer on HPUX server is up to IP_206.44.21.2 . The unable to provide the remaining part . Becasue of that the printer is not getting configured on hpux server as the Remote Printer Name should be exactly same.
I tried using sam as well as command line.

lpadmin -pPL7032P -v/dev/null -mrmodel -ocmrcmodel -osmrsmodel -ob3 -ormwindows serverIP -orpIP_206.44.21.237

$ lpstat -v
device for PL7032P: /dev/null
remote to: IP_206.44.21.2 on 206.44.25.42
$

$ lpstat -t
scheduler is running
no system default destination

device for PL7032P: /dev/null
remote to: IP_206.44.21.2 on 206.44.25.42
PL7032P accepting requests since Oct 2 04:09
printer PL7032P is idle. enabled since Oct 2 04:09
fence priority : 0

printer queue for PL7032P

Windows LPD Server
Error: specified printer does not exist

no entries

Can anyone please help me on this ?
6 REPLIES
V. Nyga
Honored Contributor

Re: Unbale to configure the printer on HPUX due to long remote port name

Hi,

what's about creating a shorter name at the windows server and forward the print jobs at the server to the printer with the long name?

Volkmar
*** Say 'Thanks' with Kudos ***
TTr
Honored Contributor

Re: Unbale to configure the printer on HPUX due to long remote port name

I can not test it right now but shouldn't you be using the printer name itself in the -orp option? It seems to me that the port name is the device that is used by the windows printing system to send jobs to the printer. The UNIX remote spooler should be pointing to a priner spooler name on the windows server. Now if the printer name is too long as well you need to rename it.
Bill Hassell
Honored Contributor

Re: Unbale to configure the printer on HPUX due to long remote port name

Use lpadmin -ql to extend the limit from 14 to 250 characdters, BUT read the warnings in the lpadmin man page. If this remote print server is the only one that HP-UX will use, then you should be OK. It is not a good practice to use long names inside print servers if they are to remain compatible. HP-UX happens to have an option to handle this condition -- other OS's may not be as flexible.


Bill Hassell, sysadmin
Tim Nelson
Honored Contributor

Re: Unbale to configure the printer on HPUX due to long remote port name

Another option, if there is no real reason to use the windows print server, is to skip the windows print server altogether and print directly to the printer

"If" your printers are network connected then simply configure them as network printers instead of remote printers.

install and use the HP JetDirect Printer Installer. printers can be added with the addqueue command.


Vijeesh CTK
Trusted Contributor

Re: Unbale to configure the printer on HPUX due to long remote port name

I have requested windows team to check wheteher it is possible to create a diffrent queue with short name and same port. Waiting for that .
I will try lpadmin -ql if I cannot get a short name.

I tried configuring this printer directly.This printer printronix L7032 does not support lpr/lpd printing as per printronix tech team . So , I am unable to bypass windows server . It prints from windows print server .
Tim Nelson
Honored Contributor

Re: Unbale to configure the printer on HPUX due to long remote port name

>>I tried configuring this printer directly.This printer printronix L7032 does not support lpr/lpd printing as per printronix tech team . So , I am unable to bypass windows server . It prints from windows print server .

network based printers do not have to support LPR/LPD

how is the printer connected ? via the network using tcp/ip..

use the 206.44.212.2 ip address, find a compatable unix printer driver if needed and use addqueue
e.g. addqueue -h 206.44.212.2 -q myprinter

all done... no need to bother the windoze guys.