cancel
Showing results for 
Search instead for 
Did you mean: 

Unclaimed Device

 
SOLVED
Go to solution
catastro
Super Advisor

Unclaimed Device

Hi all. I have an L2000 running HP-UX 11.11 and since last week (don't know why and no changes were made in the system) I have an UNCLAIMED device, and it's making making my ignites to fail.
I have been looking at the threads in the ITRC, and all speaks aboout some patches of mux and Pty (I have the latest one) and the PDC ones (I also have the latest one, 44.28).
My Ignite version is 7.6.1 and I am no sure if by upgrading my version to the latest one (7.8.201) will solve this.
Any ideas about this? Why is this happening as well... Thanks for the helps...

casta:/root# model
9000/800/L2000-5X
casta:/root# uname -a
HP-UX casta B.11.11 U 9000/800 113901501 unlimited-user license
casta:/root# swlist -l product | grep -i ignite
Ignite-UX C.7.6.100 HP-UX System Installation Services
casta:/root# swlist -l patch | grep PHNE_35939
PHNE_35939.CORE2-KRN 1.0 OS-Core.CORE2-KRN committed
PHNE_35939.KERN2-RUN 1.0 OS-Core.KERN2-RUN committed
# PHNE_35939 1.0 Cumulative Mux and Pty Patch
# PHNE_35939.CORE2-KRN 1.0 OS-Core.CORE2-KRN committed
# PHNE_35939.KERN2-RUN 1.0 OS-Core.KERN2-RUN committed
casta:/root# swlist -l patch | grep PHSS_32705
PHSS_32705.KERN-RUN 1.0 OS-Core.KERN-RUN committed
# PHSS_32705 1.0 rp5400 (L1000) and rp5450 (L2000) 44.28 PDC
# PHSS_32705.KERN-RUN 1.0 OS-Core.KERN-RUN committed

unknown -1 0/0/4/0 UNCLAIMED UNKNOWN PCI BaseSystem (103c10ed)
tty 0 0/0/4/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/tty0p0 /dev/tty0p4
/dev/diag/mux0 /dev/tty0p1
/dev/mux0 /dev/tty0p2
13 REPLIES
Jozef_Novak
Respected Contributor

Re: Unclaimed Device

Hello,

do you make your Ignite backups over network to an Ignite server or to a local tape ?

If tape is your option, check whether the device is available:

# ioscan -fnC tape

J.
catastro
Super Advisor

Re: Unclaimed Device

Hi. I make both, through a tape ans through the network to an ignite server, and both fails. The tape device is in Claimed state as well as the network adapters and enough space in the ignite server's disk.
Jozef_Novak
Respected Contributor

Re: Unclaimed Device

Okay and what are the Ignite error messages ?
catastro
Super Advisor

Re: Unclaimed Device

ERROR: Unable to initiate connection to IO listener: Error 0 (errno = 0)
ERROR: Could not write disk information file

...

======= 05/15/09 00:00:56 METDST make_net_recovery completed unsuccessfully


Between those lines, there are no error messages, just normal outputs checcking the vg and lvols.
I think it is not an ignite issue.
smatador
Honored Contributor

Re: Unclaimed Device

Hi,
I assume you have read this thread,
http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=108143

Perhaps, another idea is to rmsf -H 0/0/4/0 do the ignite to have one. After that ioscan and insf to see if this gsp is always unknown.

Hope it helps
Jozef_Novak
Respected Contributor

Re: Unclaimed Device

Hello,

don't you have a saved ioscan output from the time when backups were running normally ? You could check what was the state of the device before the problem appeared.

J.
catastro
Super Advisor

Re: Unclaimed Device

Hi smatador. I didn't read that post, I missed that one. I did it right now, and I can tell my drivers are "in" in both cases (asio0 and PCItoPCI), and I have no warning in my syslog.
Before making a destructive thing, I would like to consider other options.

Hi Jozef. The last ioscan I have appears as well as UNCLAIMED, but 2 weeks ago's ignite just worked perfectly (I have no copy of it as it was overwritten). Is from now it is not working.

Any ideas or comments???
Armin Kunaschik
Esteemed Contributor

Re: Unclaimed Device

What does "kmsystem" report?
Are the necessary entries there, like:
Module Configured Loadable
=================================================
[..]
PCItoPCI Y -
asio0 Y -

You might need to re-include the drivers in your kernel (in this case with reboot).

My 2 cents,
Armin
And now for something completely different...
catastro
Super Advisor

Re: Unclaimed Device

Hi Armin. The PCItoPCI and asio0 modules appear as you say, configured ("Y") but nothing more is showing up.
I am going to upgrade my Ignite sw to the latest version, the 7.8.201 as I had to do it anyway, but don´t know if this will fix the issue. Any more ideas?
Armin Kunaschik
Esteemed Contributor

Re: Unclaimed Device

I'd doubt, that upgrading Ignite will fix this problem. Ignite will probably fail because of the UNCLAIMED resources!

Are the UNCLAIMED devices go away after a reboot? Does swverify \* report any errors?

Sometimes ioscan reports rubbish (e.g. NO_HW but the device is actually there). What's your "overall patch level" of the system (e.g. did you install a current QPK)?

Last but not least: Is it possible, that you have a hardware problem? Any error message visible on the MP (sl)?

My 2 cents,
Armin
And now for something completely different...
catastro
Super Advisor

Re: Unclaimed Device

Hi Armin. The swverify output shows some errors related to printer subsystem and the OV man pages, but nothing serious and/or related to anything hardware.
My patches are up to date, but I have to upgrade my QPKG to this year release soon.

casta:/root# swlist -l bundle | grep -i gold
GOLDAPPS11i B.11.11.0806.476 Applications Patches for HP-UX 11i v1, May 2008
GOLDBASE11i B.11.11.0806.476 Base Patches for HP-UX 11i v1, May 2008

The SL shows some error related to a crash that had the server and this one is about the system board, what I will be changing for a new one next week.
I am thinking now, that his thing is just happening after the crash happened.
Maybe it's a system board issue. After I replace the system board I will try again and post the result.
Torsten.
Acclaimed Contributor
Solution

Re: Unclaimed Device

Check if you have these or newer patches:

Console Driver Patch [PHNE_26326/PACHRDME/English](reboot!)
INSF Patch [PHCO_27243/PACHRDME/English]

Run
# insf -e -d asio0

This is related to the GSP rev. B firmware (it is creating new h/w pathes for the serial device.



Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
catastro
Super Advisor

Re: Unclaimed Device

Hi Torsten. I don't have those two patches installed on my system.
I will do it as soon as I install the new Gold Package on my server.
Afetr performing the insf -e -d asio0 command, still appears the UNCLAIMED hardware, but now the ignite works just fine with no comments.
Thanks for all the replys and help.