HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

Update-Ux using DRD

 
Sum_2
Occasional Contributor

Update-Ux using DRD

Hi All,
I just tried to upgrade my 11.23 OS to 11.31 on my drd cloned disk using "drd runcmd update-ux " command. But i am getting the following error. I have the latest verion of DRD running on my server. Can someone please sugget what wrong it is and how can i upgrade my OS (11.23 to 31) on the cloned disk using DRD .

Error
=====
======= 03/16/11 22:36:36 EDT BEGIN Executing Command On Inactive System
Image (user=root) (jobid=rx260-01)

* Checking for Valid Inactive System Image
* Analyzing Command To Be Run On Inactive System Image
* Locating Inactive System Image
* Preparing Inactive System Image For Command Execution
* The inactive system image is already mounted.
* Selected inactive system image "sysimage_001" on disk
"/dev/dsk/c3t2d0".
* Accessing Inactive System Image for Command Execution
* Setting Up Environment For Command Execution
* Executing Command On Inactive System Image
* Using unsafe patch list version 20061206
* Starting swagentd for drd runcmd
ERROR: The "update-ux" command can only be executed by "drd runcmd"
on B.11.31 and newer releases. B.11.23 is not supported.
* Stopping swagentd for drd runcmd
/opt/drd/wrappers/chrooted/stop_swagentd: not found
/opt/drd/wrappers/chrooted/stop_fsdaemon: not found
ERROR: Failed to run all post commands.
- The postcommand "/opt/drd/wrappers/chrooted/stop_fsdaemon" fails
with the return code "1".
- The postcommand "/opt/drd/wrappers/chrooted/stop_swagentd" fails
with the return code "1".
ERROR: Exiting due to keyboard interrupt.
* Cleaning Up After Command Execution On Inactive System Image
* Executing Command On Inactive System Image failed with 2 errors.

======= 03/16/11 22:36:57 EDT END Executing Command On Inactive System Image
failed with 2 errors. (user=root) (jobid=rx260-01)



Thanks,
Sumesh
3 REPLIES
Torsten.
Acclaimed Contributor

Re: Update-Ux using DRD

The reason is here:

ERROR: The "update-ux" command can only be executed by "drd runcmd"
on B.11.31 and newer releases. B.11.23 is not supported.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Matti_Kurkela
Honored Contributor

Re: Update-Ux using DRD

Is this error message somehow unclear?

> ERROR: The "update-ux" command can only be executed by "drd runcmd" on B.11.31 and newer releases. B.11.23 is not supported.

According to software.hp.com, even the latest version of DRD claims update-ux is only supported in this way:
----
# Perform an OE Update on the clone from an older version of HP-UX 11i v3 to HP-UX 11i v3 update 4 or later
----

Apparently, upgrading the HP-UX version using DRD is not possible at this time.

MK
MK
Ismail Azad
Esteemed Contributor

Re: Update-Ux using DRD

Hi,

As mentioned by Torsten and Matti, DRD can_not be used to upgrade from one version to another. To be more precise you can do "updates" Sep 2007, March 2008, September 2008, March 2009 and later releases.

DRD has as of now not progressed to update from one version to the other but only on to a better "operating environment" and that too normally only_for the 11.31 operating system.

For v2, you might also not see the kctune command on drd runcmd.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....