System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade from B.11.23.0609 into a more recent version

Samshen
Frequent Advisor

Upgrade from B.11.23.0609 into a more recent version

Hi,
My version of HPUX is B.11.23.0609.
I have to install a Virtual Machine on HPUX which requires a more recent version (the error was:
ERROR:: Bundle, HPUXBaseAux,r=B.11.23.0612 or greater is required for HP
: Please upgrade HPUX to version 0612 or later before continuing. ).
I found that the next bundle is:
Dec '07 (11.23 Standard Patch Bundles)
(I do not want the 2008s bundles).
Please inform me if I should install all these bundles in order to upgrade:

BUNDLE11i(B.11.23.0409.3) Required Patch Bundle for HP-UX 11i v2 (B.11.23), September 2004
HWEnable11i(B.11.23.0712.070) Hardware Enablement Patches for HP-UX 11i v2, December 2007
FEATURE11i(B.11.23.0712.070) Feature Enablement Patches for HP-UX 11i v2, December 2007
QPK1123(B.11.23.0712.070a) Quality Pack Depot for 11i v2, December 2007

(I am most doubting for BUNDLE11i, which is for an earlier version that mines).
Are these enough to perform the upgrade?

Thank you.
8 REPLIES
Steven E. Protter
Exalted Contributor

Re: Upgrade from B.11.23.0609 into a more recent version

Shalom,

swinstall of any newer bi-annual patch set from http://itrc.hp.com is the way to upgrade.

You get the same results on a binary level as a cold install.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Samshen
Frequent Advisor

Re: Upgrade from B.11.23.0609 into a more recent version

Hi,
I have rolled up the patches:

FEATURE11i_B.11.23.0712.070.depot
HWEnable11i_B.11.23.0712.070.depot

but still the version is:
HPUXBaseAux B.11.23.0609

Please help me which patchset to download to perform the upgrade.

Thank you.
James R. Ferguson
Acclaimed Contributor

Re: Upgrade from B.11.23.0609 into a more recent version

Hi:

The HPUXBaseAux bundle is part of the core-OS and is a fundamental part of identifying the release.

You will need to get current Operating Environment (OE ) media and perform an 'update_ux' to refresh your installation.

There is no reason for not using the most current (December 2008) patch bundles, either, to finish your upgrade. The standard bundles are the most well-tested patch sets available for general use.

Regards!

...JRF...
likid0
Honored Contributor

Re: Upgrade from B.11.23.0609 into a more recent version

yep you should do the update-ux, to update the base to the new release, I am on Dec07, and the upgragre processos worked fine on all the servers.

You should, make an ignite backup of your server
split mirrors if you have them

and then something like:

[root@sd:/]# swlist -l bundle | grep -i oe
HPUX11i-OE B.11.23.0712 HP-UX Foundation Operating Environment Component
[root@sd:/]# update-ux -s /your/release/depot HPUX11i-OE



that will get your hole system updated to 0712 in my case
Windows?, no thanks
Samshen
Frequent Advisor

Re: Upgrade from B.11.23.0609 into a more recent version

Hi,
Thank you for your replies.
Please inform me where I can get Operating Environment (OE ) media, can I download or I should order from HP? Is it free?

Thank you
Patrick Wallek
Honored Contributor

Re: Upgrade from B.11.23.0609 into a more recent version

>>Please inform me where I can get Operating
>>Environment (OE ) media, can I download or I
>>should order from HP? Is it free?

You cannot download any HP-UX installation media. You have to order it from HP. As long as you have an active software support contract the media is free. If you do not have software support, you will have to purchase it.
Samshen
Frequent Advisor

Re: Upgrade from B.11.23.0609 into a more recent version

Hi,
I have the HP-UX 11i V2 OE media (HPUPD_KITLBL B9106-60112) DVD, release June 2008.
My version of HPUX is B.11.23.0609 and I want to update the release.
I issue the command:

update-ux -s /dvdrom

but it fails with the error:
ERROR: This system is running the Foundation OE, and you have selected no OE
(base OS install). Updating from an OE to the base Operating System
is not supported.
ERROR: Pre-Update script update_ok.001 failed.

Please help me how to update the release of HPUX.

Thank you.
Torsten.
Acclaimed Contributor

Re: Upgrade from B.11.23.0609 into a more recent version

Please refer to

http://docs.hp.com/en/B3921-60631/update-ux.1M.html


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!