System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

 
Bob_Vance
Esteemed Contributor

VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

After installing VNC 4.1.3 on HPUX 11.31, it failed because it could not find libstdc++.sl .

libstdc++.sl is not an HPUX C library.

Apparently, the RealVNC VNC 4.1.3 binary was compiled with GCC.

I copied libstdc++.sl from an HPUX 11.23 PArisc system with GCC installed to 11.31 and it got rid of the library error.


HOWEVER, it exposed another problem:
on BOTH 11.23 and 11.31 , I now get
... /usr/lib/dld.sl: Unresolved symbol: __register_frame_info_table
... (code) from /usr/local/lib/libstdc++.sl

Anyone fixed this problem yet?


bv
"The lyf so short, the craft so long to lerne." - Chaucer
8 REPLIES
anypager
Occasional Visitor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

Did you get a solution? It also came to me.

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

>dld.sl: Unresolved symbol: __register_frame_info_table

You will need to get the version of libstdc++.sl that corresponds to the version of g++ used to compile VNC 4.1.3.
Bob_Vance
Esteemed Contributor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

No, I did not research it any further.
We can try Dennis' suggestion.

bv
"The lyf so short, the craft so long to lerne." - Chaucer
Bob_Vance
Esteemed Contributor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

I'm not going to pursue this anymore.

I forgot to mention that the 4.1.2 PA-RISC version works fine on both 11.23 and 11.31 on *both* PA-RISC and Itanium.

So, I'm simply sticking with the 4.1.2 version.

bv
"The lyf so short, the craft so long to lerne." - Chaucer
Jeff Arthur
Occasional Advisor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

I have the same issue on 11.11 any suggestions?

IS there a depot for 4.1.2 out there anywhere? I do not seem to be able to find one.

Jeff
A noise annoys an oyster, a noisy noise annoys an oyster more.
Bob_Vance
Esteemed Contributor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

You can get it at realvnc.com.
They currently have 4.1.3 depot available now.
I've downloaded it, but I haven't tried it.
You'll have to register to download it.

http://www.realvnc.com/cgi-bin/download.cgi
"The lyf so short, the craft so long to lerne." - Chaucer
Bob_Vance
Esteemed Contributor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

Excuse the brain fart.

As expected, the 4.1.3 PArisc 11.11 version did not work on 11.23.

So, I guess you tried 4.1.3 on 11.11 and really need 4.1.2.

It's an old, free version, but it's too big to attach.
contact me
bob_reg
aa
govance
dd
com


bv
"The lyf so short, the craft so long to lerne." - Chaucer
David Vann_2
Advisor

Re: VNC 4.1.3 fails with unresolved symbol on HPUX 11.23 and 11.31

I'm having the same issue with 4.1.3. I can't find a depot for 4.1.2. I've installed the tar version of 4.1.2 for hpux and I can get the vncserver to start, but none of the graphics display. Is there a 4.1.2 depot available or proper install instructions for the tar file. I followed the README instructions and no luck. The graphics will not display.