cancel
Showing results for 
Search instead for 
Did you mean: 

Very long login by ssh

Xou
Advisor

Very long login by ssh

Hi ALL!
I have trouble while login to OS by ssh. I use login@ssh command and after I input pass must wait approximately 20 minutes bash promt.

System info:
=================
OpenSSH_5.2p1+sftpfilecontrol-v1.3, OpenSSL 0.9.8g 19 Oct 2007
HP-UX Secure Shell-A.05.20.006, HP-UX Secure Shell version
===
sshd_config:

AllowTcpForwarding yes
ClientAliveCountMax 1
ClientAliveInterval 1440
HPNDisabled no
LogLevel DEBUG3
Port 22
Protocol 2
Subsystem sftp /opt/ssh/libexec/sftp-server
TCPKeepAlive yes
UseDNS no
UsePAM yes
X11DisplayOffset 10
X11Forwarding yes
X11UseLocalhost no
===
GNU bash, version 4.0.10(1)-release (ia64-hp-hpux11.31)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
===
machinfo
CPU info:
8 Intel(R) Itanium 2 9100 series processors (1.6 GHz, 24 MB)
533 MT/s bus, CPU version A1
16 logical processors (2 per socket)

Memory: 65403 MB (63.87 GB)

Firmware info:
Firmware revision: 9.48
FP SWA driver revision: 1.18
IPMI is supported on this system.
BMC firmware revision: 26.03

Platform info:
Model: "ia64 hp superdome server SD16B"
Machine ID number: ffffffff-ffff-ffff-ffff-ffffffffffff
Machine serial number:

OS info:
Nodename: alm
Release: HP-UX B.11.31
Version: U (unlimited-user license)
Machine: ia64
ID Number: 4294967295
vmunix _release_version:
@(#) $Revision: vmunix: B.11.31_LR FLAVOR=perf
===
kcusage nstrpty 729
average user by top: 35%
average sys by top: 40%
avr idle by top: 30%
29 REPLIES
Suraj K Sankari
Honored Contributor

Re: Very long login by ssh

Hi,
There are so many resions see the below thread...
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1352425

Suraj
Javed Khan_1
Valued Contributor

Re: Very long login by ssh

Hi,

Check if all dns servers are working fine which are mentioned in /etc/resolv.conf

Also check if you system is able to resolve dns


Javed
Never Give Up
Xou
Advisor

Re: Very long login by ssh

>Check if all dns servers are working fine which are mentioned in /etc/resolv.conf

>Also check if you system is able to resolve dns

look up, in sshd_config: UseDNS no
Ivan Krastev
Honored Contributor

Re: Very long login by ssh

Try to run server in DEBUG mode (sshd -d) and see for error messages.

regards,
ivan
avizen9
Esteemed Contributor

Re: Very long login by ssh

Hello,
its local account or NIS?

Xou
Advisor

Re: Very long login by ssh

>Try to run server in DEBUG mode (sshd -d) and see for error messages.

Messages in DEBUG 3 mode look like standart:

=============
Aug 17 09:53:25 SERVER sshd[14549]: Accepted keyboard-interactive/pam for user1 from 192.168.x.71 port 1149 ssh2
Aug 17 09:53:25 SERVER sshd[14549]: User child is on pid 26493
Aug 17 09:53:25 SERVER sshd[24136]: Accepted keyboard-interactive/pam for user2 from 192.168.x.120 port 42536 ssh2
Aug 17 09:53:26 SERVER sshd[24136]: User child is on pid 26701
Aug 17 09:53:27 SERVER sshd[22131]: Accepted keyboard-interactive/pam for user3 from 192.168.x.228 port 1401 ssh2
Aug 17 09:53:27 SERVER sshd[18165]: Accepted keyboard-interactive/pam for user4 from 192.168.x.29 port 1138 ssh2
Aug 17 09:53:27 SERVER sshd[22131]: User child is on pid 27433
Aug 17 09:53:27 SERVER sshd[18165]: User child is on pid 27538
Xou
Advisor

Re: Very long login by ssh

>its local account or NIS?
all accounts're local
Ivan Krastev
Honored Contributor

Re: Very long login by ssh

From the log file it looks that everything is ok - timestamps are fine:

Aug 17 09:53:26 SERVER sshd[24136]: User child is on pid 26701
Aug 17 09:53:27 SERVER sshd[22131]: Accepted keyboard-interactive/pam for user3 from 192.168.x.228 port 1401 ssh2


Check for any command started from the user .profile file(s).

regards,
ivan
Bill Hassell
Honored Contributor

Re: Very long login by ssh

Since the trace indicates that ssh login completed normally with no delays, the problem is with /etc/profile or .bashrc or .bash_profile. If other users do not have delays, then move the .bashrc (and .bash_profile) to another name and try again. If that fixes the problem, then move the bash profiles back and add this to the top of the profile:

set -vx

This will trace each step of the profile on the screen. The delay will be obvious then.


Bill Hassell, sysadmin
avizen9
Esteemed Contributor

Re: Very long login by ssh

if possible create a new test account and login with it through ssh.

it will clear the issue is something system related or that particular account related.

Tingli
Esteemed Contributor

Re: Very long login by ssh

Is it possible some file systems (especially the nfs disks) are not mounted?
Steve Post
Trusted Contributor

Re: Very long login by ssh

I had an initial slow ssh connection. I found it was caused by a 500 meg /var/adm/wtmp file. I ran this:

/etc/sbin/init.d/acct stop
/usr/sbin/nulladm /var/adm/wtmp
/etc/sbin/init.d/acct start

Now I ran this during a maintenence cycle so there were no people logged on. Run a man page on nulladm and wtmp.

Why would THIS cause delays to ssh????
Because file ssh_prnd_cmds runs a series of commands for randomness. One of the commands is "last." This command looks at the logins in the wtmp file. If the file is huge, it might take a while to get a response back. That delay in the "last" command WAS my login delay on ssh.

steve
PS: I probably got the solution of this from the hp forums when I was the guy asking about it.
Xou
Advisor

Re: Very long login by ssh

> Check for any command started from the user .profile file(s).

>if possible create a new test account and login with it through ssh.

I create new account with clear .profile but issue long wait are stay on.

>Is it possible some file systems (especially the nfs disks) are not mounted?

Isn't possible because all file systems are local

>I had an initial slow ssh connection. I found it was caused by a 500 meg /var/adm/wtmp file.....

du -k /var/adm/wtmp
32 /var/adm/wtmp

But I execute recommended commands and flush wtmp, issue is stay on.
avizen9
Esteemed Contributor

Re: Very long login by ssh

Have you check for below which bill suggested?

how about reboot this server? possible?


Since the trace indicates that ssh login completed normally with no delays, the problem is with /etc/profile or .bashrc or .bash_profile. If other users do not have delays, then move the .bashrc (and .bash_profile) to another name and try again. If that fixes the problem, then move the bash profiles back and add this to the top of the profile:

set -vx

This will trace each step of the profile on the screen. The delay will be obvious then.


Xou
Advisor

Re: Very long login by ssh

Also no wait when executes a single ssh command(example: ssh user1@SERVER ls) or scp.

Is it problem with pts initialization?
Xou
Advisor

Re: Very long login by ssh

>how about reboot this server? possible?
it isn't possible, system must work 24/7 by SLA.

>set -vx

after long wait same bash prompt standard output displayed:

================
# @(#)B.11.31_LR

# Default user .profile file (/usr/bin/sh initialization).

# Set up the terminal:
if [ "$TERM" = "" ]
then
eval ` tset -s -Q -m ':?hp' `
else
eval ` tset -s -Q `
fi
+ '[' xterm = '' ']'
tset -s -Q
++ tset -s -Q
+ eval export 'TERM;' 'TERM=xterm;'
export TERM; TERM=xterm;
++ export TERM
++ TERM=xterm
stty erase "^H" kill "^U" intr "^C" eof "^D"
+ stty erase '^H' kill '^U' intr '^C' eof '^D'
stty hupcl ixon ixoff
+ stty hupcl ixon ixoff
export TERM=xterm
+ export TERM=xterm
+ TERM=xterm
stty -istrip
+ stty -istrip
tabs
+ tabs

# NOTE: '.' is added to $PATH for compatibility reasons only. This
# default will be changed in a future release. If "." is not
# needed for compatibility it is better to omit this line.
# Please edit .profile according to your site requirements.

# Set up the search paths:
PATH=$PATH:.
+ PATH=/usr/bin:/usr/ccs/bin:/usr/contrib/bin:/usr/contrib/Q4/bin:/opt/perl/bin:/opt/ipf/bin:/opt/nettladm/bin:/opt/fcms/bin:/opt/wbem/bin:/opt/wbem/sbin:/opt/sas/bin:/opt/ssh/bin:/opt/graphics/common/bin:/opt/atok/bin:/usr/bin/X11:/usr/contrib/bin/X11:/opt/sec_mgmt/bastille/bin:/opt/caliper/bin:/opt/resmon/bin:/opt/drd/bin:/opt/dsau/bin:/opt/dsau/sbin:/opt/firefox:/opt/gnome/bin:/opt/perf/bin:/opt/ignite/bin:/usr/contrib/kwdb/bin:/opt/mozilla:/opt/prm/bin:/opt/perl_32/bin:/opt/perl_64/bin:/opt/sfm/bin:/opt/swm/bin:/opt/sec_mgmt/spc/bin:/opt/sentinel/bin:/opt/swa/bin:/opt/hpsmh/bin:/opt/thunderbird:/opt/langtools/bin:.

# Set up the shell environment:
set -u
+ set -u
trap "echo 'logout'" 0
+ trap 'echo '\''logout'\''' 0

# Set up the shell variables:
EDITOR=vi
+ EDITOR=vi
export EDITOR
+ export EDITOR

export PATH=/usr/local/bin:$PATH:/pragma/bin
+ export PATH=/usr/local/bin:/usr/bin:/usr/ccs/bin:/usr/contrib/bin:/usr/contrib/Q4/bin:/opt/perl/bin:/opt/ipf/bin:/opt/nettladm/bin:/opt/fcms/bin:/opt/wbem/bin:/opt/wbem/sbin:/opt/sas/bin:/opt/ssh/bin:/opt/graphics/common/bin:/opt/atok/bin:/usr/bin/X11:/usr/contrib/bin/X11:/opt/sec_mgmt/bastille/bin:/opt/caliper/bin:/opt/resmon/bin:/opt/drd/bin:/opt/dsau/bin:/opt/dsau/sbin:/opt/firefox:/opt/gnome/bin:/opt/perf/bin:/opt/ignite/bin:/usr/contrib/kwdb/bin:/opt/mozilla:/opt/prm/bin:/opt/perl_32/bin:/opt/perl_64/bin:/opt/sfm/bin:/opt/swm/bin:/opt/sec_mgmt/spc/bin:/opt/sentinel/bin:/opt/swa/bin:/opt/hpsmh/bin:/opt/thunderbird:/opt/langtools/bin:.:/pragma/bin
+ PATH=/usr/local/bin:/usr/bin:/usr/ccs/bin:/usr/contrib/bin:/usr/contrib/Q4/bin:/opt/perl/bin:/opt/ipf/bin:/opt/nettladm/bin:/opt/fcms/bin:/opt/wbem/bin:/opt/wbem/sbin:/opt/sas/bin:/opt/ssh/bin:/opt/graphics/common/bin:/opt/atok/bin:/usr/bin/X11:/usr/contrib/bin/X11:/opt/sec_mgmt/bastille/bin:/opt/caliper/bin:/opt/resmon/bin:/opt/drd/bin:/opt/dsau/bin:/opt/dsau/sbin:/opt/firefox:/opt/gnome/bin:/opt/perf/bin:/opt/ignite/bin:/usr/contrib/kwdb/bin:/opt/mozilla:/opt/prm/bin:/opt/perl_32/bin:/opt/perl_64/bin:/opt/sfm/bin:/opt/swm/bin:/opt/sec_mgmt/spc/bin:/opt/sentinel/bin:/opt/swa/bin:/opt/hpsmh/bin:/opt/thunderbird:/opt/langtools/bin:.:/pragma/bin
export LANG=ru_RU.cp1251
+ export LANG=ru_RU.cp1251
+ LANG=ru_RU.cp1251
export LC_ALL=ru_RU.cp1251
+ export LC_ALL=ru_RU.cp1251
+ LC_ALL=ru_RU.cp1251

-bash-4.0$ exit
exit
+ exit
logout
echo 'logout'
+ echo logout
logout
Connection to SERVER closed.
Dennis Handly
Acclaimed Contributor

Re: Very long login by ssh

>>set -vx

>after long wait same bash prompt standard output displayed:

You're saying that there is a long wait before the contents of /etc/profile is printed?
If quota checking delays, I think that prints something?

Can you try the same thing with another user that uses the real shell, /usr/bin/sh?
Mel Burslan
Honored Contributor

Re: Very long login by ssh

Could you also provide the contents of your /etc/profile ? Looks like something in there is causing you all this grief.
________________________________
UNIX because I majored in cryptology...
Turgay Cavdar
Honored Contributor

Re: Very long login by ssh

What about the sizes of /var/adm/wtmps and /var/adm/wtmp?
Xou
Advisor

Re: Very long login by ssh

> Could you also provide the contents of your /etc/profile ? Looks like something in there is causing you all this grief.

Look trace up.

> What about the sizes of /var/adm/wtmps and /var/adm/wtmp?

Look up.

Next is log ssh -vvv user1@SERVER
=============
OpenSSH_5.1p1 Debian-5ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /home/xou/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to alm [192.168.1.201] port 22.
debug1: Connection established.
debug1: identity file /home/xou/.ssh/identity type -1
debug3: Not a RSA1 key file /home/xou/.ssh/id_rsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /home/xou/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/xou/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2p1+sftpfilecontrol-v1.3
debug1: match: OpenSSH_5.2p1+sftpfilecontrol-v1.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5ubuntu1
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-cbc hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 119/256
debug2: bits set: 527/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: filename /home/xou/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 26
debug3: check_host_in_hostfile: filename /home/xou/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 27
debug1: Host 'alm' is known and matches the RSA host key.
debug1: Found key in /home/xou/.ssh/known_hosts:26
debug2: bits set: 508/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/xou/.ssh/identity ((nil))
debug2: key: /home/xou/.ssh/id_rsa (0xb8b6ba98)
debug2: key: /home/xou/.ssh/id_dsa ((nil))
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug3: start over, passed a different list publickey,password,keyboard-interactive
debug3: preferred gssapi-keyex,gssapi-with-mic,gssapi,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/xou/.ssh/identity
debug3: no such identity: /home/xou/.ssh/identity
debug1: Offering public key: /home/xou/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug2: input_userauth_pk_ok: fp 53:81:f4:01:29:2c:29:32:32:ea:9e:29:e1:6f:19:3e
debug3: sign_and_send_pubkey
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug2: callback start
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug3: tty_make_modes: ospeed 38400
debug3: tty_make_modes: ispeed 38400
debug1: Sending environment.
debug3: Ignored env SSH_AGENT_PID
debug3: Ignored env DM_CONTROL
debug3: Ignored env GPG_AGENT_INFO
debug3: Ignored env TERM
debug3: Ignored env DESKTOP_STARTUP_ID
debug3: Ignored env SHELL
debug3: Ignored env XDG_SESSION_COOKIE
debug3: Ignored env XDM_MANAGED
debug3: Ignored env KONSOLE_DBUS_SERVICE
debug3: Ignored env GTK2_RC_FILES
debug3: Ignored env GS_LIB
debug3: Ignored env WINDOWID
debug3: Ignored env KDE_FULL_SESSION
debug3: Ignored env http_proxy
debug3: Ignored env USER
debug3: Ignored env LS_COLORS
debug3: Ignored env SSH_AUTH_SOCK
debug3: Ignored env SESSION_MANAGER
debug3: Ignored env PATH
debug3: Ignored env DESKTOP_SESSION
debug3: Ignored env PWD
debug3: Ignored env KDE_SESSION_UID
debug1: Sending env LANG = ru_RU.UTF-8
debug2: channel 0: request env confirm 0
debug3: Ignored env KONSOLE_DBUS_SESSION
debug3: Ignored env HISTCONTROL
debug3: Ignored env COLORFGBG
debug3: Ignored env HOME
debug3: Ignored env SHLVL
debug3: Ignored env KDE_SESSION_VERSION
debug3: Ignored env LANGUAGE
debug3: Ignored env XCURSOR_THEME
debug3: Ignored env LOGNAME
debug3: Ignored env XDG_DATA_DIRS
debug3: Ignored env DBUS_SESSION_BUS_ADDRESS
debug3: Ignored env LESSOPEN
debug3: Ignored env WINDOWPATH
debug3: Ignored env PROFILEHOME
debug3: Ignored env DISPLAY
debug3: Ignored env QT_PLUGIN_PATH
debug3: Ignored env LESSCLOSE
debug3: Ignored env _
debug3: Ignored env OLDPWD
debug2: channel 0: request shell confirm 1
debug2: fd 3 setting TCP_NODELAY
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_confirm: type 99 id 0
debug2: shell request accepted on channel 0

===========

Wait is after line "debug2: channel 0: open confirm rwindow 0 rmax 32768"
Dennis Handly
Acclaimed Contributor

Re: Very long login by ssh

>> What about the sizes of /var/adm/wtmps and /var/adm/wtmp?

>Look up.

Since you are on 11.31, you may need to check all 6 files:
du -k /var/adm/wtmp* /etc/utmp*
Mel Burslan
Honored Contributor

Re: Very long login by ssh

>> Could you also provide the contents of your /etc/profile ? Looks like something in there is causing you all this grief.

> Look trace up.

I also can not see any trace of /etc/profile anywhere in the thread. Maybe you need to read the postings a little more carefully.
________________________________
UNIX because I majored in cryptology...
OldSchool
Honored Contributor

Re: Very long login by ssh

Ok, so where/how did the "set -vx" get set. did you type it or stick it in one of the profiles????

it appears to have echoed the .profile. You said it still had a delay, and that the .profile stuff printed in a reasonable time (once it started). that leaves /etc/profile, which still hasn't been posted. you might consider adding a message at the begining and end of that file, or a "set -vx" to that one.

it almost sounds like its trying to do quota checking, but a drive is missing.
Dennis Handly
Acclaimed Contributor

Re: Very long login by ssh

>OldSchool: it almost sounds like its trying to do quota checking, but a drive is missing.

I mentioned that above but I would hope that it prints a progress message saying it is doing that, since it takes some time.

Do we know where in the login process it prints those quota checking messages? Before/after the motd or copyright?
I have:
1) last login info
2) /etc/motd
3) /etc/profile -> You have mail.
4) ~/.profile