cancel
Showing results for 
Search instead for 
Did you mean: 

VxFSD utilizing more CPU

resolve of disks fails
Occasional Advisor

VxFSD utilizing more CPU

Hi

Can any one let me know What is this VxFSD this Deamon is utilizing more CPU ,pls let me know how we can reduce this utilization.

CPU TTY PID USERNAME PRI NI SIZE RES STATE TIME %WCPU %CPU COMMAND
12 ? 72 root 152 20 38736K 34432K run 35614:17 158.03 157.75 vxfsd


Regards
Vishal
3 REPLIES
likid0
Honored Contributor

Re: VxFSD utilizing more CPU

Hi, it's the vxfsd daemon, which is in charge of the vxfs filesystems.

you should check you don't have memory preassure on that server and you are swapping like mad, could you post #swapinfo -atm , and also check the vhand daemon isn't eating cpu also.


You can also make the inode cache static because.
By default you get a dynamic cache which increases and decreases over time. Thus at regular intervals one of the vxfsd daemons scans the inode free list and free's inactive inodes.


The tunable kernel parameter vx_ifree_timelag can be changed to control how long an inode is inactive
before it is freed.By Setting
vx_ifree_timelag to 0 you make the inode cache static.
Windows?, no thanks
likid0
Honored Contributor

Re: VxFSD utilizing more CPU

We also need to know what versions are you running, so,veritas, etc.

So you can check for missing patches.
Windows?, no thanks
kashyapi
Frequent Advisor

Re: VxFSD utilizing more CPU

your filesystem utilization is very high ie most of the filesystems are full or above 80%.
When your filesystem utilization is high CPU utilization for Vxfsd will be more....

:)