HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

WBEM - cimprovagt is utilising more CPU (100%)

 
SOLVED
Go to solution
sabinkarvijay
Frequent Advisor

WBEM - cimprovagt is utilising more CPU (100%)

Hi All,

We had a issue with one of the process which is utilising more CPU..not sure what it is for..

CPU TTY PID USERNAME PRI NI SIZE RES STATE TIME %WCPU %CPU COMMAND
7 ? 27409 root 152 20 208M 54508K run 149141:19 100.09 99.91 cimprovagt

root 27409 1876 0 Mar 6 ? 149141:28 /opt/wbem/lbin/cimprovagt 18 17 HP_NParProviderModule

I could see it's running for such a long time since 105 days..

if anyone aware, Please let me know How can i Proceed for decreasing the utilisation of CPU by that process...

Thanks in Advance,

Regards,

Vijay Sabinkari.
15 REPLIES
Vivek Bhatia
Trusted Contributor
Solution

Re: WBEM - cimprovagt is utilising more CPU (100%)

Hi Sabin,

I would suggest you to log a case with HP and ask for the latest patches if any.

Keep us informed.

Regards
Vivek
Mel Burslan
Honored Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

what is your OS version ? Do you have (more than likely you do) system fault manager (SFM) installed and what is the version of that ? What type of hardware you are running on ?

There are/were a lot of performance problems related to WBEM related services. Your best bet is to contact HP under a software support agreement as this foray into troubleshooting may turn ugly real fast.
________________________________
UNIX because I majored in cryptology...
sabinkarvijay
Frequent Advisor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Hi Vivek/Mel,

we ran the below command on the server:

#/opt/wbem/lbin/cimserver -s

and found that the process utilisation increased more than 190 %

So went for starting the Cimserver using the below command:

#/opt/wbem/lbin/cimserver

Now there were two instances of cimserver processes running...

So went for killing the old processes which are running for such a longtime..

Now the same process is utilising very less amount of CPU...

Hope the Problem got resolved now:

Regards,
Vijay Sabinkari.
Mel Burslan
Honored Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

If what I have read is similar to your configuration, believe me, it will come back in a few days if not few hours. So check with HP to get necessary patches for your H/W, OS and S/W versions.
________________________________
UNIX because I majored in cryptology...
sabinkarvijay
Frequent Advisor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Thanks for your concern Mel,

I will do that...

Regards,
Vijay Sabinkari.
Steven E. Protter
Exalted Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Shalom,

The general cause for such problems is a problem with the application.


WBEM may be patched by patches from the patch database at http://itrc.hp.com or it may need to be replaced with a new set of binaries.

The new binaries may come from http://software.hp.com or on the application DVD, which is available to users with a service contract covering software.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Armin Kunaschik
Esteemed Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

HP probably will recommend updating to the most current version of WBEM and all the surrounding providers.
From my experience the whole WBEM functionality is still beta software!
I have the same problems again and again, even with the newest versions. My "workaround" for this is to stop/start cimserver on a regular basis. Most of the time the cimserver is not able to stop gracefully, leaving some cimproviders running. Then those leftover processes have to be killed before restarting cimserver.

My 2 cents,
Armin

PS: Please assign points!
And now for something completely different...
sabinkarvijay
Frequent Advisor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Hi Armin,

the process which i did for stopping and starting of Cimserver I have mentioned in this thread... is it correct?


Thanks in Advance,

Regards,
Vijay Sabinkari.
Armin Kunaschik
Esteemed Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

"cimserver -s" should stop the cimserver and all child cimprovagt's. But this doesn't always work. After "cimserver -s" you should check that no other cim* processes are alive anymore (except cimserverd which is started from inittab).

My 2 cents,
Armin
And now for something completely different...
sabinkarvijay
Frequent Advisor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Hi Armin,

So finally I have concluded to do below , if it happens again:
=============================================================
1) stop cimserver by using below command:

#cimserver -s

2) Kill old running cim processes as below:

#ps -ef | grep cim*

We will kill all running cim* processes:

kill -9


3) start the cim process by using below command:


#cimserver

==========================================================

Here I have one more query ,

I didn't find any entry related to "cimserverd" in "/etc/inittab", Let me know How can i proceed for this?


Thanks in Advance,

Regards,
Vijay Sabinkari.

Re: WBEM - cimprovagt is utilising more CPU (100%)

>I didn't find any entry related to cimserverd in /etc/inittab, how can I proceed for this?

I assume that when you used "cimserver -s" the entry was removed from inittab.

More info:
http://docs.hp.com/en/B8465-90017/ch05s03.html

Note: We are talking about belts and suspenders here. There is cimserverd that checks to see if cimserver is running. Then there is init(1m) that checks to see if cimserverd is running.
Armin Kunaschik
Esteemed Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

I tried "cimserver -s" and it did not remove the cim entry from inittab.
Mine looks like:
cim1:3456:respawn:/opt/wbem/lbin/cimserverd

My 2 cents,
Armin
And now for something completely different...
sabinkarvijay
Frequent Advisor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Hi Armin,

Can i try adding this entry manually in /etc/inittab ?


could you please give me the correct entry inorder to add..

Thanks in Advance,

Regards,
Vijay Sabinkari.
Mel Burslan
Honored Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

Vijay,

You can copy the line in Armin's post verbatim and put it into your /etc/inittab without any modification. The order of the lines in this file should not make any difference, so you can put it anywhere in the file as long as it is on a new line by itself.
________________________________
UNIX because I majored in cryptology...
Armin Kunaschik
Esteemed Contributor

Re: WBEM - cimprovagt is utilising more CPU (100%)

I wonder why this entry is not there... please run swverify \* and take care about any errors and/or unconfigured packages.
You can simply add the line I posted and issue an "init q" to ask init to re-read the inittab.

My 2 cents,
Armin
And now for something completely different...