cancel
Showing results for 
Search instead for 
Did you mean: 

Write to DVD

SOLVED
Go to solution
cuppajo
Advisor

Write to DVD

On my rp3440 running 11.11 I am having a problem writing a single file to a DVD. I have a DVD drive, and I am using a DVD+R disc which is new. We run our recoveries to this DVD drive successfully, but I am having the hardest time just writing one file to DVD.

The command I am using is:
/opt/ignite/lbinpa/./growisofs -Z /dev/rdsk/c0t0d0 filename

It comes back with:
Executing 'mkisofs filename | builtin_dd of=/dev/rscsi/c0t0l0 obs=32k seek=0'
:-( unable to execute mkisofs: No such file or directory
:-( write failed: I/O error

I am root, and all permissions seem to be in line. The drive does work. I tried running it from from the directory where both growisofs and mkisofs are located, and I tried running it where the file is located.

Much obliged if you can offer advice.
5 REPLIES
Steven Schweda
Honored Contributor
Solution

Re: Write to DVD

I don't use it, so I know nothing, but if
"growisofs" is a program or shell script
which tries to run "mkisofs", that might
explain your error message.

Figure out where "mkisofs" is, and add that
directory to your PATH.

Knowing nothing, I might start with something
like:

find /opt/ignite -name mkisofs

Around here:

dyi # uname -a
HP-UX dyi B.11.31 U ia64 4235313755 unlimited-user license

dyi # find /opt/ignite -name mkisofs
/opt/ignite/lbinia/mkisofs
/opt/ignite/lbinpa/mkisofs

So, if you're using
"/opt/ignite/lbinpa/growisofs", I'd vote for
adding "/opt/ignite/lbinpa" to your PATH.
(That should save some keystrokes when you
run "growisofs", too.)
cuppajo
Advisor

Re: Write to DVD

Added that directory to my path and saved profile, but I received the same error message.
Pete Randall
Outstanding Contributor

Re: Write to DVD

> Added that directory to my path and saved profile

Yes, but did you run the profile? Check your path now to make sure.


Pete

Pete
Steven Schweda
Honored Contributor

Re: Write to DVD

Editing "~/.profile" and adding something to
PATH are not equivalent. What, exactly, did
you do?

echo $PATH
cuppajo
Advisor

Re: Write to DVD

Ok, I edited my path this way:

PATH=$PATH\:/opt/ignite/lbinpa ; export PATH

...and now my command works. Thanks for your patience, tips, and instruction.