HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong default gateway

 
Fidel Ramirez_1
Frequent Advisor

Wrong default gateway

This is a HP-UX 11.31 rp3440 server and its host NIC is on lan0.
netstat -nr output is
default x.x.x.x UG 0 lan2 1500
instead of lan0.
The netconf file is ok.
I have rebooted the server and used
route delete default gateway and then
route add default gateway 1
but netstat keeps showing lan2 on the gateway and there is no connectivity to the outside.
I’ll appreciate your input on this issue.
Thank you,
Fidel
10 REPLIES
Ismail Azad
Esteemed Contributor

Re: Wrong default gateway

Hi,

Try editting netconf with the gateway entry and also do assign the gateway with the all powerful command set_parms. Try both. Hope it helps.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Steven Schweda
Honored Contributor

Re: Wrong default gateway

> default x.x.x.x UG 0 lan2 1500

Hiding potentially useful details ("x.x.x.x")
may not be the most efficient path to helpful
answers.

> The netconf file is ok.

I'm glad that you like it, but seeing the
actual file contents might be more helpful
than seeing your opinion of them.

> but netstat keeps showing lan2 on the
> gateway [...]

And this is a problem because ...?

> [...] there is no connectivity to the
> outside.

You determined this how?

As usual, showing actual commands with their
actual output can be more helpful than vague
descriptions or interpretations.

It might be helpful if you revealed the IP
addresses and netmasks of all the interfaces
on this system. And "gateway".
Hakki Aydin Ucar
Honored Contributor

Re: Wrong default gateway

I faced a similar problem before;

Sometimes with some reason route delete can be unable to delete specified route, you can then try the following to just flush the route tables *

# /usr/sbin/route â f

prior to do this I recommend to keep a backup of old netstat -rn output, and netconf file.
V. Nyga
Honored Contributor

Re: Wrong default gateway

Hi,

route has nothing to do with the lan-id you use.
Your server will always use the defined lan!
You can try to use SAM (Networking and Communications) to change the settings.

HTH
V.
*** Say 'Thanks' with Kudos ***
Laurent Menase
Honored Contributor

Re: Wrong default gateway

Hi Fidel,

Without a netstat -nrv and netstat -ni
and the address of the default gateway
it will be difficult to help you
Laurent Menase
Honored Contributor

Re: Wrong default gateway

> default x.x.x.x UG 0 lan2 1500
> instead of lan0.
This means that the address of your default x.x.x.x is in lan2 subnet range.

Dave Johnson_1
Super Advisor

Re: Wrong default gateway

Can you provide the output of netstat -nr?
Mel Burslan
Honored Contributor

Re: Wrong default gateway

looks like your interface where you are routing your default route to, is defined on lan2 instead of the lan0. As previously said, blanking out the IP addresses does not help in your case as they are the most relevant piece of information.

make sure the ip address associated with the default route is showing up under lan0 as you expect but not on lan2 (which I am assuming is in your case). Once you re-configure your lan from lan2 to lan0, everything will be okay.

outputs from the following commands would be most helpful

lanscan
ifconfig lan0
ifconfig lan2
netstat -rn
netstat -in

________________________________
UNIX because I majored in cryptology...
Fidel Ramirez_1
Frequent Advisor

Re: Wrong default gateway

Thank you all who responded to my question.
The issue was a switch port wrongly assigned.
Thank you again for your great help.

Fidel
Fidel Ramirez_1
Frequent Advisor

Re: Wrong default gateway

Bad switch port connected to the server.