cancel
Showing results for 
Search instead for 
Did you mean: 

X11 Collgui problem

X11 Collgui problem

I am getting the following error when I try to start collgui from my workstation on our old Alphaserver running TRU64 V51A. This machine is identical to our production machine where this works OK.
**************
# collgui
Xlib: connection to "10.206.201.57:0.0" refused by server
Xlib: Client is not authorized to connect to Server
java.lang.InternalError: Can't connect to X11 window server using '10.206.201.57
:0.0' as the value of the DISPLAY variable.
Check DISPLAY environment variable setting.
*************
I have checked all the configuration things that I know about and see no differences between the machines.

CDS
12 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: X11 Collgui problem

Hi,

please check with dxhosts hat your client has authorized access to the machine.

greetings,

Michael

Re: X11 Collgui problem

Thanks for the tip. I checked the dxhosts on the Alphaserver and my client was there. To be sure I added all hosts to the ACL. When I tried to login again, it failed, but this time the error message was different It was failing when the Alpha tried to connect back to my client. This Alpha was brought out of retirement recently and had a different IP address in the past. I deleted it from Access, Accounts, deleted all Applications for it, and reset the hosts entry on my client. Restarted the server. Added it back in with the new IP address to Accounts, Access and made an Xterm application and it worked! Thanks.

Re: X11 Collgui problem

A little hasty. Xterm worked, but collgui still isn't !?!
Venkatesh BL
Honored Contributor

Re: X11 Collgui problem

did u try "xhost +"?

Does apps like 'xclock' run fine?
Kris Smith
Advisor

Re: X11 Collgui problem

Charles,

From the iformation provided, I would assume that you are using xdm (X display manager and would expect that you have a Session Manager menu. If so, on this menu, select Options -> Security... On this menu, type in the Hostname of the remote Alpha and press Add, then Apply, then OK. If you don't have the appropriate host name in /etc/hosts, you must edit that file or you can enter the IP address instead of hostname in the Security... dialog. To make this permanent, select Session Manager -> Save Current Settings. Hope this helps.

Regards,
Kris

Re: X11 Collgui problem

I am using eXcursion. The remote Alpha is defined in the local machine hosts file and Xterm works OK, but that seems to be the only application that will run. At least, clock won't and Collgui won't.
Kris Smith
Advisor

Re: X11 Collgui problem

Charles,

If you are starting collgui from the command line, are you specifying the environment variable for DISPLAY? In other words, are you specifying
#setenv DISPLAY=hostname:0.0 (csh)(hostname:display#) or
#export DISPLAY=hostname:0.0 (ksh)
From looking closer at your original posting, it seems that this is the primary issue in your problem. Before starting any graphics application from the command line, it is necessary to tell the application where to DISPLAY the graphics. Maybe this will help.

Regards,
Kris

Re: X11 Collgui problem

Yes I think the DISPLAY variable is set correctly. Here is what I get when logged in.

# env | grep DISPLAY
DISPLAY=10.206.201.57:0.0

57 is my clients IP address.
Michael Schulte zur Sur
Honored Contributor

Re: X11 Collgui problem

Charles,

you use a pc as a client?
If so try 10.206.201.57:0 as DISPLAY
.0 is used when you have more than one window like on the graphics console.

hth,

Michael
Kris Smith
Advisor

Re: X11 Collgui problem

Charles,

Xterm is a command line application, unlike clock and collgui. What you ARE seeing is an indication that the application that has graphics to display cannot resolve the machine (IP) and display number(:0) of the receiving device. Since you received the response about the display error, it can be assumed that there is no IP issue (the server knows who you are and how to get to you). There is a problem with the DISPLAY portion, which is probably due to the :0.0 vs :0 setting, as described in the last posting. It is likely that you have authorized 10.206.201.57:0 in your Security settings, but the application is trying to connect to 10.206.201.57:0.0 which does not match (on a character basis). You could always try adding both the :0.0 and the :0 to see if that resolves your issue.
If that does not work, you will need to supply more information, as troubles described by the info you posted, to the best of my knowledge, have been answered.
Also, please post a notification when this problem has been fixed.

Regards,
Kris

Re: X11 Collgui problem

Thanks to everyone for the suggestions. I have decided to bail on collgui. I am going to try using cfilt to create a text file that I will import into Excel.

CDS

Re: X11 Collgui problem

Taking another approach