System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

XWindows KDE network login

 
SOLVED
Go to solution

XWindows KDE network login

I have installed redhat 7.1 (More times than I can remember haha). I have the X desktop setup on the main console session 7 like normal. However, I would like to offer this desktop on a XDMCP broadcast. Sometimes when I install redhat I can use my windows workstation Xwindows client and connect perfectly. Other times I install redhat I cannot. From an administrator standpoint I am frustrated. I have the GUI login setup on the main console. Now I want to offer it to my network clients via XDMCP broadcasts. Can someone point me in the right direction? What services should I make sure are running? Etc.
SCO veteran converting to HP UX
2 REPLIES 2
Highlighted
Mike Brown_3
Frequent Advisor
Solution

Re: XWindows KDE network login

Have done this many times ....... but a while ago now.
Check out the following - it may help;
http://www.linuxgazette.com/issue27/kaszeta.html

And also try -indirect instead of -query in the
X startup line, ensuring you have a willing indirect xdm server to run the chooser.
See Xserver and xdm man pages for more details.

There's no substitute for experience
Kodjo Agbenu
Honored Contributor

Re: XWindows KDE network login

Hello,

By default, XDMCP is disable because it is considered by security specialists as a security hole. Why ? I don't know, but I suppose they know what they say... :-)

To enable XDMCP :

-> Edit /etc/X11/xdm/Xaccess : make sure that the two following lines are uncommented :

* #any host can get a login window
* CHOOSER BROADCAST #any indirect host can get a chooser


-> Edit /etc/X11/xdm/xdm-config : check that the XDMCP port is well configured :

DisplayManager.requestPort: 177


-> If you are using KDE2, edit /usr/share/config/kdm/kdmrc or /opt/kde2/share/config/kdm/kdmrc, then check the following lines :

[Xdmcp]
Enable=true


-> If you are using gnome instead, edit /etc/X11/gdm/gdm.conf (or /etc/opt/gnome/gdm/gdm.conf) :

[xdmcp]
Enable=true
HonorIndirect=true
...
Port=177


After that, re-start the login screen (xdm, gdm, kdm) then try again.


Note : one additional point : make sure that the xdmcp service exists in /etc/services, and that network connections to this port are not disabled in /etc/hosts.allow or /etc/hosts.deny.


Good luck.

Kodjo


P.S. Don't forget to assign points to this answer (from 1 to 10).
Learn and explain...