cancel
Showing results for 
Search instead for 
Did you mean: 

Xen - installation

Piotr Kirklewski
Super Advisor

Xen - installation

Hi there I'm following this tutorial:

http://www.howtoforge.com/xen_3.0_ubuntu_dapper_drake

Till now I did this:

1. 1.Install a clean base server system.

2. apt-get update

3. apt-get upgrade

4. apt-get install iproute python python-twisted bridge-utils debootstrap
5. wget http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-3.0.1-install-x86_32.tgz
6. tar xvf xen-3.0.1-install-x86_32.tgz

7. cd xen-3.0.1-install

8. ./install.sh

9. Check for error messages - it should say OK to all.

10. see /lib/modules for the correct kernel version
(2.6.12.6-xen 2.6.12.6-xen0 2.6.12.6-xenU

2.6.15-26-server)

11. /sbin/depmod -a 2.6.12.6-xen

12. Edit /etc/mkinitramfs/modules and append the following line:
loop max_loop=64

13. cd /boot

14. mkinitramfs -o initrd.img- 2.6.12.6-xen 2.6.12.6-xen


And I'm having this eror:

root@xen:/boot# mkinitramfs -o initrd.img-2.6.12.6-xen 2.6.12.6-xen

W: udev hook script requires at least kernel version 2.6.15
W: not generating requested initramfs for kernel 2.6.12.6-xen


Does anyone know how to get rid of this problem ?

Cheers
Jesus is the King
1 REPLY
Ivan Ferreira
Honored Contributor

Re: Xen - installation

Maybe is complaining about you current kernel version, what is your current kernel version? Try updating your current kernel version above 2.6.15.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?