Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

a question swinstall difference between HPUX B.11.11 and B.11.23

hank_xu
Occasional Visitor

a question swinstall difference between HPUX B.11.11 and B.11.23

Hello,
When I use swinstall to update my software to a new version. I met a difference between HPUX B.11.11 and HPUX B.11.23. Who can help me to analyse it? Thanks in advance.

My software consists of 2 filesets: Mysoft.PRE and Mysoft.POST. Mysoft.PRE is prerequisite of Mysoft.POST. The install sequence is Mysoft.PRE then Mysoft.POST.

On a HPUX B.11.11 machine with Mysoft D.01.40.00011 is installed, then I update it with Mysoft D.01.50.00002 by swinstall, it is ok. But turn onto HPUX B.11.23, it fails. The error message is as below:

******************
* The installed fileset
"Mysoft.POST,l=/opt/mysoft,r=D.01.40.00011" requires
the fileset
"Mysoft.PRE,l=/opt/mysoft,r=D.01.40.00011" as a
prerequisite. The new version of the prerequisite,
"Mysoft.PRE,r=D.01.50.00002", does not satisfy the
dependency.
ERROR: The dependencies for fileset
"Mysoft.POST,l=/opt/mysoft,r=D.01.40.00011" cannot
be resolved (see previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* Executing preDSA command.

* Summary of Analysis Phase:
ERROR: Exclude Mysoft.PRE,r=D.01.50.00002
ERROR: 1 of 1 filesets had Errors.
ERROR: The Analysis Phase had errors. See the above output for
details.
******************

It shows on HPUX B.11.23 machine, Mysoft.PRE D.01.40.00011 is replaced by D.01.50.00002 version. But it breaks the prerequiste relationship with Mysoft.POST D.01.40.00011. Then means Mysoft.POST D.01.40.00011 does not allow Mysoft.PRE D.01.40.00011 to be removed. But HPUX B.11.11 allows it, why?

BTW, I do not use versioned directory to store Mysoft. New version will completely overwite the old version, but not switch links
4 REPLIES
Steven E. Protter
Exalted Contributor

Re: a question swinstall difference between HPUX B.11.11 and B.11.23

Shalom,

HP-UX 11.23 is a totally different replease of HP-UX. It is designed to work on PA-RISC or IA-64 Itanium systems.

Software designed specifically for 11.23 will not install on an 11.11 system.

"Mysoft.PRE,r=D.01.50.00002", does not satisfy the
dependency. May require ysoft.PRE D.01.40.00011 be installed first. This software might work on both 11.23 and 11.11.

The problem here is 11.11 is a PA-RISC chip only release and 11.23 will work on either PA-RISC or IA-64. Many vendors had to write software in two sets for the two architectures.

I think this issue is best resolved with the software vendor. You have not described your hardware but I suspect the 11.23 machnine may be IA-64 and the software is not.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Dennis Handly
Acclaimed Contributor

Re: a question swinstall difference between HPUX B.11.11 and B.11.23

>Mysoft.PRE D.01.40.00011 is replaced by D.01.50.00002 version. But it breaks the prerequiste relationship with Mysoft.POST D.01.40.00011.

Right. Your installation instructions must say to remove both pieces before installing the new pieces. If your Mysoft.POST D.01.40.00011 will actually work with Mysoft.PRE D.01.50.00002, you should have used r>=D.01.40.00011.

>Then means Mysoft.POST D.01.40.00011 does not allow Mysoft.PRE D.01.40.00011 to be removed. But HP-UX B.11.11 allows it, why?

I can only assume that swinstall has been fixed to enforce dependencies correctly. Suppose you weren't installing Mysoft.POST D.01.50.00002, the state would be messed up.

The simple way to solve this is to not use requisites and document that you must install both filesets.
hank_xu
Occasional Visitor

Re: a question swinstall difference between HPUX B.11.11 and B.11.23

Hi Dennis,
>>I can only assume that swinstall has been fixed to enforce dependencies correctly. Suppose you weren't installing Mysoft.POST D.01.50.00002, the state would be messed up.

Can I get some HP documents which can prove the assumption?
Dennis Handly
Acclaimed Contributor

Re: a question swinstall difference between HPUX B.11.11 and B.11.23

>Can I get some HP documents which can prove the assumption?

I seriously doubt it unless it is mentioned in the 11.23 Release Notes.
I suppose if you have a support contract you can discuss it with the Response Center. Or wait and see if Bob has an opinion.