cancel
Showing results for 
Search instead for 
Did you mean: 

advfs (not) full

SOLVED
Go to solution
Roberto Polli
Trusted Contributor

advfs (not) full

Hi all,
on osf1 v5.1b i get a daily mail warning me that root_domain is full.

1)df -h shows root_domain is 65% free
2)I can't (re)boot or "init S" so can't safely use quotacheck on root_domain
3)some days ago root_domain may have been full but that situation lasted some minutes (as df -h showed)

q1) how does the cron'ed mail realize that the FS is full?
q2) do you know how to resolve this problem?

hints: in kernel tuning parameters there should be something about the frequency of disk syncronization...
8 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: advfs (not) full

Hi Robert with ooooooooooo! ;-)

do you still have problems with space?
Have you tried the vdf command?
What does du -ksx / say?

greetings,

Michael
Victor Semaska
Frequent Advisor

Re: advfs (not) full

I had a similar problem. The solution was to use quotacheck while running in multi-user mode. Never had any problems.

The command to use would be:

# quotacheck -v /

Vic
Ralf Puchner
Honored Contributor

Re: advfs (not) full

Victor,

it seems the original poster need an instruction how to use the search function within the forum. The question was ask several times - but he has not check it.

This is the reason why he used commands like df etc. so get the size of an advfs domain.

Btw. a search within google with the same keyword leads to the same question and many answered within other forums (osf.managers etc.).... hell how complicated must be a search engine ;-)

Help() { FirstReadManual(urgently); Go_to_it;; }
Roberto Polli
Trusted Contributor

Re: advfs (not) full

Hi all,
sorry not to have been fully RTFM compliant but to be this way I would have never posted anything :-)
Anyway sure I already take a look at google and ITRC (even if I could have missed the right page). So I know about quotacheck and vdf that both gave the same output: root_domain is not full.


Prior to run quotacheck (which surely will work) I read the manual and I found the following:
---quote from man quotacheck---
It is
recommended that system filesets /, /usr, /var be checked in single-user
mode, due to possible system background activity on these filesets in
multi-user mode.
---end of quote
so I posted my question, which I re-ask clearly:
which command does EVM use to get Disk Usage?

Hoping not to have posted a lamer question,
cheers & Peace,
R.






Yong_7
Frequent Advisor

Re: advfs (not) full

Hi Roberto,

I think you've got the answer to your q2.

still curious about q1, how you got notified,

the way evm knew root was full is that by default there is a event channel connects to evm daemon. once some evm is produced, then is delivered to evm system, after that email notification is triggered to root account usually. we use /.forwarder to our desktop mailbox to keep alert about such things.

Cheers !

YJ
Roberto Polli
Trusted Contributor

Re: advfs (not) full

Hi Yong,
and thank you very much.

Is there a way to trap the evm signal?
What can I do to make evm recognize the right free space?

Peace, R.
Yong_7
Frequent Advisor
Solution

Re: advfs (not) full

Hi Roberto,

please have a look at the bottown of /etc/evmlogger.conf and "#man evmlogger" and more man evm. that's place to you may interested in.

BTW, i don't think evm mistook the root full event. what could happen is eg.

1. DB backup borrows disk space from / to shuffle around the files ;-) ( they have root access ).

2. TMPDIR points to root fs by some root users ?

what's the cause ? when you saw
"3)some days ago root_domain may have been full but that situation lasted some minutes (as df -h showed)"

looks to me, some processes/users are jumping on root fs.

Good luck !

YJ
Roberto Polli
Trusted Contributor

Re: advfs (not) full

Thanks to your help I (think I've) resolved!
I had already read the evm man thinking I should find something about advfs. But it was not the case.

Here's the whole story which I get thru evmget.
1)I took from mail the evmchannel that returns the error (evmlog)

2) issue
#evmget -A -C evmlog
and got the log of following error:
AdvFS: AdvFS domain root_domain is full
vmunix: /: file system full
binmail[343155]: Cannot write to temporary file /tmp/ma1JLVdo. No space left on device
EVM: Mark event

so it was a "binmail" fault

3) in var_domain I check that there were huge spool/mail files (their size was bigger than the free space of root_domain)
3a) I suppose that when a user logs in, binmail tried to copy the mail file in /tmp
3b) being /tmp on root_domain he failed to copy that files and gets the "disk full"
3c) being unable to copy the whole file he cancel the copy leaving root_domain free (as df command has always shown)

4) removed huge (and unuseful) spool/mail files, and 'till now I've not seen any error.

Thank you very much again!

Peace, R.






1) root_domain was not full